summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index d797ac8f..d5f052a5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,6 +12,8 @@ SHELL := sh -e
CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
CFLAGS := $(patsubst -O2,-Os,$(CFLAGS))
+ZSTD := $(shell grep '^udeb: ' /var/lib/dpkg/info/libzstd*.shlibs)
+
%:
dh ${@} --with bash-completion
@@ -19,7 +21,11 @@ override_dh_autoreconf:
dh_autoreconf ./autogen.sh
override_dh_auto_configure:
- dh_auto_configure -- --bindir=/bin --disable-convert
+ifneq (,$(ZSTD))
+ dh_auto_configure -- --bindir=/bin --disable-convert --enable-zstd
+else
+ dh_auto_configure -- --bindir=/bin --disable-convert --disable-zstd
+endif
override_dh_auto_build:
dh_auto_build -- V=1