summaryrefslogtreecommitdiff
path: root/man
diff options
context:
space:
mode:
Diffstat (limited to 'man')
-rw-r--r--man/Makefile2
-rw-r--r--man/btrfs-find-root.8.in30
2 files changed, 31 insertions, 1 deletions
diff --git a/man/Makefile b/man/Makefile
index b1d36453..3d2e3ba9 100644
--- a/man/Makefile
+++ b/man/Makefile
@@ -12,7 +12,7 @@ man8dir = $(mandir)/man8
.SUFFIXES: .in .gz
MANPAGES = mkfs.btrfs.8.gz btrfsck.8.gz btrfs-image.8.gz btrfs.8.gz \
- btrfs-debug-tree.8.gz btrfs-show-super.8.gz
+ btrfs-debug-tree.8.gz btrfs-show-super.8.gz btrfs-find-root.8.gz
INFILES = ${MANPAGES:.in=.gz}
all: $(MANPAGES)
diff --git a/man/btrfs-find-root.8.in b/man/btrfs-find-root.8.in
new file mode 100644
index 00000000..398aa411
--- /dev/null
+++ b/man/btrfs-find-root.8.in
@@ -0,0 +1,30 @@
+.TH BTRFS-FIND-ROOT 8
+.SH NAME
+btrfs-find-root \- filter to find btrfs root.
+.SH SYNOPSIS
+.B btrfs-find-root [\fIoptions\fP] \fI<dev>\fP
+.SH DESCRIPTION
+\fBbtrfs-find-root\fP is used to find the satisfied root, you can filter by root tree's objectid, generation, level.
+
+\fIOptions\fP
+.IP "\fB-g \fI<generation>\fP" 5
+filter root tree by it's original transaction id, tree root's generation in default.
+.IP "\fB-o \fI<objectid>\fP" 5
+filter root tree by it's objectid,tree root's objectid in default.
+.IP "\fB-l \fI<level>\fP" 5
+filter root tree by B-+ tree's level, level 0 in default.
+
+.SH EXIT CODE
+\fBbtrfs-find-root\fP will return 0 if no error happened.
+If any problems happened, 1 will be returned.
+
+.SH AUTHOR
+Written by Shilong Wang and Wenruo Qu.
+
+.SH COPYRIGHT
+Copyright \(co 2013 Fujitsu, Inc.
+License GPLv2: GNU GPL version 2 <http://gnu.org/licenses/gpl.html>.
+.br
+This is free software: you are free to change and redistribute it. There is NO WARRANTY, to the extent permitted by law.
+.SH SEE ALSO
+.BR mkfs.btrfs (8)