summaryrefslogtreecommitdiff
path: root/man
diff options
context:
space:
mode:
Diffstat (limited to 'man')
-rw-r--r--man/Makefile27
-rw-r--r--man/btrfsck.8.in17
2 files changed, 44 insertions, 0 deletions
diff --git a/man/Makefile b/man/Makefile
new file mode 100644
index 00000000..2665dd1d
--- /dev/null
+++ b/man/Makefile
@@ -0,0 +1,27 @@
+GZIP=gzip
+INSTALL= install
+
+prefix ?= /usr/local
+bindir = $(prefix)/bin
+mandir = $(prefix)/man
+man8dir = $(mandir)/man8
+
+MANPAGES = mkfs.btrfs.8.gz btrfsctl.8.gz btrfsck.8.gz
+
+all: $(MANPAGES)
+
+mkfs.btrfs.8.gz: mkfs.btrfs.8.in
+ $(GZIP) -n -c mkfs.btrfs.8.in > mkfs.btrfs.8.gz
+
+btrfsctl.8.gz: btrfsctl.8.in
+ $(GZIP) -n -c btrfsctl.8.in > btrfsctl.8.gz
+
+btrfsck.8.gz: btrfsck.8.in
+ $(GZIP) -n -c btrfsck.8.in > btrfsck.8.gz
+
+clean :
+ rm -f $(MANPAGES)
+
+install: $(MANPAGES)
+ $(INSTALL) -m755 -d $(DESTDIR)$(man8dir)
+ $(INSTALL) -m 644 $(MANPAGES) $(DESTDIR)$(man8dir)
diff --git a/man/btrfsck.8.in b/man/btrfsck.8.in
new file mode 100644
index 00000000..400a0820
--- /dev/null
+++ b/man/btrfsck.8.in
@@ -0,0 +1,17 @@
+.TH BTRFSCK 8
+.SH NAME
+btrfsck \- check a btrfs filesystem
+.SH SYNOPSIS
+.B btrfsck \fI device\fP
+.SH DESCRIPTION
+\fBbtrfsck\fP is used to check a btrfs filesystem.
+\fIdevice\fP is the device file where the filesystem is stored.
+.SH AVAILABILITY
+.B btrfsck
+is part of btrfs-progs. Btrfs is currently under heavy development,
+and not suitable for for any uses other than benchmarking and review.
+Please refer to the btrfs wiki http://btrfs.wiki.kernel.org for
+further details.
+.SH SEE ALSO
+.BR mkfs.btrfs (8)
+.BR btrfsctl (8)