summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorW. Trevor King <wking@drexel.edu>2010-10-22 10:06:03 -0400
committerW. Trevor King <wking@drexel.edu>2010-10-22 10:06:03 -0400
commit4ee83193a9fb8433ca4769b85b9244dc5cd9d4fa (patch)
treead395f290fb03f98077ae02d4e50062a5502d188
parentc3d3f531440102986c83bf6611f45e81c9e636b3 (diff)
Allow command line overrides for built documentation.
For example, to install without documentation, use: $ make DOC= install which overrides Makefile's default DOC definition, setting it to the empty string.
-rw-r--r--Makefile5
-rwxr-xr-xsetup.py12
2 files changed, 13 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 120963b..e4f2de9 100644
--- a/Makefile
+++ b/Makefile
@@ -37,6 +37,9 @@ XP = /usr/bin/xsltproc --nonet --param man.charmap.use.subset "0" \
PREFIX = ${HOME}
INSTALL_OPTIONS = "--prefix=${PREFIX}"
+# Select the documentation you wish to build
+DOC = sphinx man
+
# Directories with semantic meaning
DOC_DIR := doc
MAN_DIR := ${DOC_DIR}/man
@@ -58,7 +61,7 @@ build: $(LIBBE_VERSION)
python setup.py build
.PHONY: doc
-doc: sphinx man
+doc: $(DOC)
.PHONY: install
install: build doc
diff --git a/setup.py b/setup.py
index da1ebad..b7fb839 100755
--- a/setup.py
+++ b/setup.py
@@ -1,11 +1,19 @@
#!/usr/bin/env python
from distutils.core import setup
+import os.path
+
from libbe import _version
rev_id = _version.version_info["revision"]
rev_date = _version.version_info["date"]
+data_files = []
+
+man_path = os.path.join('doc', 'man', 'be.1')
+if os.path.exists(man_path):
+ data_files.append(('share/man/man1', [man_path]))
+
setup(
name='Bugs Everywhere',
version=rev_date,
@@ -20,7 +28,5 @@ setup(
'libbe.ui.util',
'libbe.util'],
scripts=['be'],
- data_files=[
- ('share/man/man1', ['doc/man/be.1']),
- ]
+ data_files=data_files,
)