summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAntoine Beaupré <anarcat@koumbit.org>2013-11-29 11:40:04 -0500
committerAntoine Beaupré <anarcat@koumbit.org>2013-11-29 12:11:23 -0500
commitfd66a9c786b5e15b914e432d5300c58972a07495 (patch)
tree253dd12367658b63882ac09208fe6eb12da6f82a /Makefile
parent0177099ff165e38367da403374df698341e05aae (diff)
use upstream workaround for build-time git repo dependency
instead of generating the version file during the build using git, we generate it statically using the debian metadata
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index fe6ccba..c7ee58e 100644
--- a/Makefile
+++ b/Makefile
@@ -55,7 +55,7 @@ MAN_DIR := ${DOC_DIR}/man
MANPAGES = be.1
LIBBE_VERSION := libbe/_version.py
-GENERATED_FILES := build
+GENERATED_FILES := build $(LIBBE_VERSION)
MANPAGE_FILES = $(patsubst %,${MAN_DIR}/%,${MANPAGES})
MANPAGE_HTML = $(patsubst %,${MAN_DIR}/%.html,${MANPAGES})
@@ -86,6 +86,7 @@ clean:
$(MAKE) -C ${DOC_DIR} clean
+.PHONY: libbe/_version.py
libbe/_version.py:
echo "# -*- coding: utf-8 -*-" > $@
git log -1 --encoding=UTF-8 --date=short --pretty='format:"Autogenerated by make libbe/_version.py"%nversion_info = {%n "date":"%cd",%n "revision":"%H",%n "committer":"%cn"}%n' >> $@