summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2018-02-09 17:15:47 +0100
committerDidier Raboud <odyx@debian.org>2018-02-09 17:07:57 +0100
commit9b039767df21eecb2fd87f2906224a4bb7ff70f8 (patch)
treef169a8043bb221978754d5a6513fad3f69103812
parentee18550dc32e4bf9a44b716929b6b406ab41486d (diff)
Inherit CFLAGS and LDFLAGS from the environment. Also use CPPFLAGS in the building command
Last-Update: 2014-04-13
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 727aa49..5fc6601 100644
--- a/Makefile
+++ b/Makefile
@@ -10,8 +10,8 @@
# Important compiler and linker options
CC=gcc
LD=gcc
-CFLAGS=-g -O2
-LDFLAGS=-g -O2
+CFLAGS+=-g -O2
+LDFLAGS+=-g -O2
# Required libraries
LDLIBS=
@@ -23,7 +23,7 @@ MOD=$(SRC:.c=.o)
# Standard production rule
.c.o:
- $(CC) $(CFLAGS) -c $<
+ $(CC) $(CPPFLAGS) $(CFLAGS) -c $<
# make all
all: c2050