summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephane Glondu <steph@glondu.net>2011-08-02 15:34:21 +0200
committerStéphane Glondu <glondu@debian.org>2019-09-01 20:45:55 +0200
commita1f6711ae0bda7a7505587038b6d1cfd6afbdc92 (patch)
treec4e4eaa3052cbd7537efb4eb8a144c9e077c7610
parentc7504d0a2669069a0406ff1c5f146572b010ff5a (diff)
Fix Makefile to avoid recompiling files in /usr
The "-I /path/to/lablgtk2" option should not be used when calling ocamldep, otherwise files there are considered as possible targets by the build system. Signed-off-by: Stephane Glondu <steph@glondu.net> Gbp-Pq: Name 0002-Fix-Makefile-to-avoid-recompiling-files-in-usr.patch
-rw-r--r--src/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile b/src/Makefile
index 46a62f6..c9c64b7 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -117,7 +117,7 @@ clean :
.depend : $(wildcard *.ml *.mli)
@echo "making deps"
- @$(OCAMLDEP) $(if $(LABLGTKDIR),-I $(LABLGTKDIR)) $^ > $@
+ @$(OCAMLDEP) $^ > $@
-include .depend
-include .depend_c