From 90ee23cb84d7a394d7fe97f5c153079c6a06c351 Mon Sep 17 00:00:00 2001 From: Stephane Glondu Date: Mon, 18 May 2015 17:29:08 +0200 Subject: Imported Upstream version 2.04 --- .depend | 126 +++++++++++++++++---------------- CHANGES | 8 +++ Makefile.in | 15 ++-- config.status | 4 +- doc/Calendar.Precise.html | 63 +++++++++-------- doc/Calendar.html | 13 ++-- doc/Calendar_builder.Make.html | 65 ++++++++--------- doc/Calendar_builder.Make_Precise.html | 65 ++++++++--------- doc/Calendar_builder.html | 13 ++-- doc/Calendar_sig.S.Date.html | 73 +++++++++---------- doc/Calendar_sig.S.Period.html | 21 +++--- doc/Calendar_sig.S.Time.html | 33 ++++----- doc/Calendar_sig.S.html | 63 +++++++++-------- doc/Calendar_sig.html | 13 ++-- doc/Date.html | 13 ++-- doc/Date_sig.S.Period.html | 15 ++-- doc/Date_sig.S.html | 71 ++++++++++--------- doc/Date_sig.html | 13 ++-- doc/Fcalendar.Precise.html | 63 +++++++++-------- doc/Fcalendar.html | 13 ++-- doc/Ftime.html | 13 ++-- doc/Period.S.html | 13 ++-- doc/Period.html | 13 ++-- doc/Printer.Calendar.html | 15 ++-- doc/Printer.CalendarPrinter.html | 15 ++-- doc/Printer.Date.html | 13 ++-- doc/Printer.DatePrinter.html | 15 ++-- doc/Printer.Fcalendar.html | 13 ++-- doc/Printer.Ftime.html | 15 ++-- doc/Printer.Precise_Calendar.html | 15 ++-- doc/Printer.Precise_Fcalendar.html | 15 ++-- doc/Printer.S.html | 11 +-- doc/Printer.Time.html | 15 ++-- doc/Printer.TimePrinter.html | 15 ++-- doc/Printer.html | 25 +++---- doc/Time.html | 13 ++-- doc/Time_Zone.html | 21 +++--- doc/Time_sig.S.Period.html | 17 ++--- doc/Time_sig.S.Second.html | 11 +-- doc/Time_sig.S.html | 31 ++++---- doc/Time_sig.Second.html | 11 +-- doc/Time_sig.html | 13 ++-- doc/Utils.Comparable.html | 9 +-- doc/Utils.Float.html | 11 +-- doc/Utils.Int.html | 11 +-- doc/Utils.html | 11 +-- doc/Version.html | 11 +-- doc/index.html | 42 +++++------ doc/index_attributes.html | 6 +- doc/index_class_types.html | 6 +- doc/index_classes.html | 6 +- doc/index_exceptions.html | 6 +- doc/index_methods.html | 6 +- doc/index_module_types.html | 6 +- doc/index_modules.html | 12 ++-- doc/index_types.html | 6 +- doc/index_values.html | 14 ++-- doc/style.css | 37 ++++++---- src/printer.ml | 49 +++++++++---- tests/gen_test.ml | 2 +- tests/gen_test.mli | 2 +- tests/test.ml | 2 +- tests/test_fcalendar.ml | 2 +- tests/test_fpcalendar.ml | 2 +- tests/test_ftime.ml | 2 +- tests/test_pcalendar.ml | 2 +- tests/test_printer.ml | 8 ++- tests/test_time.ml | 2 +- tests/test_timezone.ml | 2 +- utils/example.ml.3 | 2 +- utils/example.ml.4 | 2 +- 71 files changed, 747 insertions(+), 633 deletions(-) diff --git a/.depend b/.depend index d537c94..2b491b9 100644 --- a/.depend +++ b/.depend @@ -1,90 +1,94 @@ -src/calendar.cmo: src/time.cmi src/date.cmi src/calendar_builder.cmi \ +src/calendar.cmo : src/time.cmi src/date.cmi src/calendar_builder.cmi \ src/calendar.cmi -src/calendar.cmx: src/time.cmx src/date.cmx src/calendar_builder.cmx \ +src/calendar.cmx : src/time.cmx src/date.cmx src/calendar_builder.cmx \ src/calendar.cmi -src/calendar_builder.cmo: src/utils.cmi src/time_sig.cmi src/time_Zone.cmi \ +src/calendar_builder.cmo : src/utils.cmi src/time_sig.cmi src/time_Zone.cmi \ src/period.cmi src/date_sig.cmi src/calendar_builder.cmi -src/calendar_builder.cmx: src/utils.cmx src/time_sig.cmi src/time_Zone.cmx \ +src/calendar_builder.cmx : src/utils.cmx src/time_sig.cmi src/time_Zone.cmx \ src/period.cmi src/date_sig.cmi src/calendar_builder.cmi -src/date.cmo: src/utils.cmi src/time_Zone.cmi src/period.cmi src/date.cmi -src/date.cmx: src/utils.cmx src/time_Zone.cmx src/period.cmi src/date.cmi -src/fcalendar.cmo: src/ftime.cmi src/date.cmi src/calendar_builder.cmi \ +src/date.cmo : src/utils.cmi src/time_Zone.cmi src/period.cmi src/date.cmi +src/date.cmx : src/utils.cmx src/time_Zone.cmx src/period.cmi src/date.cmi +src/fcalendar.cmo : src/ftime.cmi src/date.cmi src/calendar_builder.cmi \ src/fcalendar.cmi -src/fcalendar.cmx: src/ftime.cmx src/date.cmx src/calendar_builder.cmx \ +src/fcalendar.cmx : src/ftime.cmx src/date.cmx src/calendar_builder.cmx \ src/fcalendar.cmi -src/ftime.cmo: src/utils.cmi src/time_Zone.cmi src/period.cmi src/ftime.cmi -src/ftime.cmx: src/utils.cmx src/time_Zone.cmx src/period.cmi src/ftime.cmi -src/printer.cmo: src/time_Zone.cmi src/time.cmi src/period.cmi src/ftime.cmi \ - src/fcalendar.cmi src/date.cmi src/calendar.cmi src/printer.cmi -src/printer.cmx: src/time_Zone.cmx src/time.cmx src/period.cmi src/ftime.cmx \ - src/fcalendar.cmx src/date.cmx src/calendar.cmx src/printer.cmi -src/time.cmo: src/utils.cmi src/time_Zone.cmi src/period.cmi src/time.cmi -src/time.cmx: src/utils.cmx src/time_Zone.cmx src/period.cmi src/time.cmi -src/time_Zone.cmo: src/time_Zone.cmi -src/time_Zone.cmx: src/time_Zone.cmi -src/utils.cmo: src/utils.cmi -src/utils.cmx: src/utils.cmi -src/version.cmo: src/version.cmi -src/version.cmx: src/version.cmi -src/calendar.cmi: src/time.cmi src/date.cmi src/calendar_sig.cmi -src/calendar_builder.cmi: src/time_sig.cmi src/date_sig.cmi \ +src/ftime.cmo : src/utils.cmi src/time_Zone.cmi src/period.cmi src/ftime.cmi +src/ftime.cmx : src/utils.cmx src/time_Zone.cmx src/period.cmi src/ftime.cmi +src/printer.cmo : src/utils.cmi src/time_Zone.cmi src/time.cmi \ + src/period.cmi src/ftime.cmi src/fcalendar.cmi src/date.cmi \ + src/calendar.cmi src/printer.cmi +src/printer.cmx : src/utils.cmx src/time_Zone.cmx src/time.cmx \ + src/period.cmi src/ftime.cmx src/fcalendar.cmx src/date.cmx \ + src/calendar.cmx src/printer.cmi +src/time.cmo : src/utils.cmi src/time_Zone.cmi src/period.cmi src/time.cmi +src/time.cmx : src/utils.cmx src/time_Zone.cmx src/period.cmi src/time.cmi +src/time_Zone.cmo : src/time_Zone.cmi +src/time_Zone.cmx : src/time_Zone.cmi +src/utils.cmo : src/utils.cmi +src/utils.cmx : src/utils.cmi +src/version.cmo : src/version.cmi +src/version.cmx : src/version.cmi +src/calendar.cmi : src/time.cmi src/date.cmi src/calendar_sig.cmi +src/calendar_builder.cmi : src/time_sig.cmi src/date_sig.cmi \ src/calendar_sig.cmi -src/calendar_sig.cmi: src/time_sig.cmi src/time_Zone.cmi src/period.cmi \ +src/calendar_sig.cmi : src/time_sig.cmi src/time_Zone.cmi src/period.cmi \ src/date_sig.cmi -src/date.cmi: src/date_sig.cmi -src/date_sig.cmi: src/period.cmi -src/fcalendar.cmi: src/ftime.cmi src/date.cmi src/calendar_sig.cmi -src/ftime.cmi: src/time_sig.cmi -src/period.cmi: -src/printer.cmi: src/time.cmi src/ftime.cmi src/fcalendar.cmi src/date.cmi \ +src/date.cmi : src/date_sig.cmi +src/date_sig.cmi : src/period.cmi +src/fcalendar.cmi : src/ftime.cmi src/date.cmi src/calendar_sig.cmi +src/ftime.cmi : src/time_sig.cmi +src/period.cmi : +src/printer.cmi : src/time.cmi src/ftime.cmi src/fcalendar.cmi src/date.cmi \ src/calendar.cmi -src/time.cmi: src/time_sig.cmi -src/time_Zone.cmi: -src/time_sig.cmi: src/time_Zone.cmi src/period.cmi -src/utils.cmi: -src/version.cmi: -tests/gen_test.cmo: tests/gen_test.cmi -tests/gen_test.cmx: tests/gen_test.cmi -tests/test.cmo: tests/test_timezone.cmo tests/test_time.cmo \ +src/time.cmi : src/time_sig.cmi +src/time_Zone.cmi : +src/time_sig.cmi : src/time_Zone.cmi src/period.cmi +src/utils.cmi : +src/version.cmi : +tests/gen_test.cmo : tests/gen_test.cmi +tests/gen_test.cmx : tests/gen_test.cmi +tests/test.cmo : tests/test_timezone.cmo tests/test_time.cmo \ tests/test_printer.cmo tests/test_pcalendar.cmo tests/test_ftime.cmo \ tests/test_fpcalendar.cmo tests/test_fcalendar.cmo tests/test_date.cmo \ tests/test_calendar.cmo -tests/test.cmx: tests/test_timezone.cmx tests/test_time.cmx \ +tests/test.cmx : tests/test_timezone.cmx tests/test_time.cmx \ tests/test_printer.cmx tests/test_pcalendar.cmx tests/test_ftime.cmx \ tests/test_fpcalendar.cmx tests/test_fcalendar.cmx tests/test_date.cmx \ tests/test_calendar.cmx -tests/test_calendar.cmo: src/utils.cmi src/time_Zone.cmi src/time.cmi \ +tests/test_calendar.cmo : src/utils.cmi src/time_Zone.cmi src/time.cmi \ src/period.cmi tests/gen_test.cmi src/date.cmi src/calendar.cmi -tests/test_calendar.cmx: src/utils.cmx src/time_Zone.cmx src/time.cmx \ +tests/test_calendar.cmx : src/utils.cmx src/time_Zone.cmx src/time.cmx \ src/period.cmi tests/gen_test.cmx src/date.cmx src/calendar.cmx -tests/test_date.cmo: src/time_Zone.cmi src/period.cmi tests/gen_test.cmi \ +tests/test_date.cmo : src/time_Zone.cmi src/period.cmi tests/gen_test.cmi \ src/date.cmi -tests/test_date.cmx: src/time_Zone.cmx src/period.cmi tests/gen_test.cmx \ +tests/test_date.cmx : src/time_Zone.cmx src/period.cmi tests/gen_test.cmx \ src/date.cmx -tests/test_fcalendar.cmo: src/utils.cmi src/time_Zone.cmi src/time.cmi \ +tests/test_fcalendar.cmo : src/utils.cmi src/time_Zone.cmi src/time.cmi \ src/period.cmi tests/gen_test.cmi src/fcalendar.cmi src/date.cmi -tests/test_fcalendar.cmx: src/utils.cmx src/time_Zone.cmx src/time.cmx \ +tests/test_fcalendar.cmx : src/utils.cmx src/time_Zone.cmx src/time.cmx \ src/period.cmi tests/gen_test.cmx src/fcalendar.cmx src/date.cmx -tests/test_fpcalendar.cmo: src/utils.cmi src/time_Zone.cmi src/time.cmi \ +tests/test_fpcalendar.cmo : src/utils.cmi src/time_Zone.cmi src/time.cmi \ src/period.cmi tests/gen_test.cmi src/fcalendar.cmi src/date.cmi -tests/test_fpcalendar.cmx: src/utils.cmx src/time_Zone.cmx src/time.cmx \ +tests/test_fpcalendar.cmx : src/utils.cmx src/time_Zone.cmx src/time.cmx \ src/period.cmi tests/gen_test.cmx src/fcalendar.cmx src/date.cmx -tests/test_ftime.cmo: src/utils.cmi src/time_Zone.cmi src/period.cmi \ +tests/test_ftime.cmo : src/utils.cmi src/time_Zone.cmi src/period.cmi \ tests/gen_test.cmi src/ftime.cmi -tests/test_ftime.cmx: src/utils.cmx src/time_Zone.cmx src/period.cmi \ +tests/test_ftime.cmx : src/utils.cmx src/time_Zone.cmx src/period.cmi \ tests/gen_test.cmx src/ftime.cmx -tests/test_pcalendar.cmo: src/utils.cmi src/time_Zone.cmi src/time.cmi \ +tests/test_pcalendar.cmo : src/utils.cmi src/time_Zone.cmi src/time.cmi \ src/period.cmi tests/gen_test.cmi src/date.cmi src/calendar.cmi -tests/test_pcalendar.cmx: src/utils.cmx src/time_Zone.cmx src/time.cmx \ +tests/test_pcalendar.cmx : src/utils.cmx src/time_Zone.cmx src/time.cmx \ src/period.cmi tests/gen_test.cmx src/date.cmx src/calendar.cmx -tests/test_printer.cmo: src/time_Zone.cmi src/time.cmi src/printer.cmi \ - tests/gen_test.cmi src/date.cmi src/calendar.cmi -tests/test_printer.cmx: src/time_Zone.cmx src/time.cmx src/printer.cmx \ - tests/gen_test.cmx src/date.cmx src/calendar.cmx -tests/test_time.cmo: src/utils.cmi src/time_Zone.cmi src/time.cmi \ +tests/test_printer.cmo : src/utils.cmi src/time_Zone.cmi src/time.cmi \ + src/printer.cmi tests/gen_test.cmi src/ftime.cmi src/date.cmi \ + src/calendar.cmi +tests/test_printer.cmx : src/utils.cmx src/time_Zone.cmx src/time.cmx \ + src/printer.cmx tests/gen_test.cmx src/ftime.cmx src/date.cmx \ + src/calendar.cmx +tests/test_time.cmo : src/utils.cmi src/time_Zone.cmi src/time.cmi \ src/period.cmi tests/gen_test.cmi -tests/test_time.cmx: src/utils.cmx src/time_Zone.cmx src/time.cmx \ +tests/test_time.cmx : src/utils.cmx src/time_Zone.cmx src/time.cmx \ src/period.cmi tests/gen_test.cmx -tests/test_timezone.cmo: src/time_Zone.cmi tests/gen_test.cmi -tests/test_timezone.cmx: src/time_Zone.cmx tests/gen_test.cmx -tests/gen_test.cmi: +tests/test_timezone.cmo : src/time_Zone.cmi tests/gen_test.cmi +tests/test_timezone.cmx : src/time_Zone.cmx tests/gen_test.cmx +tests/gen_test.cmi : diff --git a/CHANGES b/CHANGES index a9fc2ef..374cf24 100644 --- a/CHANGES +++ b/CHANGES @@ -6,6 +6,14 @@ Mark "*": bug fixed. Mark "!": change that can break compatibility with older version of the library =============================================================================== +version 2.04, 2014-10-29: +=========================== +* [Makefile] Fix minor issues with ocamlfind and 'make install' (from + Christopher Zimmermann). +o [Printer] In function from_fstring of sub-module Ftime, Fcalendar, and + Precise_Fcalendar, the number of seconds corresponding to %S may be a floating + point number (from Christophe Troestler' suggestion). + version 2.03.2, 2012-06-26: =========================== o [Compilation] Compatibility with OCaml 4 diff --git a/Makefile.in b/Makefile.in index 14c9a63..9eb3026 100644 --- a/Makefile.in +++ b/Makefile.in @@ -45,7 +45,7 @@ HAS_NATDYNLINK=@HAS_NATDYNLINK@ NAME = calendar NAMELIB = calendarLib -VERSION = 2.03.2 +VERSION = 2.04 LIBDIR = target @@ -120,7 +120,8 @@ src/version.ml: Makefile echo "let date = \"`date`\"" >> $@ META: Makefile - echo "description = \"$(NAME) library\"" > $@ + echo "name = \"$(NAME)\"" > $@ + echo "description = \"$(NAME) library\"" >> $@ echo "version = \"$(VERSION)\"" >> $@ echo "archive(byte) = \"$(NAMELIB).cma\"" >> $@ echo "archive(native) = \"$(NAMELIB).cmxa\"" >> $@ @@ -177,10 +178,10 @@ $(NAMELIB).ps: $(SRC) $(CAMLWEB) --ps -o $@ $^ ifeq ($(CAMLMAJORVERSION),3) -utils/example.ml: utils/example.ml.3 +utils/example.ml: utils/example.ml.3 Makefile cp $< $@ else -utils/example.ml: utils/example.ml.4 +utils/example.ml: utils/example.ml.4 Makefile cp $< $@ endif @@ -209,7 +210,7 @@ headers: install: $(LIBS) $(CLIBS) META @if [ "`sed -n -e 's/version = "\([0-9.+dev]*\)"/\1/p' META`" = "$(VERSION)" ]; then \ (if test -d `ocamlfind install -help | grep destdir | sed -e "s/.*default: \(.*\))/\1/"`/$(NAME); then $(MAKE) uninstall; fi;\ - $(CAMLFIND) install $(NAME) target/*.cm[ioxa] target/*.cmx[as] $(MLI) $(CLIBS) META); \ + $(CAMLFIND) install $(NAME) target/*.cm* $(MLI) $(CLIBS) META); \ else \ (echo; echo "Not the good version. Please, do :"; \ echo " make clean && make"; \ @@ -222,7 +223,7 @@ uninstall: # Exporting ########### -EXPORT_DIR= $$HOME/WWW/prog/$(NAME) +EXPORT_DIR= $$HOME/EXPORT/$(NAME) TMP_DIR = $$HOME/tmp ROOT= $$HOME/DEV/calendar @@ -234,6 +235,7 @@ export: doc rm -rf $(TMP_DIR)/trunk (cd $(ROOT)/tags; svn commit -m "v $(VERSION)") rm -rf $(EXPORT_DIR)/doc + mkdir -p $(EXPORT_DIR) cp -rf CHANGES doc $(EXPORT_DIR) cp -rf $(ROOT)/tags/v$(VERSION) $(TMP_DIR)/$(NAME)-$(VERSION) cp -rf .depend configure config.status doc $(TMP_DIR)/$(NAME)-$(VERSION) @@ -271,6 +273,7 @@ clean: for i in . src tests utils; do \ rm -f $$i/*~ $$i/\#* $$i/*.cm[iox] $$i/*.*a $$i/*$(OBJ_EXT) $$i/a.out; \ done + rm -f utils/example.ml dist-clean distclean: clean rm -rf $(NAME).ps.gz doc $(LIBDIR) diff --git a/config.status b/config.status index a63f768..709641a 100755 --- a/config.status +++ b/config.status @@ -598,8 +598,8 @@ S["LIBOBJS"]="" S["HAS_NATDYNLINK"]="yes" S["LIBEXT"]=".a" S["OBJEXT"]=".o" -S["OCAMLLIB"]="/localhome/julien/godi/lib/ocaml/std-lib" -S["OCAMLMAJOR"]="3" +S["OCAMLLIB"]="/localhome/julien/.opam/4.00.1/lib/ocaml" +S["OCAMLMAJOR"]="4" S["OCAMLBEST"]="opt" S["OCAMLDOT"]="ocamldot" S["OCAMLWC"]="ocamlwc" diff --git a/doc/Calendar.Precise.html b/doc/Calendar.Precise.html index b0077b0..ec57f49 100644 --- a/doc/Calendar.Precise.html +++ b/doc/Calendar.Precise.html @@ -34,15 +34,16 @@ Calendar.Precise -
-

Constructors


+

Constructors


val make : int -> int -> int -> int -> int -> second -> t
make year month day hour minute second makes the calendar "year-month-day; hour-minute-second".
@@ -239,7 +240,7 @@ Return the Modified Julian day. It is Julian day - 2 400 000.5 (more precise than Date.from_mjd).

-

Conversions


+

Conversions



Those functions have the same behaviour as those defined in Time_sig.S.
@@ -253,7 +254,7 @@ Those functions have the same behaviour as those defined in See also Time_sig.S.from_gmt

-

Getters


+

Getters



Those functions have the same behavious as those defined in Date_sig.S.
@@ -294,7 +295,7 @@ Those functions have the same behavious as those defined in See also Time_sig.S.second

-

Calendars are comparable


+

Calendars are comparable


val equal : t -> t -> bool
Equality function between two calendars.
See also Utils.Comparable.equal.
@@ -330,7 +331,7 @@ Those functions have the same behavious as those defined in See also Time_sig.S.is_am

-

Coercions


+

Coercions


val to_unixtm : t -> Unix.tm
Convert a calendar into the unix.tm type. The field isdst is always false. More precise than @@ -368,12 +369,12 @@ Convert a calendar to a time. Date part of the calendar is ignored.
Since 1.03

-

Period


+

Period


module Period: sig .. end
A period is the number of seconds between two calendars.

-

Arithmetic operations on calendars and periods


+

Arithmetic operations on calendars and periods



Those functions have the same behavious as those defined in Date_sig.S.
diff --git a/doc/Calendar.html b/doc/Calendar.html index 0b7edd7..0eb466b 100644 --- a/doc/Calendar.html +++ b/doc/Calendar.html @@ -28,18 +28,19 @@ Calendar -
-

Calendars are comparable


+

Calendars are comparable


val equal : t -> t -> bool
Equality function between two calendars.
See also Utils.Comparable.equal.
@@ -354,7 +355,7 @@ Those functions have the same behavious as those defined in See also Time_sig.S.is_am

-

Coercions


+

Coercions


val to_unixtm : t -> Unix.tm
Convert a calendar into the unix.tm type. The field isdst is always false. More precise than @@ -392,12 +393,12 @@ Convert a calendar to a time. Date part of the calendar is ignored.
Since 1.03

-

Period


+

Period


module Period: sig .. end
A period is the number of seconds between two calendars.

-

Arithmetic operations on calendars and periods


+

Arithmetic operations on calendars and periods



Those functions have the same behavious as those defined in Date_sig.S.
diff --git a/doc/Calendar_builder.Make_Precise.html b/doc/Calendar_builder.Make_Precise.html index 4b2e6ea..451c387 100644 --- a/doc/Calendar_builder.Make_Precise.html +++ b/doc/Calendar_builder.Make_Precise.html @@ -35,14 +35,15 @@ Calendar_builder.Make_Precise -
-

Constructors


+

Constructors


val make : int -> int -> int -> int -> int -> second -> t
make year month day hour minute second makes the calendar "year-month-day; hour-minute-second".
@@ -261,7 +262,7 @@ Return the Modified Julian day. It is Julian day - 2 400 000.5 (more precise than Date.from_mjd).

-

Conversions


+

Conversions



Those functions have the same behaviour as those defined in Time_sig.S.
@@ -275,7 +276,7 @@ Those functions have the same behaviour as those defined in See also Time_sig.S.from_gmt

-

Getters


+

Getters



Those functions have the same behavious as those defined in Date_sig.S.
@@ -316,7 +317,7 @@ Those functions have the same behavious as those defined in See also Time_sig.S.second

-

Calendars are comparable


+

Calendars are comparable


val equal : t -> t -> bool
Equality function between two calendars.
See also Utils.Comparable.equal.
@@ -352,7 +353,7 @@ Those functions have the same behavious as those defined in See also Time_sig.S.is_am

-

Coercions


+

Coercions


val to_unixtm : t -> Unix.tm
Convert a calendar into the unix.tm type. The field isdst is always false. More precise than @@ -390,12 +391,12 @@ Convert a calendar to a time. Date part of the calendar is ignored.
Since 1.03

-

Period


+

Period


module Period: sig .. end
A period is the number of seconds between two calendars.

-

Arithmetic operations on calendars and periods


+

Arithmetic operations on calendars and periods



Those functions have the same behavious as those defined in Date_sig.S.
diff --git a/doc/Calendar_builder.html b/doc/Calendar_builder.html index acaf993..f67bccf 100644 --- a/doc/Calendar_builder.html +++ b/doc/Calendar_builder.html @@ -28,14 +28,15 @@ Calendar_builder -
-

Periods are comparable


+

Periods are comparable


val equal : [< Period.date_field ] period ->
[< Period.date_field ] period -> bool
Equality function between two periods.
Since 1.09.0
@@ -79,7 +80,7 @@ Hash function for periods.
See also Utils.Comparable.hash

-

Constructors


+

Constructors


val make : int ->
int -> int -> int -> int -> Calendar_sig.S.second -> t
make year month day hour minute second makes a period of the specified length.
@@ -116,7 +117,7 @@ Those functions have the same behavious as those defined in See also Time_sig.S.Period.second

-

Coercions


+

Coercions


val from_date : ([< Period.date_field ] as 'a) Date.Period.period ->
'a period
Convert a date period to a calendar period.
diff --git a/doc/Calendar_sig.S.Time.html b/doc/Calendar_sig.S.Time.html index 9d746cb..070edc2 100644 --- a/doc/Calendar_sig.S.Time.html +++ b/doc/Calendar_sig.S.Time.html @@ -38,17 +38,18 @@ Calendar_sig.S.Time -
-

Conversions


+

Conversions


val convert : t -> Time_Zone.t -> Time_Zone.t -> t
convert t t1 t2 converts the time t expressed in the time zone t1 to the same time expressed in the time zone t2.
@@ -115,7 +116,7 @@ The current time based on Time_Zone (make (-73) 0 0) returns the time 23-0-0 and (-4).

-

Getters


+

Getters


val hour : t -> int
Hour.
Example: hour (make 20 0 0) returns 20.
@@ -143,7 +144,7 @@ Number of hours of a time. The resulting fractional part represents Example: to_hours (make 1 3 0) returns 1 + 0.05 = 1.05.

-

Times are comparable


+

Times are comparable


val equal : t -> t -> bool
Equality function between two times.
Since 1.09.0
@@ -159,7 +160,7 @@ Hash function for times.
See also Utils.Comparable.hash.

-

Boolean operations on times


+

Boolean operations on times


val is_pm : t -> bool
Return true is the time is before midday in the current time zone; false otherwise.
@@ -173,7 +174,7 @@ Return true is the time i true.

-

Coercions


+

Coercions


val from_seconds : second -> t
Inverse of to_seconds.
@@ -184,12 +185,12 @@ Inverse of to_minutes.
Inverse of to_hours.

-

Period


+

Period


module Period: sig .. end
A period is the number of seconds between two times.

-

Arithmetic operations on times and periods


+

Arithmetic operations on times and periods


val add : t ->
[< Period.date_field ] Period.period -> t
app t p returns t + p.
Example: add (make 20 0 0) (Period.minute 70) returns the time diff --git a/doc/Calendar_sig.S.html b/doc/Calendar_sig.S.html index 2c99dc1..b13f721 100644 --- a/doc/Calendar_sig.S.html +++ b/doc/Calendar_sig.S.html @@ -34,15 +34,16 @@ Calendar_sig.S -
-

Constructors


+

Constructors


val make : int -> int -> int -> int -> int -> second -> t
make year month day hour minute second makes the calendar "year-month-day; hour-minute-second".
@@ -239,7 +240,7 @@ Return the Modified Julian day. It is Julian day - 2 400 000.5 (more precise than Date.from_mjd).

-

Conversions


+

Conversions



Those functions have the same behaviour as those defined in Time_sig.S.
@@ -253,7 +254,7 @@ Those functions have the same behaviour as those defined in See also Time_sig.S.from_gmt

-

Getters


+

Getters



Those functions have the same behavious as those defined in Date_sig.S.
@@ -294,7 +295,7 @@ Those functions have the same behavious as those defined in See also Time_sig.S.second

-

Calendars are comparable


+

Calendars are comparable


val equal : t -> t -> bool
Equality function between two calendars.
See also Utils.Comparable.equal.
@@ -330,7 +331,7 @@ Those functions have the same behavious as those defined in See also Time_sig.S.is_am

-

Coercions


+

Coercions


val to_unixtm : t -> Unix.tm
Convert a calendar into the unix.tm type. The field isdst is always false. More precise than @@ -368,12 +369,12 @@ Convert a calendar to a time. Date part of the calendar is ignored.
Since 1.03

-

Period


+

Period


module Period: sig .. end
A period is the number of seconds between two calendars.

-

Arithmetic operations on calendars and periods


+

Arithmetic operations on calendars and periods



Those functions have the same behavious as those defined in Date_sig.S.
diff --git a/doc/Calendar_sig.html b/doc/Calendar_sig.html index e84f697..7447f4f 100644 --- a/doc/Calendar_sig.html +++ b/doc/Calendar_sig.html @@ -28,13 +28,13 @@ Calendar_sig -