summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c9312c3..9ccf0bf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,6 +3,8 @@
-include /usr/share/dpkg/buildtools.mk
export CC
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
BASE=debian/chrony
@@ -33,3 +35,11 @@ override_dh_install:
override_dh_fixperms:
dh_fixperms -X usr/share/chrony/chrony.keys
+
+override_dh_installinit:
+ dh_installinit
+# Disable the system call filter on architectures mentioned below
+# due to missing support in libseccomp and/or in the Linux kernel.
+ifneq (,$(filter $(DEB_HOST_ARCH), alpha ia64 m68k riscv64 sh4 sparc64))
+ sed -i '/DAEMON_OPTS=/s/"-F -1"/""/' $(BASE)/etc/default/chrony
+endif