summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharles Comstock <dgtized@gmail.com>2013-10-24 20:36:25 -0500
committerCharles Comstock <dgtized@gmail.com>2013-10-24 20:36:25 -0500
commit375977e73347c2eeb0d5199ddf16c1125652eead (patch)
tree5ef5350851c7137e943ad9e9a67ad8b01ab43162
parent4e36f6fc9306b83c69caf98b0df4c49c65b2e6ed (diff)
Strip remainder of require line to avoid comments
If you don't match the remainder of the line it only transforms the section that matches, so; cider.el: (require 'cider-foo) ;comment Becomes the following line in .depends cider.el: cider-foo.elc ; comment When we want it to be cider.el: cider-foo.elc
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 5cd5f39e..91d50316 100644
--- a/Makefile
+++ b/Makefile
@@ -10,7 +10,7 @@ OBJECTS = $(ELS:.el=.elc)
@echo Compute dependencies
@rm -f .depend
@for f in $(ELS); do \
- sed -n "s/(require '\(\(cider\|nrepl\)-.*\))/$${f}c: \1.elc/p" $$f >> .depend;\
+ sed -n "s/(require '\(\(cider\|nrepl\)-.*\)).*$$/$${f}c: \1.elc/p" $$f >> .depend;\
done
-include .depend