summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitalie Spinu <spinuvit@gmail.com>2017-08-03 19:17:47 +0200
committerBozhidar Batsov <bozhidar.batsov@gmail.com>2017-08-05 16:45:50 +0300
commitee3f3b2997b3af9e0e5fe6a8d25c611defcc8bbc (patch)
tree6e4b23e5e78511edc643f3c225e9a3b71e6e8ef0
parentb88daf2455a3e4dba3ba48e7101d03af659f2c4a (diff)
Make elpa target understand emacs versions
... and add elpa dependency to test-checks target
-rw-r--r--.gitignore2
-rw-r--r--Makefile9
2 files changed, 7 insertions, 4 deletions
diff --git a/.gitignore b/.gitignore
index 570b10ba..72f1bb16 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,7 +3,7 @@
*.\#*
*.elc
.cask
-elpa
+elpa*
.depend
TAGS
.DS_STORE
diff --git a/Makefile b/Makefile
index 4a82c725..c16a2795 100644
--- a/Makefile
+++ b/Makefile
@@ -16,18 +16,21 @@ OBJECTS = $(ELS:.el=.elc)
-include .depend
-elpa:
+elpa-$(EMACS):
$(CASK) install
$(CASK) update
touch $@
+.PHONY: elpa
+elpa: elpa-$(EMACS)
+
.PHONY: build version
build : elpa $(OBJECTS)
version:
$(EMACS) --version
-test-checks : version
+test-checks : version elpa
$(CASK) exec $(EMACS) --no-site-file --no-site-lisp --batch \
-l test/scripts/cider-checks.el ./
@@ -46,7 +49,7 @@ clean :
.PHONY: elpaclean
elpaclean : clean
- rm -f elpa
+ rm -f elpa*
rm -rf .cask # Clean packages installed for development
%.elc : %.el