summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorVignesh Sarma K <vignesh.sarma@gmail.com>2015-08-28 15:03:09 +0530
committerVignesh Sarma K <vignesh.sarma@gmail.com>2015-09-19 17:13:04 +0530
commit7140c792d6072c7b71f1c96e194af535d334575f (patch)
tree023ba3bc105173e75aa7773476898163c8f0ea4e /Makefile
parent48d7dbf6f17741af36f0a99712fc556f92a06a12 (diff)
Run tests against 4 different versions of emacs
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 66a0c6bb..ee8ac236 100644
--- a/Makefile
+++ b/Makefile
@@ -21,11 +21,13 @@ elpa:
$(CASK) update
touch $@
-.PHONY: build
+.PHONY: build version
build : elpa $(OBJECTS)
-.PHONY: test
-test : build
+version:
+ $(EMACS) --version
+
+test : version build
$(CASK) exec $(EMACS) --no-site-file --no-site-lisp --batch \
$(EMACSFLAGS) \
-l test/run-tests