summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorArtur Malabarba <bruce.connor.am@gmail.com>2015-09-25 14:33:24 +0100
committerArtur Malabarba <bruce.connor.am@gmail.com>2015-09-25 14:33:24 +0100
commit16abaf45febe5f391cff053e955278374553d279 (patch)
tree4c245377a138adeb91c321b62fa7d7dbdb792270 /Makefile
parent9461c4a300fe713d0319f2fdaf59d073428d61fd (diff)
Add a test for check-declares
This same test can easily be used to run checkdoc, we only need to make CIDER comply with checkdoc first.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 44429a07..c1c5feac 100644
--- a/Makefile
+++ b/Makefile
@@ -27,6 +27,10 @@ build : elpa $(OBJECTS)
version:
$(EMACS) --version
+test-checks : version
+ $(CASK) exec $(EMACS) --no-site-file --no-site-lisp --batch \
+ -l test/cider-checks.el ./
+
test-bytecomp : version $(ELS:.el=.elc-test)
%.elc-test : %.el elpa