summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorBozhidar Batsov <bozhidar@tradeo.com>2013-10-28 18:16:49 +0200
committerBozhidar Batsov <bozhidar@tradeo.com>2013-10-28 18:16:49 +0200
commitbf4e8f1d012fa91f36b53f5679360af933564ca5 (patch)
tree96bbc5f43bccda61aabb7770210a2d1363f04afe /Makefile
parent024db0cde6587f999e3d1257f83f157fca227a63 (diff)
Add package building task
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 91d50316..8523737b 100644
--- a/Makefile
+++ b/Makefile
@@ -2,6 +2,8 @@ EMACS = emacs
EMACSFLAGS = -L .
CASK = cask
VAGRANT = vagrant
+VERSION = $(shell git describe --tags --abbrev=0 | sed 's/^v//')
+PACKAGE_DIR = packages/cider-$(VERSION)
ELS = $(wildcard *.el)
OBJECTS = $(ELS:.el=.elc)
@@ -20,6 +22,15 @@ elpa:
$(CASK) update
touch $@
+package:
+ mkdir -p $(PACKAGE_DIR)
+ cp $(ELS) $(PACKAGE_DIR)
+ tar cf $(PACKAGE_DIR).tar $(PACKAGE_DIR)
+
+packageclean:
+ rm -rf $(PACKAGE_DIR)
+ rm $(PACKAGE_DIR).tar
+
.PHONY: build
build : elpa $(OBJECTS)