summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorBozhidar Batsov <bozhidar@tradeo.com>2013-10-29 16:16:39 +0200
committerBozhidar Batsov <bozhidar@tradeo.com>2013-10-29 16:16:39 +0200
commitfe158d85706503b1aefa24ca67a08a5a5903b369 (patch)
tree6e6a70e0749374d1f9956bd038fdfbd5bd652f1c /Makefile
parent9a30ebcf32d2bc5173d29679cdf01e6bbb7e1eca (diff)
Refactor package generation code
cider-pkg.el is now auto-generated by cask. Special thanks to @lunaryorn for suggesting this.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 9580e3bb..3377a649 100644
--- a/Makefile
+++ b/Makefile
@@ -23,11 +23,13 @@ elpa:
touch $@
package:
+ cask package
mkdir -p packages/$(PACKAGE_NAME)
cp $(ELS) packages/$(PACKAGE_NAME)
tar cf packages/$(PACKAGE_NAME).tar -C packages $(PACKAGE_NAME)
packageclean:
+ rm cider-pkg.el
rm -rf packages/$(PACKAGE_NAME)
rm packages/$(PACKAGE_NAME).tar