summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cider-repl.el4
-rw-r--r--cider-util.el4
-rw-r--r--cider.el2
-rw-r--r--debian/changelog41
-rw-r--r--debian/cider-doc.doc-base10
-rw-r--r--debian/cider-doc.docs1
-rw-r--r--debian/clean1
-rw-r--r--debian/compat1
-rw-r--r--debian/control63
-rw-r--r--debian/copyright60
-rw-r--r--debian/elpa-cider.README.Debian18
-rw-r--r--debian/elpa-cider.elpa1
-rw-r--r--debian/elpa-test2
-rw-r--r--debian/patches/debian-changes252
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules14
-rw-r--r--debian/source/format1
-rw-r--r--debian/source/options2
-rw-r--r--debian/source/patch-header16
-rw-r--r--debian/watch4
-rw-r--r--doc/about/contributing.md2
-rw-r--r--doc/index.md4
-rw-r--r--doc/installation.md121
-rw-r--r--mkdocs.yml2
-rw-r--r--test/cider-util-tests.el18
25 files changed, 506 insertions, 139 deletions
diff --git a/cider-repl.el b/cider-repl.el
index 1b07bfd3..3adfb1d4 100644
--- a/cider-repl.el
+++ b/cider-repl.el
@@ -368,7 +368,9 @@ client process connection. Unless NO-BANNER is non-nil, insert a banner."
(substitute-command-keys
"\n;; ======================================================================
;; If you're new to CIDER it is highly recommended to go through its
-;; manual first. Type <M-x cider-view-manual> to view it.
+;; manual first. Install the cider-doc apt package and then type
+;; <M-x cider-view-manual> to view it.
+;; You should also read /usr/share/doc/elpa-cider/README.Debian
;; In case you're seeing any warnings you should consult the manual's
;; \"Troubleshooting\" section.
;;
diff --git a/cider-util.el b/cider-util.el
index c5a09634..629e67f1 100644
--- a/cider-util.el
+++ b/cider-util.el
@@ -404,7 +404,7 @@ plugin or dependency with:
(defvar cider-version)
-(defconst cider-manual-url "https://docs.cider.mx/en/%s/"
+(defconst cider-manual-url "file:///usr/share/doc/elpa-cider/html/index.html"
"The URL to CIDER's manual.")
(defun cider--manual-version ()
@@ -415,7 +415,7 @@ plugin or dependency with:
(defun cider-manual-url ()
"The CIDER manual's url."
- (format cider-manual-url (cider--manual-version)))
+ cider-manual-url)
;;;###autoload
(defun cider-view-manual ()
diff --git a/cider.el b/cider.el
index a3772811..75014b58 100644
--- a/cider.el
+++ b/cider.el
@@ -286,7 +286,7 @@ This variable is used by `cider-connect'."
:group 'cider
:package-version '(cider . "0.9.0"))
-(defcustom cider-inject-dependencies-at-jack-in t
+(defcustom cider-inject-dependencies-at-jack-in nil
"When nil, do not inject repl dependencies (most likely nREPL middlewares) at `cider-jack-in' time."
:type 'boolean
:safe #'booleanp
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 00000000..a4038d48
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,41 @@
+cider (0.18.0+dfsg-2) unstable; urgency=medium
+
+ [ Dmitry Shachnev ]
+ * Stop overriding mkdocs theme, search works fine now.
+ * Use dh_mkdocs instead of dh_linktree.
+ * Prevent search_index.json from being compressed.
+
+ [ Sean Whitton ]
+ * Prevent any HTML docs being compressed, too.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Wed, 19 Dec 2018 11:53:14 +0000
+
+cider (0.18.0+dfsg-1) unstable; urgency=medium
+
+ * New upstream release.
+ - Update README.Debian for changes to jack-in commands
+ - Add elpa-sesman & leiningen build-deps.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Sat, 08 Sep 2018 11:07:23 -0700
+
+cider (0.17.0+dfsg-1) unstable; urgency=medium
+
+ * New upstream release (Closes: #900825, #901564).
+ * Flip long descriptions of binary packages, which were somehow the
+ wrong way around.
+ * Update debian/cider-doc.linktrees as search javascript in bin:mkdocs
+ has moved.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Fri, 06 Jul 2018 08:36:11 +0100
+
+cider (0.16.0+dfsg-2) unstable; urgency=medium
+
+ * Set autopkgtest_keep in d/elpa-test.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Fri, 09 Feb 2018 22:24:34 -0700
+
+cider (0.16.0+dfsg-1) unstable; urgency=medium
+
+ * Initial release (Closes: #885384).
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Sat, 20 Jan 2018 12:02:32 -0700
diff --git a/debian/cider-doc.doc-base b/debian/cider-doc.doc-base
new file mode 100644
index 00000000..da288b7b
--- /dev/null
+++ b/debian/cider-doc.doc-base
@@ -0,0 +1,10 @@
+Document: cider-doc
+Title: CIDER: The Clojure Interactive Development Environment that Rocks
+Author: Bozhidar Batsov, Artur Malabarba and CIDER contributors
+Abstract: This manual describes what CIDER is
+ and how it can be used to develop Clojure projects with Emacs.
+Section: Editors
+
+Format: HTML
+Index: /usr/share/doc/elpa-cider/html/index.html
+Files: /usr/share/doc/elpa-cider/html/*.html
diff --git a/debian/cider-doc.docs b/debian/cider-doc.docs
new file mode 100644
index 00000000..1936cc1d
--- /dev/null
+++ b/debian/cider-doc.docs
@@ -0,0 +1 @@
+html
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 00000000..5ccff1a6
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1 @@
+html/
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 00000000..f599e28b
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/debian/control b/debian/control
new file mode 100644
index 00000000..c2bb7e95
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,63 @@
+Source: cider
+Section: lisp
+Priority: optional
+Maintainer: Debian Emacs addons team <pkg-emacsen-addons@lists.alioth.debian.org>
+Uploaders:
+ Sean Whitton <spwhitton@spwhitton.name>,
+Build-Depends:
+ debhelper (>= 10),
+ dh-elpa,
+ elpa-buttercup,
+ elpa-clojure-mode,
+ elpa-pkg-info,
+ elpa-queue,
+ elpa-sesman,
+ elpa-spinner,
+ leiningen,
+ mkdocs (>= 1.0.4),
+Standards-Version: 4.1.2
+Vcs-Browser: https://salsa.debian.org/emacsen-team/cider
+Vcs-Git: https://salsa.debian.org/emacsen-team/cider
+Homepage: https://www.github.com/clojure-emacs/cider
+Testsuite: autopkgtest-pkg-elpa
+
+Package: cider-doc
+Section: doc
+Architecture: all
+Depends:
+ elpa-cider (= ${source:Version}),
+ ${misc:Depends},
+ ${mkdocs:Depends},
+Description: Clojure IDE for Emacs - documentation
+ CIDER is the Clojure(Script) Interactive Development Environment that Rocks
+ .
+ While clojure-mode provides Emacs support for editing Clojure source files,
+ CIDER's cider-mode provides support for interacting with a running Clojure
+ process for compilation, debugging, looking up definitions and more.
+ .
+ This package installs CIDER's documentation.
+
+Package: elpa-cider
+Architecture: all
+Depends:
+ ${elpa:Depends},
+ ${misc:Depends},
+ leiningen | gradle,
+# | boot-clojure
+Recommends:
+ emacs (>= 46.0),
+# libcider-nrepl-clojure,
+# libtools-nrepl-clojure,
+Enhances:
+ emacs,
+ emacs25,
+Provides:
+ elpa-nrepl,
+Suggests:
+ cider-doc,
+Description: Clojure IDE for Emacs
+ CIDER is the Clojure(Script) Interactive Development Environment that Rocks
+ .
+ While clojure-mode provides Emacs support for editing Clojure source files,
+ CIDER's cider-mode provides support for interacting with a running Clojure
+ process for compilation, debugging, looking up definitions and more.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 00000000..dea02869
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,60 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: cider
+Source: http://www.github.com/clojure-emacs/cider
+Files-Excluded: logo doc/favicon.ico
+
+Files: *
+Copyright: (C) 2012-2017 Tim King, Alvin Francis Dumalus, Phil Hagelberg, Jeff Valk, Bozhidar Batsov, Artur Malabarba, John Andrews, Juan Monetta, Vital Reactor, LLC, John Valente and browse-kill-ring authors and CIDER contributors
+License: GPL-3+
+
+Files: cider-compat.el
+Copyright: (C) 1985-1987, 1992-2017 Free Software Foundation, Inc.
+License: GPL-3+
+Comment:
+ Upstream's copyright notice on this file is wrong. See subr-x.el and files.el
+ in the emacs25 package for the correct notices.
+
+Files: travis-ci/retry.sh
+Copyright: (C) 2013 Travis CI GmbH <contact@travis-ci.org>
+License: Expat
+Comment: https://github.com/travis-ci/travis-build/blob/73f74a94957f73eb54dc821f80c0c85ad8f8aab7/lib/travis/build/script/templates/header.sh#L168-L187
+
+Files: debian/*
+Copyright: (C) 2017-2018 Sean Whitton <spwhitton@spwhitton.name>
+License: GPL-3+
+
+License: GPL-3+
+ This program is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation, either version 3 of the License, or
+ (at your option) any later version.
+ .
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ .
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+ .
+ On Debian systems, the complete text of the GNU General
+ Public License version 3 can be found in `/usr/share/common-licenses/GPL-3'
+
+License: Expat
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+ .
+ The above copyright notice and this permission notice shall be included in
+ all copies or substantial portions of the Software.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+ THE SOFTWARE.
diff --git a/debian/elpa-cider.README.Debian b/debian/elpa-cider.README.Debian
new file mode 100644
index 00000000..2f5fd0b7
--- /dev/null
+++ b/debian/elpa-cider.README.Debian
@@ -0,0 +1,18 @@
+Injection of CIDER's dependencies
+=================================
+
+The usual way to start a CIDER REPL is `M-x cider-jack-in-clj` and
+related commands. This requires CIDER's nREPL middleware be available
+in your project. CIDER can automatically download and inject this
+middleware during `M-x cider-jack-in-clj`, but CIDER in Debian has
+this feature disabled by default to avoid surprise downloads from the
+Internet.
+
+You can either toggle the Emacs variable
+cider-inject-dependencies-at-jack-in to t in your ~/.emacs, which will
+enable transparent download and injection of CIDER's middleware, or
+add the middleware as dependencies of your project. See the "CIDER's
+nREPL middleware" subsection of the "Installation" section of CIDER's
+manual.
+
+ -- Sean Whitton <spwhitton@spwhitton.name>, Sat, 8 Sep 2018 09:31:43 -0700
diff --git a/debian/elpa-cider.elpa b/debian/elpa-cider.elpa
new file mode 100644
index 00000000..abf136d1
--- /dev/null
+++ b/debian/elpa-cider.elpa
@@ -0,0 +1 @@
+*.el
diff --git a/debian/elpa-test b/debian/elpa-test
new file mode 100644
index 00000000..17c9d3b0
--- /dev/null
+++ b/debian/elpa-test
@@ -0,0 +1,2 @@
+buttercup_load_path = test/utils
+autopkgtest_keep = test/*
diff --git a/debian/patches/debian-changes b/debian/patches/debian-changes
new file mode 100644
index 00000000..0a8a2ddc
--- /dev/null
+++ b/debian/patches/debian-changes
@@ -0,0 +1,252 @@
+The Debian packaging of cider is maintained in git, using the merging workflow
+described in dgit-maint-merge(7). There isn't a patch queue that can be
+represented as a quilt series.
+
+A detailed breakdown of the changes is available from their canonical
+representation - git commits in the packaging repository. For example, to see
+the changes made by the Debian maintainer in the first upload of upstream
+version 1.2.3, you could use:
+
+ % git clone https://git.dgit.debian.org/cider
+ % cd cider
+ % git log --oneline 1.2.3..debian/1.2.3-1 -- . ':!debian'
+
+(If you have dgit, use `dgit clone cider`, rather than plain `git clone`.)
+
+A single combined diff, containing all the changes, follows.
+--- cider-0.18.0+dfsg.orig/cider-repl.el
++++ cider-0.18.0+dfsg/cider-repl.el
+@@ -359,7 +359,9 @@ client process connection. Unless NO-BA
+ (substitute-command-keys
+ "\n;; ======================================================================
+ ;; If you're new to CIDER it is highly recommended to go through its
+-;; manual first. Type <M-x cider-view-manual> to view it.
++;; manual first. Install the cider-doc apt package and then type
++;; <M-x cider-view-manual> to view it.
++;; You should also read /usr/share/doc/elpa-cider/README.Debian
+ ;; In case you're seeing any warnings you should consult the manual's
+ ;; \"Troubleshooting\" section.
+ ;;
+--- cider-0.18.0+dfsg.orig/cider-util.el
++++ cider-0.18.0+dfsg/cider-util.el
+@@ -404,7 +404,7 @@ plugin or dependency with:
+
+ (defvar cider-version)
+
+-(defconst cider-manual-url "http://docs.cider.mx/en/%s/"
++(defconst cider-manual-url "file:///usr/share/doc/elpa-cider/html/index.html"
+ "The URL to CIDER's manual.")
+
+ (defun cider--manual-version ()
+@@ -415,7 +415,7 @@ plugin or dependency with:
+
+ (defun cider-manual-url ()
+ "The CIDER manual's url."
+- (format cider-manual-url (cider--manual-version)))
++ cider-manual-url)
+
+ ;;;###autoload
+ (defun cider-view-manual ()
+--- cider-0.18.0+dfsg.orig/cider.el
++++ cider-0.18.0+dfsg/cider.el
+@@ -286,7 +286,7 @@ This variable is used by `cider-connect'
+ :group 'cider
+ :package-version '(cider . "0.9.0"))
+
+-(defcustom cider-inject-dependencies-at-jack-in t
++(defcustom cider-inject-dependencies-at-jack-in nil
+ "When nil, do not inject repl dependencies (most likely nREPL middlewares) at `cider-jack-in' time."
+ :type 'boolean
+ :safe #'booleanp
+--- cider-0.18.0+dfsg.orig/doc/about/contributing.md
++++ cider-0.18.0+dfsg/doc/about/contributing.md
+@@ -71,7 +71,7 @@ You can support the development of CIDER
+ [Patreon](https://www.patreon.com/bbatsov),
+ [Liberapay](https://liberapay.com/bbatsov/donate) and PayPal.
+
+-[![Paypal](https://www.paypalobjects.com/en_US/i/btn/btn_donate_SM.gif)](https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=GRQKNBM6P8VRQ)
++[Paypal](https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=GRQKNBM6P8VRQ)
+
+ ### Open Collective
+
+--- cider-0.18.0+dfsg.orig/doc/index.md
++++ cider-0.18.0+dfsg/doc/index.md
+@@ -1,7 +1,3 @@
+-<p align="center">
+- <img src="https://raw.github.com/clojure-emacs/cider/master/logo/cider-logo-w640.png" alt="CIDER Logo"/>
+-</p>
+-
+ CIDER is the **C**lojure(Script) **I**nteractive **D**evelopment **E**nvironment
+ that **R**ocks!
+
+--- cider-0.18.0+dfsg.orig/doc/installation.md
++++ cider-0.18.0+dfsg/doc/installation.md
+@@ -1,125 +1,3 @@
+-The canonical way to install CIDER is via `package.el` (Emacs's built-in package
+-manager), but it can be installed manually or via alternative package managers such
+-as `el-get`.
+-
+-## Prerequisites
+-
+-You'll need to have Emacs installed (preferably the latest stable
+-release). If you're new to Emacs you might want to go through
+-[the guided tour of Emacs](https://www.gnu.org/software/emacs/tour/index.html)
+-and the built-in tutorial (just press <kbd>C-h t</kbd>).
+-
+-CIDER officially supports Emacs 25.1+, Java 8+ and Clojure(Script)
+-1.8+. CIDER 0.17 (AndalucĂ­a) was the final release which supported
+-Java 7 and Clojure(Script) 1.7.
+-
+-You'll also need a recent version of either the Clojure CLI tools or your
+-favorite build tool (Leiningen, Boot or Gradle) to be able to start CIDER via
+-`cider-jack-in`. Generally it's a good idea to use their latest stable versions.
+-
+-!!! warning
+-
+- CIDER does not support ClojureCLR.
+-
+-## Installation via package.el
+-
+-CIDER is available on the two major `package.el` community
+-maintained repos -
+-[MELPA Stable](http://stable.melpa.org)
+-and [MELPA](http://melpa.org).
+-
+-You can install CIDER with the following command:
+-
+-<kbd>M-x package-install [RET] cider [RET]</kbd>
+-
+-or by adding this bit of Emacs Lisp code to your Emacs initialization file
+-(`.emacs` or `init.el`):
+-
+-```el
+-(unless (package-installed-p 'cider)
+- (package-install 'cider))
+-```
+-
+-If the installation doesn't work try refreshing the package list:
+-
+-<kbd>M-x package-refresh-contents [RET]</kbd>
+-
+-Keep in mind that MELPA packages are built automatically from
+-the `master` branch, meaning bugs might creep in there from time to
+-time. Never-the-less, installing from MELPA is a reasonable way of
+-obtaining CIDER, as the `master` branch is normally quite stable
+-and serious regressions there are usually fixed pretty quickly.
+-
+-!!! Tip
+-
+- If you don't want to (or can't) wait for MELPA to rebuild CIDER,
+- you can easily build and install an up-to-date MELPA package locally yourself. Check out
+- [this article](http://emacsredux.com/blog/2015/05/10/building-melpa-packages-locally/)
+- for details on the subject.
+-
+-Generally, users of the non-adventurous kind are advised to stick
+-with the stable releases, available from MELPA Stable.
+-You can pin CIDER to always use MELPA
+-Stable by adding this to your Emacs initialization:
+-
+-```el
+-(add-to-list 'package-pinned-packages '(cider . "melpa-stable") t)
+-```
+-
+-!!! note
+-
+- CIDER has dependencies (e.g. `queue` & `seq`) that are only available in the
+- [GNU ELPA repository](https://elpa.gnu.org/). It's the only package repository
+- enabled by default in Emacs and you should not disable it!
+-
+-## Installation via use-package
+-
+-`use-package` can be used to install CIDER via the `package.el`'s repositories
+-[MELPA Stable](http://stable.melpa.org) and [MELPA](http://melpa.org).
+-
+-If you wanted to install the version of CIDER which is what is to be found in
+-the `master` branch, declare the following in your Emacs initialization file
+-(`.emacs` or `init.el`):
+-
+-```el
+-(use-package cider
+- :ensure t)
+-```
+-
+-However, if you wanted to be a bit more conservative and only use the stable
+-releases of CIDER, you'd declare the following:
+-
+-```el
+-(use-package cider
+- :ensure t
+- :pin melpa-stable)
+-```
+-
+-After placing one of the above s-expressions, evaluate it, for it to take effect
+-by entering: <kbd>C-x C-e</kbd>.
+-
+-For further configuration options with `use-package`, consult the
+-official [use-package repository](https://github.com/jwiegley/use-package).
+-
+-
+-## Installation via el-get
+-
+-CIDER is also available for installation from
+-the [el-get](https://github.com/dimitri/el-get) package manager.
+-
+-Provided you've already installed `el-get` you can install CIDER with the
+-following command:
+-
+-<kbd>M-x el-get-install [RET] cider [RET]</kbd>
+-
+-## Manual installation
+-
+-Installing CIDER manually is discouraged unless you plan to work with
+-CIDER's codebase. The manual installation is relatively involved as it
+-requires manual installation of the dependencies and manual generation
+-of the package autoloads. Check out the section [Hacking on
+-CIDER](hacking_on_cider.md) for more details.
+-
+ ## CIDER's nREPL middleware
+
+ Much of CIDER's functionality depends on the presence of CIDER's own
+--- cider-0.18.0+dfsg.orig/mkdocs.yml
++++ cider-0.18.0+dfsg/mkdocs.yml
+@@ -1,5 +1,6 @@
+ site_name: "CIDER: The Clojure Interactive Development Environment that Rocks"
+ repo_url: https://github.com/clojure-emacs/cider
++site_dir: html
+ edit_uri: edit/master/doc/
+ site_favicon: favicon.ico
+ copyright: "Copyright &copy; 2016-2018 Bozhidar Batsov, Artur Malabarba and CIDER contributors"
+@@ -35,6 +36,7 @@ pages:
+ - License: about/license.md
+ extra_css:
+ - css/extra.css
++use_directory_urls: false
+ markdown_extensions:
+ - admonition
+ theme: readthedocs
+--- cider-0.18.0+dfsg.orig/test/cider-util-tests.el
++++ cider-0.18.0+dfsg/test/cider-util-tests.el
+@@ -179,15 +179,15 @@
+ (expect (cider--deep-vector-to-list '[bug]) :to-equal '(bug))
+ (expect (cider--deep-vector-to-list '(bug)) :to-equal '(bug))))
+
+-(describe "cider-manual-url"
+- :var (cider-version)
+- (it "returns the manual correct url for stable cider versions"
+- (setq cider-version "0.11.0")
+- (expect (cider-manual-url) :to-equal "http://docs.cider.mx/en/stable/"))
++;; (describe "cider-manual-url"
++;; :var (cider-version)
++;; (it "returns the manual correct url for stable cider versions"
++;; (setq cider-version "0.11.0")
++;; (expect (cider-manual-url) :to-equal "http://docs.cider.mx/en/stable/"))
+
+- (it "returns the manual correct url for snapshot cider versions"
+- (setq cider-version "0.11.0-snapshot")
+- (expect (cider-manual-url) :to-equal "http://docs.cider.mx/en/latest/")))
++;; (it "returns the manual correct url for snapshot cider versions"
++;; (setq cider-version "0.11.0-snapshot")
++;; (expect (cider-manual-url) :to-equal "http://docs.cider.mx/en/latest/")))
+
+ (describe "cider-refcard-url"
+ :var (cider-version)
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 00000000..7bb82529
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+debian-changes
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..48ab2665
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ --with elpa --with mkdocs
+
+# mkdocs under python3 needs a UTF locale or Click gives up
+override_dh_auto_build:
+ LANG=C.UTF-8 LC_ALL=C.UTF-8 mkdocs build --clean
+
+override_dh_installdocs:
+ dh_installdocs -X__pycache__ --link-doc=elpa-cider
+
+override_dh_compress:
+ dh_compress -Xsearch_index.json -Xhtml/
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 00000000..163aaf8d
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/source/options b/debian/source/options
new file mode 100644
index 00000000..ce071fb4
--- /dev/null
+++ b/debian/source/options
@@ -0,0 +1,2 @@
+single-debian-patch
+auto-commit
diff --git a/debian/source/patch-header b/debian/source/patch-header
new file mode 100644
index 00000000..7e1bcc1b
--- /dev/null
+++ b/debian/source/patch-header
@@ -0,0 +1,16 @@
+The Debian packaging of cider is maintained in git, using the merging workflow
+described in dgit-maint-merge(7). There isn't a patch queue that can be
+represented as a quilt series.
+
+A detailed breakdown of the changes is available from their canonical
+representation - git commits in the packaging repository. For example, to see
+the changes made by the Debian maintainer in the first upload of upstream
+version 1.2.3, you could use:
+
+ % git clone https://git.dgit.debian.org/cider
+ % cd cider
+ % git log --oneline 1.2.3..debian/1.2.3-1 -- . ':!debian'
+
+(If you have dgit, use `dgit clone cider`, rather than plain `git clone`.)
+
+A single combined diff, containing all the changes, follows.
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 00000000..9eece446
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,4 @@
+version=4
+opts="dversionmangle=s/\+dfsg\d*$//,filenamemangle=s/(?:.*?)?v?(\d[\d.]*)\.tar\.gz/cider-$1.tar.gz/" \
+ https://github.com/clojure-emacs/cider/tags \
+ (?:.*?/)?v?(\d[\d.]*)\.tar\.gz debian uupdate
diff --git a/doc/about/contributing.md b/doc/about/contributing.md
index 6536a693..de79d5e5 100644
--- a/doc/about/contributing.md
+++ b/doc/about/contributing.md
@@ -71,7 +71,7 @@ You can support the development of CIDER, [clojure-mode][] and [inf-clojure][] v
[Patreon](https://www.patreon.com/bbatsov),
[Liberapay](https://liberapay.com/bbatsov/donate) and PayPal.
-[![Paypal](https://www.paypalobjects.com/en_US/i/btn/btn_donate_SM.gif)](https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=GRQKNBM6P8VRQ)
+[Paypal](https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=GRQKNBM6P8VRQ)
### Open Collective
diff --git a/doc/index.md b/doc/index.md
index ca1e7638..cbe6be9f 100644
--- a/doc/index.md
+++ b/doc/index.md
@@ -1,7 +1,3 @@
-<p align="center">
- <img src="https://raw.github.com/clojure-emacs/cider/master/logo/cider-logo-w640.png" alt="CIDER Logo"/>
-</p>
-
CIDER is the **C**lojure(Script) **I**nteractive **D**evelopment **E**nvironment
that **R**ocks!
diff --git a/doc/installation.md b/doc/installation.md
index 2f694a97..6972933f 100644
--- a/doc/installation.md
+++ b/doc/installation.md
@@ -1,124 +1,3 @@
-The canonical way to install CIDER is via `package.el` (Emacs's built-in package
-manager), but it can be installed manually or via alternative package managers such
-as `el-get`.
-
-## Prerequisites
-
-You'll need to have Emacs installed, preferably the latest stable
-release. If you're new to Emacs you might want to go through
-[the guided tour of Emacs](https://www.gnu.org/software/emacs/tour/index.html)
-and the built-in tutorial (just press <kbd>C-h t</kbd>).
-
-CIDER officially supports Emacs 25.1+, Java 8+ and Clojure(Script)
-1.8+. CIDER 0.17 (AndalucĂ­a) was the final release which supported
-Java 7 and Clojure(Script) 1.7.
-
-You'll also need a recent version of either the Clojure CLI tools or your
-favorite build tool (Leiningen, Boot, or Gradle) to be able to start CIDER via
-`cider-jack-in`. Generally it's a good idea to use the latest stable versions.
-
-!!! warning
-
- CIDER does not support ClojureCLR.
-
-## Installation via package.el
-
-CIDER is available on the two major `package.el` community
-maintained repos -
-[MELPA Stable](http://stable.melpa.org)
-and [MELPA](http://melpa.org).
-
-You can install CIDER with the following command:
-
-<kbd>M-x package-install [RET] cider [RET]</kbd>
-
-or by adding this bit of Emacs Lisp code to your Emacs initialization file
-(`.emacs` or `init.el`):
-
-```el
-(unless (package-installed-p 'cider)
- (package-install 'cider))
-```
-
-If the installation doesn't work try refreshing the package list:
-
-<kbd>M-x package-refresh-contents [RET]</kbd>
-
-It's important to note that MELPA packages are built automatically
-from the `master` branch, and that means you'll be right on the
-leading edge of development. This has upsides and downsides; you'll
-see new features first, but you might experience some bugs from
-time to time. Nevertheless, installing from MELPA is a reasonable way
-to obtain CIDER. The `master` branch is normally quite stable
-and serious regressions there are usually fixed quickly.
-
-If you have concerns about living on the leading edge of CIDER
-deveopment, you can always pin CIDER to use MELPA Stable like this:
-
-```el
-(add-to-list 'package-pinned-packages '(cider . "melpa-stable") t)
-```
-
-!!! Tip
-
- If you don't want to (or can't) wait for MELPA to rebuild CIDER,
- you can easily build and install an up-to-date MELPA package locally yourself. Check out
- [this article](http://emacsredux.com/blog/2015/05/10/building-melpa-packages-locally/)
- for details on the subject.
-
-!!! note
-
- CIDER has dependencies (e.g. `queue` & `seq`) that are only available in the
- [GNU ELPA repository](https://elpa.gnu.org/). It's the only package repository
- enabled by default in Emacs and you should not disable it!
-
-## Installation via use-package
-
-`use-package` can be used to install CIDER via the `package.el`'s repositories
-[MELPA Stable](http://stable.melpa.org) and [MELPA](http://melpa.org).
-
-If you wanted to install the version of CIDER which is what is to be found in
-the `master` branch, declare the following in your Emacs initialization file
-(`.emacs` or `init.el`):
-
-```el
-(use-package cider
- :ensure t)
-```
-
-However, if you wanted to be a bit more conservative and only use the stable
-releases of CIDER, you'd declare the following:
-
-```el
-(use-package cider
- :ensure t
- :pin melpa-stable)
-```
-
-After placing one of the above s-expressions, evaluate it, for it to take effect
-by entering: <kbd>C-x C-e</kbd>.
-
-For further configuration options with `use-package`, consult the
-official [use-package repository](https://github.com/jwiegley/use-package).
-
-
-## Installation via el-get
-
-CIDER is also available for installation from
-the [el-get](https://github.com/dimitri/el-get) package manager.
-
-Provided you've already installed `el-get` you can install CIDER with the
-following command:
-
-<kbd>M-x el-get-install [RET] cider [RET]</kbd>
-
-## Manual Installation
-
-Installing CIDER manually is discouraged unless you plan to work with CIDER's
-codebase. The manual installation is relatively involved as it requires manual
-installation of the dependencies. Check out the section
-[Hacking on CIDER](hacking_on_cider.md) for more details.
-
## CIDER's nREPL Middleware
Much of CIDER's functionality depends on its own [nREPL
diff --git a/mkdocs.yml b/mkdocs.yml
index 25e10cce..2f984eee 100644
--- a/mkdocs.yml
+++ b/mkdocs.yml
@@ -1,5 +1,6 @@
site_name: "CIDER: The Clojure Interactive Development Environment that Rocks"
repo_url: https://github.com/clojure-emacs/cider
+site_dir: html
edit_uri: edit/master/doc/
site_favicon: favicon.ico
copyright: "Copyright &copy; 2016-2019 Bozhidar Batsov, Artur Malabarba and CIDER contributors"
@@ -35,6 +36,7 @@ pages:
- License: about/license.md
extra_css:
- css/extra.css
+use_directory_urls: false
markdown_extensions:
- admonition
theme: readthedocs
diff --git a/test/cider-util-tests.el b/test/cider-util-tests.el
index d15483b6..ad434242 100644
--- a/test/cider-util-tests.el
+++ b/test/cider-util-tests.el
@@ -179,15 +179,15 @@
(expect (cider--deep-vector-to-list '[bug]) :to-equal '(bug))
(expect (cider--deep-vector-to-list '(bug)) :to-equal '(bug))))
-(describe "cider-manual-url"
- :var (cider-version)
- (it "returns the manual correct url for stable cider versions"
- (setq cider-version "0.11.0")
- (expect (cider-manual-url) :to-equal "https://docs.cider.mx/en/stable/"))
-
- (it "returns the manual correct url for snapshot cider versions"
- (setq cider-version "0.11.0-snapshot")
- (expect (cider-manual-url) :to-equal "https://docs.cider.mx/en/latest/")))
+;; (describe "cider-manual-url"
+;; :var (cider-version)
+;; (it "returns the manual correct url for stable cider versions"
+;; (setq cider-version "0.11.0")
+;; (expect (cider-manual-url) :to-equal "https://docs.cider.mx/en/stable/"))
+
+;; (it "returns the manual correct url for snapshot cider versions"
+;; (setq cider-version "0.11.0-snapshot")
+;; (expect (cider-manual-url) :to-equal "https://docs.cider.mx/en/latest/")))
(describe "cider-refcard-url"
:var (cider-version)