summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 66a0c6bb..ee8ac236 100644
--- a/Makefile
+++ b/Makefile
@@ -21,11 +21,13 @@ elpa:
$(CASK) update
touch $@
-.PHONY: build
+.PHONY: build version
build : elpa $(OBJECTS)
-.PHONY: test
-test : build
+version:
+ $(EMACS) --version
+
+test : version build
$(CASK) exec $(EMACS) --no-site-file --no-site-lisp --batch \
$(EMACSFLAGS) \
-l test/run-tests