summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 14 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..48ab2665
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ --with elpa --with mkdocs
+
+# mkdocs under python3 needs a UTF locale or Click gives up
+override_dh_auto_build:
+ LANG=C.UTF-8 LC_ALL=C.UTF-8 mkdocs build --clean
+
+override_dh_installdocs:
+ dh_installdocs -X__pycache__ --link-doc=elpa-cider
+
+override_dh_compress:
+ dh_compress -Xsearch_index.json -Xhtml/