summaryrefslogtreecommitdiff
path: root/_src/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '_src/Makefile')
-rw-r--r--_src/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/_src/Makefile b/_src/Makefile
new file mode 100644
index 0000000..51888db
--- /dev/null
+++ b/_src/Makefile
@@ -0,0 +1,13 @@
+SVGS = $(wildcard *.svg)
+PNGS = $(SVGS:%.svg=../gtk-3.0/img/%.png) $(SVGS:%.svg=../gtk-3.0/img/%@2.png)
+
+all: $(PNGS)
+
+clean:
+ -rm -f $(PNGS)
+
+../gtk-3.0/img/%.png: %.svg
+ inkscape --without-gui --export-dpi=90 --export-background-opacity=0 --export-png=$@ $<
+
+../gtk-3.0/img/%@2.png: %.svg
+ inkscape --without-gui --export-dpi=180 --export-background-opacity=0 --export-png=$@ $<