summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJo Shields <joshield@microsoft.com>2019-01-18 13:39:32 -0500
committerJo Shields <joshield@microsoft.com>2019-01-18 13:39:32 -0500
commitfb8867394f28ead91a3d823630b13e1d9c872227 (patch)
tree4ecb3be08efe065c9900fa544610507dc716ea25
parentba2cbb4c0705d897db3d6b94d56fb038f582e421 (diff)
parent8eaab07dccf8dd84abed6720e6ad34fe071b91c2 (diff)
Merge branch 'jbicha/cli-common-master'
-rw-r--r--cli-policy.sgml4
-rw-r--r--debian/changelog45
-rw-r--r--debian/control5
-rwxr-xr-xdebian/rules4
4 files changed, 53 insertions, 5 deletions
diff --git a/cli-policy.sgml b/cli-policy.sgml
index 08f59d9..6d828a5 100644
--- a/cli-policy.sgml
+++ b/cli-policy.sgml
@@ -347,7 +347,7 @@
The only exception here is for native libraries that are of wider use;
can be used other packages. Native libraries should be packaged according to the
<url id="http://www.netfort.gr.jp/~dancer/column/libpkg-guide/libpkg-guide.html"
- name="Library Packaging Guide"> in a Debain Policy conformant way.
+ name="Library Packaging Guide"> in a Debian Policy conformant way.
</p>
<p>
@@ -959,7 +959,7 @@ binary-indep: build install
an API that allows to extend it.
<package>cli-common-dev</package> as of version 0.5.7 can extend
debhelper 7 with all commands that are needed. You can enable this by
- passing "cli" to dh in <file>debain/rules</file> like this:
+ passing "cli" to dh in <file>debian/rules</file> like this:
<example>
%:
dh $@ --with cli
diff --git a/debian/changelog b/debian/changelog
index ff6e760..821c0c8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,48 @@
+cli-common (0.9+nmu3) unstable; urgency=medium
+
+ * Non-maintainer upload.
+
+ [ Mirco Bauer ]
+ * cli-policy.sgml: --with param to dh preferred over including cli.make
+
+ [ Niels Thykier ]
+ * dh_makechilibs: Remove only compat code for debhelper compat 3
+ * dh_*: Optimize out some fork+exec calls
+ * Add NOOP promises so dh can optimize them out
+
+ [ Daniel Kahn Gillmor ]
+ * use Salsa for Vcs-* and Homepage
+
+ [ Jeremy Bicha ]
+ * Have cli-common-dev Provide dh-sequence-cli
+
+ -- Jeremy Bicha <jbicha@debian.org> Sat, 12 Jan 2019 13:47:28 -0500
+
+cli-common (0.9+nmu2) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Replace references and usage of "dh_clean -k" with "dh_prep".
+ * dh_makeclilibs: Update to support "Rules-Requires-Root: no" (R³).
+ Thanks to Daniel Kahn Gillmor for reporting the issue.
+ (Closes: #910559)
+ * Set "Rules-Requires-Root" (R³) to "no".
+ * d/rules: Remove dh_installcliframework.1 on clean.
+ * d/rules: Add required build-arch and build-indep targets.
+
+ -- Niels Thykier <niels@thykier.net> Sun, 28 Oct 2018 17:08:11 +0000
+
+cli-common (0.9+nmu1) unstable; urgency=medium
+
+ * Non-maintainer upload fixing a bug blocking serious bug #777597 --
+ perl-modules: upgrade regression: dpkg: dependency problems prevent
+ configuration of perl-modules
+
+ * replace dependencies on 'perl-modules' with just 'perl' as per Perl policy
+ existence of perl-modules package is an implementation detail
+ (Closes: #779113)
+
+ -- Damyan Ivanov <dmn@debian.org> Wed, 25 Feb 2015 20:56:32 +0000
+
cli-common (0.9) unstable; urgency=medium
* The "Hello Mono 3 and F#" release
diff --git a/debian/control b/debian/control
index e257e87..145b6b0 100644
--- a/debian/control
+++ b/debian/control
@@ -20,7 +20,7 @@ Vcs-Browser: https://salsa.debian.org/dotnet-team/cli-common
Package: cli-common
Architecture: all
Replaces: cli-common-dev (<< 0.5.1)
-Depends: perl-modules
+Depends: perl
Description: common files between all CLI packages
This package must be installed if a CLI (Common Language Infrastructure)
runtime environment is desired.
@@ -36,10 +36,11 @@ Package: cli-common-dev
Architecture: all
Replaces: cli-common (<< 0.4.0)
Depends: debhelper (>= 7.0.8),
- perl-modules,
+ perl,
mono-utils (>= 4.4~) | cil-disassembler,
mono-devel (>= 4.4~) | strong-name-tool,
libxml-dom-perl
+Provides: dh-sequence-cli
Description: common files for building CLI packages
This package must be installed if a CLI (Common Language Infrastructure)
packaging environment is desired.
diff --git a/debian/rules b/debian/rules
index c43d12d..0d62340 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,6 +6,8 @@ export MONO_SHARED_DIR=$(CURDIR)
VERSION = $(shell dpkg-parsechangelog | grep ^Vers | cut -d\ -f2)
build: build-stamp
+build-arch: build-stamp
+build-indep: build-stamp
build-stamp:
dh_testdir
debiandoc2text cli-policy.sgml
@@ -18,7 +20,7 @@ build-stamp:
clean:
dh_testdir
dh_testroot
- rm -f dh_clideps.1 dh_makeclilibs.1 dh_installcligac.1 dh_clifixperms.1 dh_clistrip.1 dh_cligacpolicy.1
+ rm -f dh_clideps.1 dh_makeclilibs.1 dh_installcligac.1 dh_clifixperms.1 dh_clistrip.1 dh_cligacpolicy.1 dh_installcliframework.1
rm -fr cli-policy.html cli-policy.txt cli-policy.pdf cli-policy.tpt
rm -f build-stamp
rm -rf $(MONO_SHARED_DIR)/.wapi