summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@debian.org>2019-01-13 14:35:24 +0200
committerPeter Pentchev <roam@debian.org>2019-01-13 14:35:24 +0200
commitd4932478943728e30613cc564d8c9e3742445d52 (patch)
tree34bd4eeeeba80a4bdb0a3565c92989ab41693800
parent42b81aa28a334511e05fd125ab1460d022ad4484 (diff)
Change DEB_NODOC to BUILD_DOC for consistency.
Gbp-Dch: ignore
-rwxr-xr-xdebian/rules10
1 files changed, 5 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index f3d59d1..8ae941c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -40,9 +40,9 @@ BUILD_IMPL_PY=no
endif
ifeq (,$(filter nodoc,$(DEB_BUILD_OPTIONS) $(DEB_BUILD_PROFILES)))
-DEB_NODOC=0
+BUILD_DOC=yes
else
-DEB_NODOC=1
+BUILD_DOC=no
endif
D= ${CURDIR}/debian
@@ -51,7 +51,7 @@ PY= ${CURDIR}/python
TESTD= ${CURDIR}/t
override_dh_auto_build:
- @echo 'building C: ${BUILD_IMPL_C}, py2: ${BUILD_IMPL_PY2}, py3: ${BUILD_IMPL_PY3}, python: ${BUILD_IMPL_PY}'
+ @echo 'building C: ${BUILD_IMPL_C}, py2: ${BUILD_IMPL_PY2}, py3: ${BUILD_IMPL_PY3}, python: ${BUILD_IMPL_PY}, doc: ${BUILD_DOC}'
ifeq (yes,${BUILD_IMPL_C})
dh_auto_build -- LFS_CPPFLAGS= LFS_LDFLAGS=
endif
@@ -65,7 +65,7 @@ ifeq (yes,${BUILD_IMPL_PY})
rm -f -- '${DTMP}/usr/bin/confget'
endif
ifeq (yes,${BUILD_IMPL_C})
-ifeq (${DEB_NODOC},1)
+ifeq (no,${BUILD_DOC})
mv -f Makefile Makefile.bak
sed -e 's/^install:.*/install: all install-bin/' Makefile.bak > Makefile
endif
@@ -74,7 +74,7 @@ endif
EXAMPLESDIR=/usr/share/doc/confget/examples \
INSTALL_PROGRAM='install -m 755' \
INSTALL_SCRIPT='install -m 755' INSTALL_DATA='install -m 644'
-ifeq (${DEB_NODOC},1)
+ifeq (no,${BUILD_DOC})
mv -f Makefile.bak Makefile
endif
endif