summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorFelipe Sateler <fsateler@debian.org>2016-07-16 17:23:10 -0400
committerFelipe Sateler <fsateler@debian.org>2016-07-16 17:42:06 -0400
commitb6d51330525e0720d1fdba0e9dd0a020b57e54e3 (patch)
tree908ad2b39fbf176891d11100a5f9fc477ab9362a /debian
parent0067a75b8ae120e37f26cd5bbcecd0b5317d39f7 (diff)
Remove more python opcode references
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/Don-t-build-the-opcodes-we-deleted.patch87
1 files changed, 85 insertions, 2 deletions
diff --git a/debian/patches/Don-t-build-the-opcodes-we-deleted.patch b/debian/patches/Don-t-build-the-opcodes-we-deleted.patch
index d67d49e..961e8fa 100644
--- a/debian/patches/Don-t-build-the-opcodes-we-deleted.patch
+++ b/debian/patches/Don-t-build-the-opcodes-we-deleted.patch
@@ -4,9 +4,92 @@ Subject: Don't build the opcodes we deleted
These opcodes were stripped from the manual at repack time.
---
- opcodes/top.xml | 6 ------
- 1 file changed, 6 deletions(-)
+ Makefile | 5 ++---
+ manual.xml | 6 ------
+ misc/quickref.xml | 13 +------------
+ opcodes.xml | 11 -----------
+ opcodes/top.xml | 6 ------
+ 5 files changed, 3 insertions(+), 38 deletions(-)
+diff --git a/Makefile b/Makefile
+index 0105754..be2a0cf 100644
+--- a/Makefile
++++ b/Makefile
+@@ -385,9 +385,8 @@ OPCODES = opcodes/0dbfs.xml opcodes/ATSadd.xml opcodes/ATSaddnz.xml \
+ opcodes/pvsmooth.xml opcodes/pvsmorph.xml opcodes/pvsosc.xml \
+ opcodes/pvsout.xml opcodes/pvspitch.xml opcodes/pvstanal.xml \
+ opcodes/pvstencil.xml opcodes/pvsvoc.xml opcodes/pvswarp.xml \
+- opcodes/pvsynth.xml opcodes/pwd.xml opcodes/pyassign.xml \
+- opcodes/pycall.xml opcodes/pyeval.xml opcodes/pyexec.xml \
+- opcodes/pyinit.xml opcodes/pyrun.xml opcodes/qinf.xml \
++ opcodes/pvsynth.xml opcodes/pwd.xml \
++ opcodes/qinf.xml \
+ opcodes/qnan.xml opcodes/r2c.xml opcodes/raises.xml \
+ opcodes/rand.xml opcodes/randh.xml opcodes/randi.xml \
+ opcodes/random.xml opcodes/randomh.xml opcodes/randomi.xml \
+diff --git a/manual.xml b/manual.xml
+index 800dc85..8cb7e25 100644
+--- a/manual.xml
++++ b/manual.xml
+@@ -1069,12 +1069,6 @@
+ <!ENTITY opcodespvsbandr SYSTEM "opcodes/pvsbandr.xml">
+ <!ENTITY opcodespvstanal SYSTEM "opcodes/pvstanal.xml">
+ <!ENTITY opcodespvs2tab SYSTEM "opcodes/pvs2tab.xml">
+-<!ENTITY opcodespyassign SYSTEM "opcodes/pyassign.xml">
+-<!ENTITY opcodespycall SYSTEM "opcodes/pycall.xml">
+-<!ENTITY opcodespyeval SYSTEM "opcodes/pyeval.xml">
+-<!ENTITY opcodespyexec SYSTEM "opcodes/pyexec.xml">
+-<!ENTITY opcodespyinit SYSTEM "opcodes/pyinit.xml">
+-<!ENTITY opcodespyrun SYSTEM "opcodes/pyrun.xml">
+
+ <!ENTITY opcodespwd SYSTEM "opcodes/pwd.xml">
+ <!ENTITY opcodesqinf SYSTEM "opcodes/qinf.xml">
+diff --git a/misc/quickref.xml b/misc/quickref.xml
+index 7a6834d..2b22fb8 100644
+--- a/misc/quickref.xml
++++ b/misc/quickref.xml
+@@ -1959,18 +1959,7 @@
+ <synopsis><link linkend="MixerSetLevel">MixerSetLevel</link> isend, ibuss, kgain</synopsis><para/>
+ <synopsis><link linkend="MixerSetLevel_i">MixerSetLevel_i</link> isend, ibuss, igain</synopsis><para/>
+ </para></formalpara>
+-<para></para><para></para><formalpara>
+-<title>Python Opcodes</title>
+-<para>
+-<para/>
+-<synopsis><link linkend="pyassign">pyassign</link> &quot;variable&quot;, kvalue</synopsis><synopsis><link linkend="pyassign">pyassigni</link> &quot;variable&quot;, ivalue</synopsis><synopsis><link linkend="pyassign">pylassign</link> &quot;variable&quot;, kvalue</synopsis><synopsis><link linkend="pyassign">pylassigni</link> &quot;variable&quot;, ivalue</synopsis><synopsis><link linkend="pyassign">pyassignt</link> ktrigger, &quot;variable&quot;, kvalue</synopsis><synopsis><link linkend="pyassign">pylassignt</link> ktrigger, &quot;variable&quot;, kvalue</synopsis><para/>
+-<synopsis> <link linkend="pycall">pycall</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kresult <link linkend="pycall">pycall1</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kresult1, kresult2 <link linkend="pycall">pycall2</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3 <link linkend="pycall">pycall3</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4 <link linkend="pycall">pycall4</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5 <link linkend="pycall">pycall5</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6 <link linkend="pycall">pycall6</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6, kr7 <link linkend="pycall">pycall7</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6, kr7, kr8 <link linkend="pycall">pycall8</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis> <link linkend="pycall">pycallt</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kresult <link linkend="pycall">pycall1t</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kresult1, kresult2 <link linkend="pycall">pycall2t</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3 <link linkend="pycall">pycall3t</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4 <link linkend="pycall">pycall4t</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5 <link linkend="pycall">pycall5t</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6 <link linkend="pycall">pycall6t</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6, kr7 <link linkend="pycall">pycall7t</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6, kr7, kr8 <link linkend="pycall">pycall8t</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis> <link linkend="pycall">pycalli</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>iresult <link linkend="pycall">pycall1i</link> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>iresult1, iresult2 <link linkend="pycall">pycall2i</link> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3 <link linkend="pycall">pycall3i</link> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4 <link linkend="pycall">pycall4i</link> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4, ir5 <link linkend="pycall">pycall5i</link> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4, ir5, ir6 <link linkend="pycall">pycall6i</link> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4, ir5, ir6, ir7 <link linkend="pycall">pycall7i</link> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4, ir5, ir6, ir7, ir8 <link linkend="pycall">pycall8i</link> &quot;callable&quot;, iarg1, ...</synopsis><synopsis><link linkend="pycall">pycalln</link> &quot;callable&quot;, nresults, kresult1, ..., kresultn, karg1, ...</synopsis><synopsis><link linkend="pycall">pycallni</link> &quot;callable&quot;, nresults, iresult1, ..., iresultn, iarg1, ...</synopsis><synopsis> <link linkend="pycall">pylcall</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kresult <link linkend="pycall">pylcall1</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kresult1, kresult2 <link linkend="pycall">pylcall2</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3 <link linkend="pycall">pylcall3</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4 <link linkend="pycall">pylcall4</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5 <link linkend="pycall">pylcall5</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6 <link linkend="pycall">pylcall6</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6, kr7 <link linkend="pycall">pylcall7</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6, kr7, kr8 <link linkend="pycall">pylcall8</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis> <link linkend="pycall">pylcallt</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kresult <link linkend="pycall">pylcall1t</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kresult1, kresult2 <link linkend="pycall">pylcall2t</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3 <link linkend="pycall">pylcall3t</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4 <link linkend="pycall">pylcall4t</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5 <link linkend="pycall">pylcall5t</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6 <link linkend="pycall">pylcall6t</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6, kr7 <link linkend="pycall">pylcall7t</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6, kr7, kr8 <link linkend="pycall">pylcall8t</link> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis> <link linkend="pycall">pylcalli</link> &quot;callable&quot;, karg1, ...</synopsis><synopsis>iresult <link linkend="pycall">pylcall1i</link> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>iresult1, iresult2 <link linkend="pycall">pylcall2i</link> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3 <link linkend="pycall">pylcall3i</link> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4 <link linkend="pycall">pylcall4i</link> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4, ir5 <link linkend="pycall">pylcall5i</link> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4, ir5, ir6 <link linkend="pycall">pylcall6i</link> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4, ir5, ir6, ir7 <link linkend="pycall">pylcall7i</link> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4, ir5, ir6, ir7, ir8 <link linkend="pycall">pylcall8i</link> &quot;callable&quot;, iarg1, ...</synopsis><synopsis><link linkend="pycall">pylcalln</link> &quot;callable&quot;, nresults, kresult1, ..., kresultn, karg1, ...</synopsis><synopsis><link linkend="pycall">pylcallni</link> &quot;callable&quot;, nresults, iresult1, ..., iresultn, iarg1, ...</synopsis><para/>
+-<synopsis>kresult <link linkend="pyeval">pyeval</link> &quot;expression&quot;</synopsis><synopsis>iresult <link linkend="pyeval">pyevali</link> &quot;expression&quot;</synopsis><synopsis>kresult <link linkend="pyeval">pyleval</link> &quot;expression&quot;</synopsis><synopsis>iresult <link linkend="pyeval">pylevali</link> &quot;expression&quot;</synopsis><synopsis>kresult <link linkend="pyeval">pyevalt</link> ktrigger, &quot;expression&quot;</synopsis><synopsis>kresult <link linkend="pyeval">pylevalt</link> ktrigger, &quot;expression&quot;</synopsis><para/>
+-<synopsis><link linkend="pyexec">pyexec</link> &quot;filename&quot;</synopsis><synopsis><link linkend="pyexec">pyexeci</link> &quot;filename&quot;</synopsis><synopsis><link linkend="pyexec">pylexec</link> &quot;filename&quot;</synopsis><synopsis><link linkend="pyexec">pylexeci</link> &quot;filename&quot;</synopsis><synopsis><link linkend="pyexec">pyexect</link> ktrigger, &quot;filename&quot;</synopsis><synopsis><link linkend="pyexec">plyexect</link> ktrigger, &quot;filename&quot;</synopsis><para/>
+-<synopsis><link linkend="pyinit">pyinit</link>&#160;</synopsis><para/>
+-<synopsis><link linkend="pyrun">pyrun</link> &quot;statement&quot;</synopsis><synopsis><link linkend="pyrun">pyruni</link> &quot;statement&quot;</synopsis><synopsis><link linkend="pyrun">pylrun</link> &quot;statement&quot;</synopsis><synopsis><link linkend="pyrun">pylruni</link> &quot;statement&quot;</synopsis><synopsis><link linkend="pyrun">pyrunt</link> ktrigger, &quot;statement&quot;</synopsis><synopsis><link linkend="pyrun">pylrunt</link> ktrigger, &quot;statement&quot;</synopsis><para/>
+-</para></formalpara>
+-<para></para><para></para><formalpara>
++<para></para><para></para><para></para><para></para><formalpara>
+ <title>Image Processing Opcodes</title>
+ <para>
+ <para/>
+diff --git a/opcodes.xml b/opcodes.xml
+index 0ccfece..e632237 100644
+--- a/opcodes.xml
++++ b/opcodes.xml
+@@ -1634,17 +1634,6 @@ pitch control and support for timescale-modified input</desc><synopsis>asig <opc
+ <opcode><desc>Sets the level of a send to a buss.</desc><synopsis><opcodename>MixerSetLevel</opcodename> isend, ibuss, kgain</synopsis></opcode>
+ <opcode><desc>Sets the level of a send to a buss.</desc><synopsis><opcodename>MixerSetLevel_i</opcodename> isend, ibuss, igain</synopsis></opcode>
+ </category>
+-<category name="Python Opcodes">
+-<opcode><desc>Assign the value of the given Csound variable to a Python variable possibly destroying its previous content.</desc><synopsis><opcodename>pyassign</opcodename> &quot;variable&quot;, kvalue</synopsis><synopsis><opcodename>pyassigni</opcodename> &quot;variable&quot;, ivalue</synopsis><synopsis><opcodename>pylassign</opcodename> &quot;variable&quot;, kvalue</synopsis><synopsis><opcodename>pylassigni</opcodename> &quot;variable&quot;, ivalue</synopsis><synopsis><opcodename>pyassignt</opcodename> ktrigger, &quot;variable&quot;, kvalue</synopsis><synopsis><opcodename>pylassignt</opcodename> ktrigger, &quot;variable&quot;, kvalue</synopsis></opcode>
+-<opcode><desc>Invoke the specified Python callable at
+- k-time and i-time (i suffix), passing the given arguments. The call is
+- perfomed in the global environment, and the result (the returning
+- value) is copied into the Csound output variables specified.</desc><synopsis> <opcodename>pycall</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kresult <opcodename>pycall1</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kresult1, kresult2 <opcodename>pycall2</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3 <opcodename>pycall3</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4 <opcodename>pycall4</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5 <opcodename>pycall5</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6 <opcodename>pycall6</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6, kr7 <opcodename>pycall7</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6, kr7, kr8 <opcodename>pycall8</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis> <opcodename>pycallt</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kresult <opcodename>pycall1t</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kresult1, kresult2 <opcodename>pycall2t</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3 <opcodename>pycall3t</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4 <opcodename>pycall4t</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5 <opcodename>pycall5t</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6 <opcodename>pycall6t</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6, kr7 <opcodename>pycall7t</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6, kr7, kr8 <opcodename>pycall8t</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis> <opcodename>pycalli</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>iresult <opcodename>pycall1i</opcodename> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>iresult1, iresult2 <opcodename>pycall2i</opcodename> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3 <opcodename>pycall3i</opcodename> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4 <opcodename>pycall4i</opcodename> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4, ir5 <opcodename>pycall5i</opcodename> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4, ir5, ir6 <opcodename>pycall6i</opcodename> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4, ir5, ir6, ir7 <opcodename>pycall7i</opcodename> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4, ir5, ir6, ir7, ir8 <opcodename>pycall8i</opcodename> &quot;callable&quot;, iarg1, ...</synopsis><synopsis><opcodename>pycalln</opcodename> &quot;callable&quot;, nresults, kresult1, ..., kresultn, karg1, ...</synopsis><synopsis><opcodename>pycallni</opcodename> &quot;callable&quot;, nresults, iresult1, ..., iresultn, iarg1, ...</synopsis><synopsis> <opcodename>pylcall</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kresult <opcodename>pylcall1</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kresult1, kresult2 <opcodename>pylcall2</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3 <opcodename>pylcall3</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4 <opcodename>pylcall4</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5 <opcodename>pylcall5</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6 <opcodename>pylcall6</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6, kr7 <opcodename>pylcall7</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6, kr7, kr8 <opcodename>pylcall8</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis> <opcodename>pylcallt</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kresult <opcodename>pylcall1t</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kresult1, kresult2 <opcodename>pylcall2t</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3 <opcodename>pylcall3t</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4 <opcodename>pylcall4t</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5 <opcodename>pylcall5t</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6 <opcodename>pylcall6t</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6, kr7 <opcodename>pylcall7t</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis>kr1, kr2, kr3, kr4, kr5, kr6, kr7, kr8 <opcodename>pylcall8t</opcodename> ktrigger, &quot;callable&quot;, karg1, ...</synopsis><synopsis> <opcodename>pylcalli</opcodename> &quot;callable&quot;, karg1, ...</synopsis><synopsis>iresult <opcodename>pylcall1i</opcodename> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>iresult1, iresult2 <opcodename>pylcall2i</opcodename> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3 <opcodename>pylcall3i</opcodename> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4 <opcodename>pylcall4i</opcodename> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4, ir5 <opcodename>pylcall5i</opcodename> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4, ir5, ir6 <opcodename>pylcall6i</opcodename> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4, ir5, ir6, ir7 <opcodename>pylcall7i</opcodename> &quot;callable&quot;, iarg1, ...</synopsis><synopsis>ir1, ir2, ir3, ir4, ir5, ir6, ir7, ir8 <opcodename>pylcall8i</opcodename> &quot;callable&quot;, iarg1, ...</synopsis><synopsis><opcodename>pylcalln</opcodename> &quot;callable&quot;, nresults, kresult1, ..., kresultn, karg1, ...</synopsis><synopsis><opcodename>pylcallni</opcodename> &quot;callable&quot;, nresults, iresult1, ..., iresultn, iarg1, ...</synopsis></opcode>
+-<opcode><desc>Evaluate a generic Python expression and store the result in a Csound variable at k-time or i-time (i suffix).</desc><synopsis>kresult <opcodename>pyeval</opcodename> &quot;expression&quot;</synopsis><synopsis>iresult <opcodename>pyevali</opcodename> &quot;expression&quot;</synopsis><synopsis>kresult <opcodename>pyleval</opcodename> &quot;expression&quot;</synopsis><synopsis>iresult <opcodename>pylevali</opcodename> &quot;expression&quot;</synopsis><synopsis>kresult <opcodename>pyevalt</opcodename> ktrigger, &quot;expression&quot;</synopsis><synopsis>kresult <opcodename>pylevalt</opcodename> ktrigger, &quot;expression&quot;</synopsis></opcode>
+-<opcode><desc>Execute a script from a file at k-time or i-time (i suffix).</desc><synopsis><opcodename>pyexec</opcodename> &quot;filename&quot;</synopsis><synopsis><opcodename>pyexeci</opcodename> &quot;filename&quot;</synopsis><synopsis><opcodename>pylexec</opcodename> &quot;filename&quot;</synopsis><synopsis><opcodename>pylexeci</opcodename> &quot;filename&quot;</synopsis><synopsis><opcodename>pyexect</opcodename> ktrigger, &quot;filename&quot;</synopsis><synopsis><opcodename>plyexect</opcodename> ktrigger, &quot;filename&quot;</synopsis></opcode>
+-<opcode><desc>Initialize the Python interpreter.</desc><synopsis><opcodename>pyinit</opcodename></synopsis></opcode>
+-<opcode><desc>Run a Python statement or block of statements.</desc><synopsis><opcodename>pyrun</opcodename> &quot;statement&quot;</synopsis><synopsis><opcodename>pyruni</opcodename> &quot;statement&quot;</synopsis><synopsis><opcodename>pylrun</opcodename> &quot;statement&quot;</synopsis><synopsis><opcodename>pylruni</opcodename> &quot;statement&quot;</synopsis><synopsis><opcodename>pyrunt</opcodename> ktrigger, &quot;statement&quot;</synopsis><synopsis><opcodename>pylrunt</opcodename> ktrigger, &quot;statement&quot;</synopsis></opcode>
+-</category>
+ <category name="Image Processing Opcodes">
+ <opcode><desc>Create an empty image of a given size.</desc><synopsis>iimagenum <opcodename>imagecreate</opcodename> iwidth, iheight</synopsis></opcode>
+ <opcode><desc>Frees memory allocated for a previously loaded or created image.</desc><synopsis><opcodename>imagefree</opcodename> iimagenum</synopsis></opcode>
diff --git a/opcodes/top.xml b/opcodes/top.xml
index 2db4b72..6402cc0 100644
--- a/opcodes/top.xml