summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile79
1 files changed, 13 insertions, 66 deletions
diff --git a/Makefile b/Makefile
index 8370780..20a2718 100644
--- a/Makefile
+++ b/Makefile
@@ -6,15 +6,13 @@
# on your system.
# *************************************************************************
BASENAME=Csound
-BASENAMEOLPC=OLPCsound
-VERSION=5.13
+VERSION=6.02
# export PATH=$PATH:/home/andres/bin/fop-0.20.5/
# export JAVA_HOME=/usr/lib/jvm/java-6-sun/
# Output Directories
HTML_DIR=html
-HTMLXO_DIR=manualOLPC
HTML_ONE_DIR=singleHTML
HTMLHELP_DIR=htmlhelp
MANPAGES_DIR=manpages
@@ -93,7 +91,8 @@ OPCODES = opcodes/0dbfs.xml opcodes/abetarand.xml \
opcodes/clfilt.xml opcodes/clip.xml opcodes/clock.xml \
opcodes/clockoff.xml opcodes/clockon.xml opcodes/cngoto.xml \
opcodes/comb.xml opcodes/control.xml opcodes/convle.xml \
- opcodes/convolve.xml opcodes/cos.xml opcodes/cosh.xml \
+ opcodes/convolve.xml opcodes/copya2ftab.xml opcodes/copyf2array.xml \
+ opcodes/cos.xml opcodes/cosh.xml \
opcodes/cosinv.xml opcodes/cps2pch.xml opcodes/cpsmidi.xml \
opcodes/cpsmidib.xml opcodes/cpsoct.xml opcodes/cpspch.xml \
opcodes/cpstmid.xml opcodes/cpstun.xml opcodes/cpstuni.xml \
@@ -110,7 +109,8 @@ OPCODES = opcodes/0dbfs.xml opcodes/abetarand.xml \
opcodes/distort1.xml opcodes/divides.xml opcodes/divz.xml \
opcodes/dollar.xml opcodes/downsamp.xml opcodes/dripwater.xml \
opcodes/dumpk.xml opcodes/dumpk2.xml opcodes/dumpk3.xml \
- opcodes/dumpk4.xml opcodes/duserrnd.xml opcodes/else.xml \
+ opcodes/dumpk4.xml opcodes/duserrnd.xml opcodes/dust.xml \
+ opcodes/dust2.xml opcodes/else.xml \
opcodes/elseif.xml opcodes/endif.xml opcodes/endin.xml \
opcodes/endop.xml opcodes/envlpx.xml opcodes/envlpxr.xml \
opcodes/equals.xml opcodes/event.xml opcodes/exitnow.xml \
@@ -149,11 +149,14 @@ OPCODES = opcodes/0dbfs.xml opcodes/abetarand.xml \
opcodes/follow.xml opcodes/follow2.xml opcodes/foscil.xml \
opcodes/foscili.xml opcodes/fout.xml opcodes/fouti.xml \
opcodes/foutir.xml opcodes/foutk.xml opcodes/fprintks.xml \
- opcodes/fprints.xml opcodes/frac.xml opcodes/ftchnls.xml \
+ opcodes/fprints.xml opcodes/frac.xml opcodes/fractalnoise.xml \
+ opcodes/ftchnls.xml \
opcodes/ftgen.xml opcodes/ftlen.xml opcodes/ftload.xml \
opcodes/ftloadk.xml opcodes/ftlptim.xml opcodes/ftmorf.xml \
opcodes/ftsave.xml opcodes/ftsavek.xml opcodes/ftsr.xml \
- opcodes/gain.xml opcodes/gauss.xml opcodes/gbuzz.xml \
+ opcodes/gain.xml opcodes/gauss.xml opcodes/gausstrig.xml \
+ opcodes/gbuzz.xml opcodes/gendy.xml opcodes/gendyc.xml \
+ opcodes/gendyx.xml \
opcodes/gogobel.xml opcodes/goto.xml opcodes/grain.xml \
opcodes/grain2.xml opcodes/grain3.xml opcodes/granule.xml \
opcodes/greaterequal.xml opcodes/greaterthan.xml opcodes/guiro.xml \
@@ -257,6 +260,8 @@ OPCODES = opcodes/0dbfs.xml opcodes/abetarand.xml \
opcodes/powoftwo.xml opcodes/prealloc.xml opcodes/print.xml \
opcodes/printk.xml opcodes/printk2.xml opcodes/printks.xml \
opcodes/prints.xml opcodes/product.xml opcodes/pset.xml \
+ opcodes/ptable.xml opcodes/ptable3.xml opcodes/ptablei.xml \
+ opcodes/ptablew.xml \
opcodes/pvadd.xml opcodes/pvbufread.xml opcodes/pvcross.xml \
opcodes/pvinterp.xml opcodes/pvoc.xml opcodes/pvread.xml \
opcodes/pvsadsyn.xml opcodes/pvsanal.xml opcodes/pvsarp.xml \
@@ -489,48 +494,6 @@ html-bw: $(XSL_HTML) manual.xml $(SRCS) Makefile
rm -rf ${HTML_DIR}/images/callouts/CVS
rm -rf ${HTML_DIR}/examples/CVS
-htmlXO: $(XSL_HTML) manualXO.xml $(SRCS) Makefile
- -mkdir -p ${HTMLXO_DIR}
- xsltproc --xinclude -o ${HTMLXO_DIR}/ ${XSL_HTML} manualXO.xml
- cp -R images ${HTMLXO_DIR}/
- cp -R imagesXO ${HTMLXO_DIR}/
- cp -R examples ${HTMLXO_DIR}/
- cp copying.txt ${HTMLXO_DIR}/
- cp csoundXO.css ${HTMLXO_DIR}/csound.css
- rm -rf ${HTMLXO_DIR}/flbutbank.png
- rm -rf ${HTMLXO_DIR}/flbutton.png
- rm -rf ${HTMLXO_DIR}/flcount.png
- rm -rf ${HTMLXO_DIR}/flknob_3d.png
- rm -rf ${HTMLXO_DIR}/flknob_clock.png
- rm -rf ${HTMLXO_DIR}/flknob_flat.png
- rm -rf ${HTMLXO_DIR}/flknob_pie.png
- rm -rf ${HTMLXO_DIR}/flpack.png
- rm -rf ${HTMLXO_DIR}/flpanel.png
- rm -rf ${HTMLXO_DIR}/flroller.png
- rm -rf ${HTMLXO_DIR}/flscroll.png
- rm -rf ${HTMLXO_DIR}/flslider_horizontal-engraved.png
- rm -rf ${HTMLXO_DIR}/flslider_horizontal-fill.png
- rm -rf ${HTMLXO_DIR}/flslider_horizontal-nice.png
- rm -rf ${HTMLXO_DIR}/fltabs.png
- rm -rf ${HTMLXO_DIR}/fltabs_joysticks-tab.png
- rm -rf ${HTMLXO_DIR}/fltabs_rollers-tab.png
- rm -rf ${HTMLXO_DIR}/fltabs_sliders-tab.png
- rm -rf ${HTMLXO_DIR}/fltext.png
- rm -rf ${HTMLXO_DIR}/symbols.png
- rm -rf ${HTMLXO_DIR}/virtualkeyboard.png
- rm -rf ${HTMLXO_DIR}/images/CVS
- rm -rf ${HTMLXO_DIR}/images/callouts/CVS
- rm -rf ${HTMLXO_DIR}/examples/CVS
-
-bundleXO: htmlXO
- cp -R ${HTMLXO_DIR} ${BASENAMEOLPC}${VERSION}_manual
- mkdir $(BASENAMEOLPC)$(VERSION)_manual/library
- cp XO/library.info $(BASENAMEOLPC)$(VERSION)_manual/library
- rm -Rd $(BASENAMEOLPC)$(VERSION)_manual.xol
- zip -r /tmp/$(BASENAMEOLPC)$(VERSION)_manual.xol ${BASENAMEOLPC}${VERSION}_manual
- mv /tmp/$(BASENAMEOLPC)$(VERSION)_manual.xol ./
- rm -Rd $(BASENAMEOLPC)$(VERSION)_manual
-
html-onechunk: $(XSL_HTML_ONECHUNK) manual.xml $(SRCS) Makefile
-mkdir -p ${HTML_ONE_DIR}
xsltproc --xinclude -o ${HTML_ONE_DIR}/ ${XSL_HTML_ONECHUNK} manual.xml
@@ -547,23 +510,12 @@ pdf: $(XSL_PRINT) manual.xml $(SRCS) Makefile
fop.sh -fo $(BASENAME)$(VERSION)_manual.fo -pdf $(BASENAME)$(VERSION)_manual.pdf
rm $(BASENAME)$(VERSION)_manual.fo
-pdfXO: $(XSL_PRINT) manualXO.xml $(SRCS) Makefile
- xsltproc --xinclude -o $(BASENAMEOLPC)$(VERSION)_manual.fo ${XSL_PRINT} manualXO.xml
- fop.sh -fo $(BASENAMEOLPC)$(VERSION)_manual.fo -pdf $(BASENAMEOLPC)$(VERSION)_manual.pdf
- rm $(BASENAMEOLPC)$(VERSION)_manual.fo
-
pdfA4: $(XSL_PRINT) manual.xml $(SRCS) Makefile
xsltproc --stringparam paper.type A4 --xinclude \
-o $(BASENAME)$(VERSION)_manual_A4.fo ${XSL_PRINT} manual.xml
fop.sh -fo $(BASENAME)$(VERSION)_manual_A4.fo -pdf $(BASENAME)$(VERSION)_manual_A4.pdf
rm $(BASENAME)$(VERSION)_manual_A4.fo
-pdfA4XO: $(XSL_PRINT) manualXO.xml $(SRCS) Makefile
- xsltproc --stringparam paper.type A4 --xinclude \
- -o $(BASENAMEOLPC)$(VERSION)_manual_A4.fo ${XSL_PRINT} manualXO.xml
- fop.sh -fo $(BASENAMEOLPC)$(VERSION)_manual_A4.fo -pdf $(BASENAMEOLPC)$(VERSION)_manual_A4.pdf
- rm $(BASENAMEOLPC)$(VERSION)_manual_A4.fo
-
htmlhelp: ${XSL_HTMLHELP} manual.xml $(SRCS)
-mkdir -p ${HTMLHELP_DIR}
xsltproc --xinclude -o ${HTMLHELP_DIR}/ ${XSL_HTMLHELP} manual.xml
@@ -584,11 +536,6 @@ html-clean:
rm -rf html
rm -f examples/*.csd~
-xo-clean:
- rm -rf htmlXO
- rm -rf ${HTMLXO_DIR}
- rm -f *.xol
-
pdf-clean:
rm -f *.pdf *.fo
@@ -599,7 +546,7 @@ htmlhelp-clean:
manpages-clean:
rm -rf manpages
-clean: html-clean pdf-clean htmlhelp-clean manpages-clean xo-clean
+clean: html-clean pdf-clean htmlhelp-clean manpages-clean
rm -f $(XSL_HTML) $(XSL_HTML_ONECHUNK) $(XSL_PRINT) $(XSL_HTMLHELP)
distclean: clean