summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelipe Sateler <fsateler@gmail.com>2015-11-30 10:02:13 -0300
committerFelipe Sateler <fsateler@debian.org>2019-07-27 09:29:39 -0400
commit6d01039df599de966fb713fb2b929ebea91762c0 (patch)
tree4a338fbbb6ed7b3bb59fd39bddb1ec9057adb9b2
parentf2d095276df2b0bc1b44fbb4c572a6797a1edcd4 (diff)
Only link to lua when necessary, and to the correct lib
Lua policy recommends not linking against the lua library, because it doesn't help at all. All lua-using programs will load the library, not the modules. TODO: The csound-lua bridge is not implemented in cmake yet. The csound-lua bridge, on the other hand, needs to link to the library or else it will fail to load. Use the correct library name. Gbp-Pq: Topic debian-specific Gbp-Pq: Name lua-link.diff
-rw-r--r--interfaces/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/interfaces/CMakeLists.txt b/interfaces/CMakeLists.txt
index 69e8d54c..ad152ff5 100644
--- a/interfaces/CMakeLists.txt
+++ b/interfaces/CMakeLists.txt
@@ -209,7 +209,7 @@ endif()
endif()
if(BUILD_LUA_INTERFACE)
- set(swiglua_LIBS ${LUA_LIBRARY} ${CSOUNDLIB} libcsnd6)
+ set(swiglua_LIBS ${CSOUNDLIB} libcsnd6)
SET_SOURCE_FILES_PROPERTIES(lua_interface.i
PROPERTIES CPLUSPLUS ON