summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2017-08-18 16:02:52 +0200
committerJonas Smedegaard <dr@jones.dk>2017-08-18 16:02:52 +0200
commitbc02a6a06d67923443a0abb8e44820d600537476 (patch)
treeacd7421ae16e03f86a1161414cb69d3ee7def121
parent6dc298fb880e4cfd74dddb3417be95b60e856f66 (diff)
Tidy rules file: Group related hints together.
-rwxr-xr-xdebian/rules10
1 files changed, 7 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index b60cc43..e912f2b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,7 +7,6 @@ debian/control.in::
sed -e 's/__LIBPKGNAME__/$(libpkgname)/g' <debian/control.in.in >debian/control.in
include /usr/share/cdbs/1/rules/upstream-tarball.mk
-include /usr/share/pkg-kde-tools/makefiles/1/cdbs/symbolshelper.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/rules/utils.mk
include /usr/share/cdbs/1/class/cmake.mk
@@ -21,8 +20,7 @@ docpkgname = $(stem)-doc
utilspkg = $(stem)-utils
# Build Dependencies
-# * recent d-shlibs needed for --v5 option
-CDBS_BUILD_DEPENDS += , cmake, d-shlibs(>=0.61), pkg-kde-tools
+CDBS_BUILD_DEPENDS +=, cmake
# Multiarch quirks
CDBS_PREDEPENDS = $(if $(DEB_HOST_MULTIARCH),multiarch-support)
@@ -75,6 +73,9 @@ clean::
# Let d-shlibs calculate development package dependencies
# and handle shared library install
+# * Recent version needed for v5 option
+# TODO: drop v5 option when major version > 2
+CDBS_BUILD_DEPENDS +=, d-shlibs (>= 0.61~)
binary-post-install/$(libpkgname) binary-post-install/$(devpkgname):: debian/stamp-local-shlibs-$(libname)
debian/stamp-local-shlibs-$(libname): binary-install/$(libpkgname) binary-install/$(devpkgname)
d-shlibmove --commit \
@@ -93,3 +94,6 @@ clean::
binary-post-install/$(docpkgname)::
find debian/$(docpkgname)/usr/share/doc/$(docpkgname)/html/ -name "*.md5" -exec rm -vf {} \;
+# track symbols using pkgkde-symbolshelper
+CDBS_BUILD_DEPENDS +=, pkg-kde-tools
+include /usr/share/pkg-kde-tools/makefiles/1/cdbs/symbolshelper.mk