summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVasudev Kamath <kamathvasudev@gmail.com>2018-08-11 21:21:28 +0530
committerVasudev Kamath <vasudev@copyninja.info>2018-08-11 21:21:28 +0530
commit5fbdfa9a2a5ac20ba3c2dd13dd2332531ee355c0 (patch)
tree7b91a3c28226faec75e996b110177ba869dd66e4
parente96313b4cd21b2e3825238ba810dcc51a57a7ab6 (diff)
Fix the name of static library
Upstream named the static library in unusual way this patch names the static library in simpler way which suits Debian infrastructure. Forwarded: no Last-Update: 2012-12-19 Gbp-Pq: Name 2002_fix-static-libname.patch
-rw-r--r--CMakeLists.txt2
-rw-r--r--ctpp2.spec2
2 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 68aa2d0..b76a927 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -426,7 +426,7 @@ SET(LIBSRCS
# Lib binary
#
ADD_LIBRARY(ctpp2-static STATIC ${LIBSRCS})
-SET_TARGET_PROPERTIES(ctpp2-static PROPERTIES OUTPUT_NAME ctpp2-st)
+SET_TARGET_PROPERTIES(ctpp2-static PROPERTIES OUTPUT_NAME ctpp2)
SET_TARGET_PROPERTIES(ctpp2-static PROPERTIES LINKER_LANGUAGE CXX)
ADD_LIBRARY(ctpp2 SHARED ${LIBSRCS})
diff --git a/ctpp2.spec b/ctpp2.spec
index 026e737..2a51f8b 100644
--- a/ctpp2.spec
+++ b/ctpp2.spec
@@ -60,7 +60,7 @@ rm -rf %{buildroot}
%files devel
%defattr(-,root,root,-)
%{_includedir}/ctpp2
-%{_libdir}/libctpp2-st.a
+%{_libdir}/libctpp2.a
%changelog
* Sat Nov 10 2012 Alexander Pankov <pianist@usrsrc.ru> - 2.8.3-0