summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Nahmias <joe@nahmias.net>2012-12-07 22:08:34 -0500
committerJoe Nahmias <joe@nahmias.net>2012-12-07 22:08:34 -0500
commitdf7a0117e5a62ef92199ed7bd52abf623972833d (patch)
tree219b57d44a4d0459c0b0a6c5883215fa68094f42
parent879e6db06338166657609930768f76d8d7e7afbb (diff)
initial packaging
-rw-r--r--debian/README.Debian23
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control16
-rw-r--r--debian/copyright27
-rw-r--r--debian/docs4
-rwxr-xr-xdebian/rules11
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch6
9 files changed, 94 insertions, 0 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000..5a43c92
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,23 @@
+Here's how to configure a Canon BJNP printer with CUPS using the command-line:
+
+# Run bjnp to list active BJNP-listening printers on the local network
+$ /usr/lib/cups/backend/bjnp
+network bjnp://CANON-MP560.local:8611 "Canon MP560 series" "Canon MP560 series CANON-MP560.local" "MFG:Canon;CMD:BJL,BJRaster3,BSCCe,NCCe,IVEC,IVECPLI;SOJ:TXT01,BJNP2;MDL:MP560 series;CLS:PRINTER;DES:Canon MP560 series;VER:1.040;STA:10;FSI:00;HRI:PAM;MSI:DAT,E3,HFSF;PDR:3;"
+
+# Find an appropriate PPD for the printer on the system
+$ sudo lpinfo -m | grep -i canon | grep -i 560
+gutenprint.5.2://bjc-560i/expert Canon 560i - CUPS+Gutenprint v5.2.9
+gutenprint.5.2://bjc-i560/expert Canon i560 - CUPS+Gutenprint v5.2.9
+gutenprint.5.2://bjc-i560X/expert Canon i560X - CUPS+Gutenprint v5.2.9
+lsb/local/canonmp560.ppd Canon MP560 series Ver.3.20
+gutenprint.5.2://bjc-MULTIPASS-MP560/expert Canon PIXMA MP560 - CUPS+Gutenprint v5.2.9
+
+# Create the printer in CUPS, enable it, and set it as the default
+$ sudo lpadmin -p CanonMP560 -v bjnp://CANON-MP560.local:8611 -D "Canon MP560 series" -m lsb/local/canonmp560.ppd
+$ sudo cupsaccept CanonMP560
+$ sudo cupsenable CanonMP560
+$ sudo lpadmin -d CanonMP560
+
+# Looks good
+$ lpstat -a
+CanonMP560 accepting requests since Fri 07 Dec 2012 02:52:10 PM EST
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..6dd1e45
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+cups-bjnp (1.2-1) UNRELEASED; urgency=low
+
+ * Initial release, closes: #695401.
+
+ -- Joe Nahmias <jello@debian.org> Fri, 07 Dec 2012 13:29:38 -0500
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..291bc3b
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,16 @@
+Source: cups-bjnp
+Section: text
+Priority: optional
+Maintainer: Joe Nahmias <jello@debian.org>
+Build-Depends: debhelper (>= 9.0.0), autotools-dev, libcups2-dev
+Standards-Version: 3.9.3
+Homepage: http://cups-bjnp.sourceforge.net/
+
+Package: cups-bjnp
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: printer backend for Canon BJNP protocol
+ This package provides a back-end for CUPS printing system to interface
+ with Canon printers using the proprietary USB over IP BJNP protocol. This
+ back-end allows Cups to print over the network to a Canon printer and was
+ designed by reverse engineering the protocol.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..8769ea0
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,27 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: cups-bjnp
+Source: http://cups-bjnp.sourceforge.net/
+
+Files: *
+Copyright: 2008-2012 Louis Lagendijk <llagendijk@sourforge.net>
+License: GPL-2.0
+
+Files: debian/*
+Copyright: 2012 Joe Nahmias <jello@debian.org>
+License: GPL-2.0
+
+License: GPL-2.0
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of version 2 of the GNU General Public License as
+ published by the Free Software Foundation.
+ .
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ .
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>
+ .
+ On Debian systems, the complete text of the GNU General
+ Public License version 2 can be found in "/usr/share/common-licenses/GPL-2".
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..a016fd6
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1,4 @@
+NEWS
+README
+TODO
+AUTHORS
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..1bb0480
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+override_dh_auto_configure:
+ dh_auto_configure -- --with-cupsbackenddir=/usr/lib/cups/backend
+
+%:
+ dh $@ --with autotools-dev
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..a361d9e
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,6 @@
+# Compulsory line, this is a version 3 file
+version=3
+# See uscan(1) for format
+
+# Uncomment to find new files on sourceforge, for devscripts >= 2.9
+http://sf.net/cups-bjnp/cups-bjnp-(.*)\.tar\.gz