summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--INSTALL2
-rw-r--r--NEWS17
-rw-r--r--README25
-rwxr-xr-xconfigure20
-rw-r--r--configure.ac2
-rw-r--r--debian/.git-dpm14
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/0001-In-liblouis1.defs.gen.in-launch-sort-with-LC_ALL-C-f.patch23
-rw-r--r--debian/patches/series2
-rw-r--r--utils/cups-browsed.c4
-rw-r--r--utils/driverless.c4
11 files changed, 68 insertions, 51 deletions
diff --git a/INSTALL b/INSTALL
index 2887dcb74..8ba14e7d9 100644
--- a/INSTALL
+++ b/INSTALL
@@ -1,4 +1,4 @@
-INSTALL - OpenPrinting CUPS Filters v1.22.0 - 2019-01-18
+INSTALL - OpenPrinting CUPS Filters v1.22.1 - 2019-02-15
--------------------------------------------------------
This file describes how to compile and install OpenPrinting CUPS
diff --git a/NEWS b/NEWS
index 4984b23c9..827902ba5 100644
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,21 @@
-NEWS - OpenPrinting CUPS Filters v1.22.0 - 2019-01-18
+NEWS - OpenPrinting CUPS Filters v1.22.1 - 2019-02-15
-----------------------------------------------------
+CHANGES IN V1.22.1
+
+ - braille: Use sort command with LC_ALL=C for reproducibility
+ of the genrated files, needed for distribution packaging.
+ - cups-browsed, driverless: When polling the printer's
+ capabilities via get-printer-attributes IPP request for
+ driverless printing, use the attributes "all" and
+ "media-col-database". Without "all" some printers do not
+ report "urf-supported" and without "media-col-database" not
+ all paper size and marging info gets reported (Issue #22,
+ Pull request #86, CUPS issue #5484).
+ - braille: Document how to rework output before
+ embossing. Thanks to Samuel Thibault for this patch (Pull
+ request #90).
+
CHANGES IN V1.22.0
- pdftopdf: Use QPDF for flattening interactive PDF forms
diff --git a/README b/README
index cd6d96f3e..1e469a5a3 100644
--- a/README
+++ b/README
@@ -1,4 +1,4 @@
-README - OpenPrinting CUPS Filters v1.22.0 - 2019-01-18
+README - OpenPrinting CUPS Filters v1.22.1 - 2019-02-15
-------------------------------------------------------
Looking for compile instructions? Read the file "INSTALL.txt"
@@ -1817,6 +1817,29 @@ the default values are shown here.
lp -o "LibLouis=fr-fr-g1 LibLouis2=gr-gr-g1 TextDotDistance=250 LineSpacing=500" file.txt
+---------------------------------
+Reworking output before embossing
+---------------------------------
+
+One may want to check and modify the .brf or .ubrl output before sending it to
+the embosser. This can be achieved by first generating the .brf file:
+
+ /usr/sbin/cupsfilter -m application/vnd.cups-brf -p /etc/cups/ppd/yourprinter.ppd yourdocument.txt > ~/test.brf
+
+One can choose a ppd file and additionally pass -o options to control the
+generated output. One can then modify the .brf file with a text editor. One can
+then emboss it:
+
+ lp -o document-format=application/vnd.cups-brf ~/test.brf
+
+
+The same can be achieved for images:
+
+ /usr/sbin/cupsfilter -m image/vnd.cups-ubrl -p /etc/cups/ppd/yourprinter.ppd yourimage.png > ~/test.ubrl
+
+ lp -o document-format=image/vnd.cups-ubrl ~/test.ubrl
+
+
---------------
BRF file output
---------------
diff --git a/configure b/configure
index 64c16834b..fcf8c945a 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for cups-filters 1.22.0.
+# Generated by GNU Autoconf 2.69 for cups-filters 1.22.1.
#
#
# Copyright (C) 1992-1996, 1998-2012 Free Software Foundation, Inc.
@@ -587,8 +587,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='cups-filters'
PACKAGE_TARNAME='cups-filters'
-PACKAGE_VERSION='1.22.0'
-PACKAGE_STRING='cups-filters 1.22.0'
+PACKAGE_VERSION='1.22.1'
+PACKAGE_STRING='cups-filters 1.22.1'
PACKAGE_BUGREPORT=''
PACKAGE_URL=''
@@ -1500,7 +1500,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures cups-filters 1.22.0 to adapt to many kinds of systems.
+\`configure' configures cups-filters 1.22.1 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1571,7 +1571,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of cups-filters 1.22.0:";;
+ short | recursive ) echo "Configuration of cups-filters 1.22.1:";;
esac
cat <<\_ACEOF
@@ -1801,7 +1801,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-cups-filters configure 1.22.0
+cups-filters configure 1.22.1
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -2439,7 +2439,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by cups-filters $as_me 1.22.0, which was
+It was created by cups-filters $as_me 1.22.1, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -3474,7 +3474,7 @@ fi
# Define the identity of the package.
PACKAGE='cups-filters'
- VERSION='1.22.0'
+ VERSION='1.22.1'
cat >>confdefs.h <<_ACEOF
@@ -21790,7 +21790,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by cups-filters $as_me 1.22.0, which was
+This file was extended by cups-filters $as_me 1.22.1, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -21856,7 +21856,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-cups-filters config.status 1.22.0
+cups-filters config.status 1.22.1
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
diff --git a/configure.ac b/configure.ac
index 43cd49c9a..7a2563f6e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,7 +7,7 @@ AC_PREREQ([2.65])
# ====================
m4_define([cups_filters_version_major],[1])
m4_define([cups_filters_version_minor],[22])
-m4_define([cups_filters_version_micro],[0])
+m4_define([cups_filters_version_micro],[1])
m4_define([cups_filters_version],[cups_filters_version_major.cups_filters_version_minor.cups_filters_version_micro])
# =============
diff --git a/debian/.git-dpm b/debian/.git-dpm
index 033788f24..9608db648 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,8 +1,8 @@
# see git-dpm(1) from git-dpm package
-fbcc0d626982b354d1ae1a95f3552c29d3468e17
-fbcc0d626982b354d1ae1a95f3552c29d3468e17
-4bb9c034aa0d1c678590dc5930230444fef29233
-4bb9c034aa0d1c678590dc5930230444fef29233
-cups-filters_1.22.0.orig.tar.xz
-9abfcc5278dc5c7396a42afe85b5bc2cd923b3d5
-1474616
+0030fffefd69db302f302c3494a08f192609b2a2
+0030fffefd69db302f302c3494a08f192609b2a2
+0030fffefd69db302f302c3494a08f192609b2a2
+0030fffefd69db302f302c3494a08f192609b2a2
+cups-filters_1.22.1.orig.tar.xz
+801dcab01d670a21a3f6f8574f027e59fa40673a
+1475456
diff --git a/debian/changelog b/debian/changelog
index 502e9ff04..b9ba4d3bb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+cups-filters (1.22.1-1) experimental; urgency=medium
+
+ * New upstream version 1.22.1
+
+ -- Didier Raboud <odyx@debian.org> Sat, 16 Feb 2019 14:09:02 +0100
+
cups-filters (1.22.0-1) experimental; urgency=low
* New upstream version 1.22.0
diff --git a/debian/patches/0001-In-liblouis1.defs.gen.in-launch-sort-with-LC_ALL-C-f.patch b/debian/patches/0001-In-liblouis1.defs.gen.in-launch-sort-with-LC_ALL-C-f.patch
deleted file mode 100644
index 2de7c87e5..000000000
--- a/debian/patches/0001-In-liblouis1.defs.gen.in-launch-sort-with-LC_ALL-C-f.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From fbcc0d626982b354d1ae1a95f3552c29d3468e17 Mon Sep 17 00:00:00 2001
-From: Didier Raboud <odyx@debian.org>
-Date: Mon, 17 Dec 2018 21:55:31 +0100
-Subject: In liblouis1.defs.gen.in; launch sort with LC_ALL=C for
- reproducibility
-
----
- filter/braille/filters/liblouis1.defs.gen.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/filter/braille/filters/liblouis1.defs.gen.in b/filter/braille/filters/liblouis1.defs.gen.in
-index ae7480327..fc53bb5b4 100644
---- a/filter/braille/filters/liblouis1.defs.gen.in
-+++ b/filter/braille/filters/liblouis1.defs.gen.in
-@@ -277,7 +277,7 @@ echo ' Choice "HyphLocale/Default hyphenation rules for language" ""'
- echo "$file:$LANGUAGE:$LOCATION:hyphenation rules:"
- done
-
--) | sort -f -t : -k 2,3 | (
-+) | LC_ALL=C sort -f -t : -k 2,3 | (
-
- IFS=:
- while read file LANGUAGE LOCATION TYPE DISPLAY_NAME
diff --git a/debian/patches/series b/debian/patches/series
index 2f6a0b39c..a22980abc 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,2 @@
-0001-In-liblouis1.defs.gen.in-launch-sort-with-LC_ALL-C-f.patch
+
auto-gitignore
diff --git a/utils/cups-browsed.c b/utils/cups-browsed.c
index 220d862e6..c1921d6f5 100644
--- a/utils/cups-browsed.c
+++ b/utils/cups-browsed.c
@@ -3846,9 +3846,7 @@ get_printer_attributes(const char* uri) {
char valuebuffer[65536];
static const char * const pattrs[] =
{
- "job-template",
- "printer-defaults",
- "printer-description",
+ "all",
"media-col-database"
};
/* Request printer properties via IPP to generate a PPD file for the
diff --git a/utils/driverless.c b/utils/driverless.c
index a46a2a3d0..6371bdbcd 100644
--- a/utils/driverless.c
+++ b/utils/driverless.c
@@ -479,9 +479,7 @@ generate_ppd (const char *uri)
int i, fd, bytes;
static const char * const pattrs[] =
{
- "job-template",
- "printer-defaults",
- "printer-description",
+ "all",
"media-col-database"
};