summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2018-04-11 17:03:18 +0200
committerDidier Raboud <odyx@debian.org>2018-04-11 17:03:19 +0200
commit263eba23688b02662a4d8d5ab002c51b318f7100 (patch)
treed5ed1848c5c7d05f29ed0931aaed0243fad0f07a
parentd8f9ab0eb88682ad5e04389b4c2b32a7973033ad (diff)
parent0fdbbada68732840ad991fb0f2be4ec4021185b0 (diff)
merge patched-debian/master into debian/master
-rw-r--r--debian/.git-dpm4
-rw-r--r--debian/patches/0038-The-lp-and-lpr-commands-now-provide-better-error-mes.patch (renamed from debian/patches/0039-The-lp-and-lpr-commands-now-provide-better-error-mes.patch)2
-rw-r--r--debian/patches/0039-Fix-another-CUPS-Create-Local-Printer-crash-Issue-52.patch31
-rw-r--r--debian/patches/manpage-translations.patch6
-rw-r--r--debian/patches/printer-filtering.patch2
-rw-r--r--debian/patches/pwg-raster-attributes.patch2
-rw-r--r--debian/patches/read-embedded-options-from-incoming-postscript-and-add-to-ipp-attrs.patch2
-rw-r--r--debian/patches/series3
-rw-r--r--packaging/cups.spec435
-rw-r--r--scheduler/ipp.c4
10 files changed, 46 insertions, 445 deletions
diff --git a/debian/.git-dpm b/debian/.git-dpm
index 5fba12dad..85db69ddd 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,6 +1,6 @@
# see git-dpm(1) from git-dpm package
-0281f2ccec886cb2b864f64bb67b37a5f10b3589
-0281f2ccec886cb2b864f64bb67b37a5f10b3589
+0fdbbada68732840ad991fb0f2be4ec4021185b0
+0fdbbada68732840ad991fb0f2be4ec4021185b0
84c97c051db7de61342461b6333a6bf31830535e
84c97c051db7de61342461b6333a6bf31830535e
cups_2.2.7.orig.tar.gz
diff --git a/debian/patches/0039-The-lp-and-lpr-commands-now-provide-better-error-mes.patch b/debian/patches/0038-The-lp-and-lpr-commands-now-provide-better-error-mes.patch
index 5be34f09c..ca5e0926d 100644
--- a/debian/patches/0039-The-lp-and-lpr-commands-now-provide-better-error-mes.patch
+++ b/debian/patches/0038-The-lp-and-lpr-commands-now-provide-better-error-mes.patch
@@ -1,4 +1,4 @@
-From 0281f2ccec886cb2b864f64bb67b37a5f10b3589 Mon Sep 17 00:00:00 2001
+From a055af60a379210b5b2bb2941b540672b3cf4ac3 Mon Sep 17 00:00:00 2001
From: Michael R Sweet <michaelrsweet@gmail.com>
Date: Wed, 1 Nov 2017 15:45:50 -0400
Subject: =?UTF-8?q?The=20`lp`=20and=20`lpr`=20commands=20now=20provide=20b?=
diff --git a/debian/patches/0039-Fix-another-CUPS-Create-Local-Printer-crash-Issue-52.patch b/debian/patches/0039-Fix-another-CUPS-Create-Local-Printer-crash-Issue-52.patch
new file mode 100644
index 000000000..1bf01bfc9
--- /dev/null
+++ b/debian/patches/0039-Fix-another-CUPS-Create-Local-Printer-crash-Issue-52.patch
@@ -0,0 +1,31 @@
+From 2698468d583471153802f8d960563ad3fce62cee Mon Sep 17 00:00:00 2001
+From: Michael R Sweet <michael.r.sweet@gmail.com>
+Date: Mon, 9 Apr 2018 15:30:52 -0400
+Subject: Fix another CUPS-Create-Local-Printer crash (Issue #5290)
+
+---
+ scheduler/ipp.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/scheduler/ipp.c b/scheduler/ipp.c
+index b82b61acf..67691c3f0 100644
+--- a/scheduler/ipp.c
++++ b/scheduler/ipp.c
+@@ -5365,6 +5365,8 @@ create_local_bg_thread(
+
+ if (_ppdCreateFromIPP(fromppd, sizeof(fromppd), response))
+ {
++ _cupsRWLockWrite(&printer->lock);
++
+ if ((!printer->info || !*(printer->info)) && (attr = ippFindAttribute(response, "printer-info", IPP_TAG_TEXT)) != NULL)
+ cupsdSetString(&printer->info, ippGetString(attr, 0, NULL));
+
+@@ -5374,6 +5376,8 @@ create_local_bg_thread(
+ if ((!printer->geo_location || !*(printer->geo_location)) && (attr = ippFindAttribute(response, "printer-geo-location", IPP_TAG_URI)) != NULL)
+ cupsdSetString(&printer->geo_location, ippGetString(attr, 0, NULL));
+
++ _cupsRWUnlock(&printer->lock);
++
+ if ((from = cupsFileOpen(fromppd, "r")) == NULL)
+ {
+ cupsdLogMessage(CUPSD_LOG_ERROR, "%s: Unable to read generated PPD: %s", printer->name, strerror(errno));
diff --git a/debian/patches/manpage-translations.patch b/debian/patches/manpage-translations.patch
index 630209b72..50c58d8b6 100644
--- a/debian/patches/manpage-translations.patch
+++ b/debian/patches/manpage-translations.patch
@@ -1,4 +1,4 @@
-From 9a00894a4f40e1a7b8c13e27f8a88e2e15e56343 Mon Sep 17 00:00:00 2001
+From 0fdbbada68732840ad991fb0f2be4ec4021185b0 Mon Sep 17 00:00:00 2001
From: Didier Raboud <odyx@debian.org>
Date: Tue, 9 Aug 2016 18:11:50 +0200
Subject: po4a infrastructure and translations for manpages.
@@ -12,8 +12,8 @@ Bug-Debian: http://bugs.debian.org/478597
Patch-Name: manpage-translations.patch
---
- man/Makefile | 15 +++-
- man/Makefile.l10n | 246 ++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ man/Makefile | 15 ++-
+ man/Makefile.l10n | 246 ++++++++++++++++++++++++++++++++++++++++++++++
man/de/Makefile | 7 ++
man/fr/Makefile | 7 ++
4 files changed, 274 insertions(+), 1 deletion(-)
diff --git a/debian/patches/printer-filtering.patch b/debian/patches/printer-filtering.patch
index 9a63d1ea9..72508c601 100644
--- a/debian/patches/printer-filtering.patch
+++ b/debian/patches/printer-filtering.patch
@@ -9,7 +9,7 @@ Last-Update: 2015-10-02
=== modified file 'cups-1.3.9/cups/ipp.c'
Patch-Name: printer-filtering.patch
---
- cups/ipp.c | 116 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ cups/ipp.c | 116 +++++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 116 insertions(+)
diff --git a/cups/ipp.c b/cups/ipp.c
diff --git a/debian/patches/pwg-raster-attributes.patch b/debian/patches/pwg-raster-attributes.patch
index a909b3a99..5ac02663b 100644
--- a/debian/patches/pwg-raster-attributes.patch
+++ b/debian/patches/pwg-raster-attributes.patch
@@ -10,7 +10,7 @@ Bug-Upstream: https://www.cups.org/str.php?L4428
Last-Update: 2015-02-10
Patch-Name: pwg-raster-attributes.patch
---
- scheduler/printers.c | 77 +++++++++++++++++++++++++++++++++++++++++++++++++++-
+ scheduler/printers.c | 77 +++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 76 insertions(+), 1 deletion(-)
diff --git a/scheduler/printers.c b/scheduler/printers.c
diff --git a/debian/patches/read-embedded-options-from-incoming-postscript-and-add-to-ipp-attrs.patch b/debian/patches/read-embedded-options-from-incoming-postscript-and-add-to-ipp-attrs.patch
index 88602d942..d2df04db4 100644
--- a/debian/patches/read-embedded-options-from-incoming-postscript-and-add-to-ipp-attrs.patch
+++ b/debian/patches/read-embedded-options-from-incoming-postscript-and-add-to-ipp-attrs.patch
@@ -15,7 +15,7 @@ Last-Update: 2015-02-10
Patch-Name: read-embedded-options-from-incoming-postscript-and-add-to-ipp-attrs.patch
---
- scheduler/ipp.c | 84 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ scheduler/ipp.c | 84 +++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 84 insertions(+)
diff --git a/scheduler/ipp.c b/scheduler/ipp.c
diff --git a/debian/patches/series b/debian/patches/series
index f1da6d720..e478956f6 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -35,5 +35,6 @@ cups-set-default-error-policy-retry-job.patch
man-cups-lpd-drop-dangling-references.patch
debianize_cups-config.patch
0037-Build-mantohtml-with-the-build-architecture-compiler.patch
+0038-The-lp-and-lpr-commands-now-provide-better-error-mes.patch
+0039-Fix-another-CUPS-Create-Local-Printer-crash-Issue-52.patch
manpage-translations.patch
-0039-The-lp-and-lpr-commands-now-provide-better-error-mes.patch
diff --git a/packaging/cups.spec b/packaging/cups.spec
deleted file mode 100644
index d58248936..000000000
--- a/packaging/cups.spec
+++ /dev/null
@@ -1,435 +0,0 @@
-#
-# RPM "spec" file for CUPS.
-#
-# Original version by Jason McMullan <jmcc@ontv.com>.
-#
-# Copyright 2007-2017 by Apple Inc.
-# Copyright 1999-2007 by Easy Software Products, all rights reserved.
-#
-# These coded instructions, statements, and computer programs are the
-# property of Apple Inc. and are protected by Federal copyright
-# law. Distribution and use rights are outlined in the file "LICENSE.txt"
-# which should have been included with this file. If this file is
-# file is missing or damaged, see the license at "http://www.cups.org/".
-#
-
-# Conditional build options (--with name/--without name):
-#
-# dbus - Enable/disable DBUS support (default = enable)
-# dnssd - Enable/disable DNS-SD support (default = enable)
-# libusb1 - Enable/disable LIBUSB 1.0 support (default = enable)
-# static - Enable/disable static libraries (default = enable)
-# systemd - Enable/disable systemd support (default = enable)
-
-%{!?_with_dbus: %{!?_without_dbus: %define _with_dbus --with-dbus}}
-%{?_with_dbus: %define _dbus --enable-dbus}
-%{!?_with_dbus: %define _dbus --disable-dbus}
-
-%{!?_with_dnssd: %{!?_without_dnssd: %define _with_dnssd --with-dnssd}}
-%{?_with_dnssd: %define _dnssd --enable-avahi}
-%{!?_with_dnssd: %define _dnssd --disable-avahi}
-
-%{!?_with_libusb1: %{!?_without_libusb1: %define _with_libusb1 --with-libusb1}}
-%{?_with_libusb1: %define _libusb1 --enable-libusb}
-%{!?_with_libusb1: %define _libusb1 --disable-libusb}
-
-%{!?_with_static: %{!?_without_static: %define _without_static --without-static}}
-%{?_with_static: %define _static --enable-static}
-%{!?_with_static: %define _static --disable-static}
-
-%{!?_with_systemd: %{!?_without_systemd: %define _with_systemd --with-systemd}}
-%{?_with_systemd: %define _systemd --enable-systemd}
-%{!?_with_systemd: %define _systemd --disable-systemd}
-
-Summary: CUPS
-Name: cups
-Version: 2.2.7
-Release: 0
-Epoch: 1
-License: GPL
-Group: System Environment/Daemons
-Source: https://github.com/apple/cups/releases/download/v2.2.7/cups-2.2.7-source.tar.gz
-Url: http://www.cups.org
-Packager: Anonymous <anonymous@example.com>
-Vendor: Example Corp
-
-# Package names are as defined for Red Hat (and clone) distributions
-BuildRequires: gnutls-devel, pam-devel
-
-%if %{?_with_dbus:1}%{!?_with_dbus:0}
-BuildRequires: dbus-devel
-%endif
-
-%if %{?_with_dnssd:1}%{!?_with_dnssd:0}
-BuildRequires: avahi-devel
-%endif
-
-%if %{?_with_libusb1:1}%{!?_with_libusb1:0}
-BuildRequires: libusb-devel >= 1.0
-%endif
-
-%if %{?_with_systemd:1}%{!?_with_systemd:0}
-BuildRequires: systemd-devel
-%endif
-
-# Use buildroot so as not to disturb the version already installed
-BuildRoot: /tmp/%{name}-root
-
-# Dependencies...
-Requires: %{name}-libs = %{epoch}:%{version}
-Obsoletes: lpd, lpr, LPRng
-Provides: lpd, lpr, LPRng
-Obsoletes: cups-da, cups-de, cups-es, cups-et, cups-fi, cups-fr, cups-he
-Obsoletes: cups-id, cups-it, cups-ja, cups-ko, cups-nl, cups-no, cups-pl
-Obsoletes: cups-pt, cups-ru, cups-sv, cups-zh
-
-%package devel
-Summary: CUPS - development environment
-Group: Development/Libraries
-Requires: %{name}-libs = %{epoch}:%{version}
-
-%package libs
-Summary: CUPS - shared libraries
-Group: System Environment/Libraries
-Provides: libcups1
-
-%package lpd
-Summary: CUPS - LPD support
-Group: System Environment/Daemons
-Requires: %{name} = %{epoch}:%{version} xinetd
-
-%description
-CUPS is the standards-based, open source printing system developed by
-Apple Inc. for macOS® and other UNIX®-like operating systems.
-
-%description devel
-This package provides the CUPS headers and development environment.
-
-%description libs
-This package provides the CUPS shared libraries.
-
-%description lpd
-This package provides LPD client support.
-
-%prep
-%setup
-
-%build
-CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_OPT_FLAGS" \
- ./configure %{_dbus} %{_dnssd} %{_libusb1} %{_static} %{_systemd}
-# If we got this far, all prerequisite libraries must be here.
-make
-
-%install
-# Make sure the RPM_BUILD_ROOT directory exists.
-rm -rf $RPM_BUILD_ROOT
-
-make BUILDROOT=$RPM_BUILD_ROOT install
-rm -rf $RPM_BUILD_ROOT/usr/share/cups/banners $RPM_BUILD_ROOT/usr/share/cups/data
-
-%post
-%if %{?_with_systemd:1}%{!?_with_systemd:0}
-/bin/systemctl enable org.cups.cupsd.service
-
-if test $1 -ge 1; then
- /bin/systemctl stop org.cups.cupsd.service
- /bin/systemctl start org.cups.cupsd.service
-fi
-
-%else
-/sbin/chkconfig --add cups
-/sbin/chkconfig cups on
-
-# Restart cupsd if we are upgrading...
-if test $1 -gt 1; then
- /sbin/service cups stop
- /sbin/service cups start
-fi
-%endif
-
-%post libs
-/sbin/ldconfig
-
-%preun
-%if %{?_with_systemd:1}%{!?_with_systemd:0}
-if test $1 -ge 1; then
- /bin/systemctl stop org.cups.cupsd.service
- /bin/systemctl disable org.cups.cupsd.service
-fi
-
-%else
-if test $1 = 0; then
- /sbin/service cups stop
- /sbin/chkconfig --del cups
-fi
-%endif
-
-%postun
-%if %{?_with_systemd:1}%{!?_with_systemd:0}
-if test $1 -ge 1; then
- /bin/systemctl stop org.cups.cupsd.service
- /bin/systemctl start org.cups.cupsd.service
-fi
-
-%else
-if test $1 -ge 1; then
- /sbin/service cups stop
- /sbin/service cups start
-fi
-%endif
-
-%postun libs
-/sbin/ldconfig
-
-%clean
-rm -rf $RPM_BUILD_ROOT
-
-%files
-%docdir /usr/share/doc/cups
-%defattr(-,root,root)
-%dir /etc/cups
-%config(noreplace) /etc/cups/*.conf
-/etc/cups/cups-files.conf.default
-/etc/cups/cupsd.conf.default
-/etc/cups/snmp.conf.default
-%dir /etc/cups/ppd
-%attr(0700,root,root) %dir /etc/cups/ssl
-
-%if %{?_with_dbus:1}%{!?_with_dbus:0}
-# DBUS
-/etc/dbus-1/system.d/*
-%endif
-
-# PAM
-%dir /etc/pam.d
-/etc/pam.d/*
-
-%if %{?_with_systemd:1}%{!?_with_systemd:0}
-# SystemD
-/usr/lib/systemd/system/org.cups.cupsd.*
-
-%else
-# Legacy init support on Linux
-/etc/init.d/*
-/etc/rc0.d/*
-/etc/rc2.d/*
-/etc/rc3.d/*
-/etc/rc5.d/*
-%endif
-
-/usr/bin/cancel
-/usr/bin/cupstestdsc
-/usr/bin/cupstestppd
-/usr/bin/ipptool
-/usr/bin/lp*
-%dir /usr/lib/cups
-%dir /usr/lib/cups/backend
-%if %{?_with_dnssd:1}%{!?_with_dnssd:0}
-# DNS-SD
-/usr/bin/ippfind
-/usr/lib/cups/backend/dnssd
-%endif
-/usr/lib/cups/backend/http
-/usr/lib/cups/backend/https
-%attr(0700,root,root) /usr/lib/cups/backend/ipp
-/usr/lib/cups/backend/ipps
-%attr(0700,root,root) /usr/lib/cups/backend/lpd
-/usr/lib/cups/backend/snmp
-/usr/lib/cups/backend/socket
-/usr/lib/cups/backend/usb
-%dir /usr/lib/cups/cgi-bin
-/usr/lib/cups/cgi-bin/*
-%dir /usr/lib/cups/daemon
-/usr/lib/cups/daemon/cups-deviced
-/usr/lib/cups/daemon/cups-driverd
-/usr/lib/cups/daemon/cups-exec
-%dir /usr/lib/cups/driver
-%dir /usr/lib/cups/filter
-/usr/lib/cups/filter/*
-%dir /usr/lib/cups/monitor
-/usr/lib/cups/monitor/*
-%dir /usr/lib/cups/notifier
-/usr/lib/cups/notifier/*
-
-/usr/sbin/*
-%dir /usr/share/cups
-%dir /usr/share/cups/drv
-/usr/share/cups/drv/*
-%dir /usr/share/cups/ipptool
-/usr/share/cups/ipptool/*
-%dir /usr/share/cups/mime
-/usr/share/cups/mime/*
-%dir /usr/share/cups/model
-%dir /usr/share/cups/ppdc
-/usr/share/cups/ppdc/*
-%dir /usr/share/cups/templates
-/usr/share/cups/templates/*
-%if %{?_with_libusb1:1}%{!?_with_libusb1:0}
-# LIBUSB quirks files
-%dir /usr/share/cups/usb
-/usr/share/cups/usb/*
-%endif
-
-%dir /usr/share/doc/cups
-/usr/share/doc/cups/*.*
-%dir /usr/share/doc/cups/help
-/usr/share/doc/cups/help/accounting.html
-/usr/share/doc/cups/help/cgi.html
-/usr/share/doc/cups/help/encryption.html
-/usr/share/doc/cups/help/glossary.html
-/usr/share/doc/cups/help/kerberos.html
-/usr/share/doc/cups/help/license.html
-/usr/share/doc/cups/help/man-*.html
-/usr/share/doc/cups/help/network.html
-/usr/share/doc/cups/help/options.html
-/usr/share/doc/cups/help/overview.html
-/usr/share/doc/cups/help/policies.html
-/usr/share/doc/cups/help/ref-*.html
-/usr/share/doc/cups/help/security.html
-/usr/share/doc/cups/help/sharing.html
-/usr/share/doc/cups/help/translation.html
-%dir /usr/share/doc/cups/images
-/usr/share/doc/cups/images/*
-
-#%dir /usr/share/doc/cups/ca
-#/usr/share/doc/cups/ca/*
-#%dir /usr/share/doc/cups/cs
-#/usr/share/doc/cups/cs/*
-%dir /usr/share/doc/cups/de
-/usr/share/doc/cups/de/*
-%dir /usr/share/doc/cups/es
-/usr/share/doc/cups/es/*
-#%dir /usr/share/doc/cups/fr
-#/usr/share/doc/cups/fr/*
-%dir /usr/share/doc/cups/ja
-/usr/share/doc/cups/ja/*
-%dir /usr/share/doc/cups/pt_BR
-/usr/share/doc/cups/pt_BR/*
-%dir /usr/share/doc/cups/ru
-/usr/share/doc/cups/ru/*
-
-%dir /usr/share/locale/ca
-/usr/share/locale/ca/cups_ca.po
-%dir /usr/share/locale/cs
-/usr/share/locale/cs/cups_cs.po
-%dir /usr/share/locale/de
-/usr/share/locale/de/cups_de.po
-%dir /usr/share/locale/es
-/usr/share/locale/es/cups_es.po
-%dir /usr/share/locale/fr
-/usr/share/locale/fr/cups_fr.po
-%dir /usr/share/locale/it
-/usr/share/locale/it/cups_it.po
-%dir /usr/share/locale/ja
-/usr/share/locale/ja/cups_ja.po
-%dir /usr/share/locale/pt_BR
-/usr/share/locale/pt_BR/cups_pt_BR.po
-%dir /usr/share/locale/ru
-/usr/share/locale/ru/cups_ru.po
-%dir /usr/share/locale/zh_CN
-/usr/share/locale/zh_CN/cups_zh_CN.po
-
-%dir /usr/share/man/man1
-/usr/share/man/man1/cancel.1.gz
-/usr/share/man/man1/cups.1.gz
-/usr/share/man/man1/cupstestdsc.1.gz
-/usr/share/man/man1/cupstestppd.1.gz
-%if %{?_with_dnssd:1}%{!?_with_dnssd:0}
-# DNS-SD
-/usr/share/man/man1/ippfind.1.gz
-%endif
-/usr/share/man/man1/ipptool.1.gz
-/usr/share/man/man1/lp.1.gz
-/usr/share/man/man1/lpoptions.1.gz
-/usr/share/man/man1/lpq.1.gz
-/usr/share/man/man1/lpr.1.gz
-/usr/share/man/man1/lprm.1.gz
-/usr/share/man/man1/lpstat.1.gz
-%dir /usr/share/man/man5
-/usr/share/man/man5/*.conf.5.gz
-/usr/share/man/man5/cupsd-logs.5.gz
-/usr/share/man/man5/ipptoolfile.5.gz
-/usr/share/man/man5/mime.*.5.gz
-%dir /usr/share/man/man8
-/usr/share/man/man8/accept.8.gz
-/usr/share/man/man8/cups-deviced.8.gz
-/usr/share/man/man8/cups-driverd.8.gz
-/usr/share/man/man8/cups-exec.8.gz
-/usr/share/man/man8/cups-snmp.8.gz
-/usr/share/man/man8/cupsaddsmb.8.gz
-/usr/share/man/man8/cupsaccept.8.gz
-/usr/share/man/man8/cupsctl.8.gz
-/usr/share/man/man8/cupsfilter.8.gz
-/usr/share/man/man8/cupsd.8.gz
-/usr/share/man/man8/cupsd-helper.8.gz
-/usr/share/man/man8/cupsdisable.8.gz
-/usr/share/man/man8/cupsenable.8.gz
-/usr/share/man/man8/cupsreject.8.gz
-/usr/share/man/man8/lpadmin.8.gz
-/usr/share/man/man8/lpc.8.gz
-/usr/share/man/man8/lpinfo.8.gz
-/usr/share/man/man8/lpmove.8.gz
-/usr/share/man/man8/reject.8.gz
-
-%dir /var/cache/cups
-%attr(0775,root,sys) %dir /var/cache/cups/rss
-%dir /var/log/cups
-%dir /var/run/cups
-%attr(0711,lp,sys) %dir /var/run/cups/certs
-%attr(0710,lp,sys) %dir /var/spool/cups
-%attr(1770,lp,sys) %dir /var/spool/cups/tmp
-
-# Desktop files
-/usr/share/applications/*
-/usr/share/icons/*
-
-%files devel
-%defattr(-,root,root)
-%dir /usr/share/cups/examples
-/usr/share/cups/examples/*
-%dir /usr/share/man/man1
-/usr/share/man/man1/cups-config.1.gz
-/usr/share/man/man1/ppd*.1.gz
-%dir /usr/share/man/man5
-/usr/share/man/man5/ppdcfile.5.gz
-/usr/share/man/man7/backend.7.gz
-/usr/share/man/man7/filter.7.gz
-/usr/share/man/man7/notifier.7.gz
-
-/usr/bin/cups-config
-/usr/bin/ppd*
-%dir /usr/include/cups
-/usr/include/cups/*
-/usr/lib*/*.so
-
-%if %{?_with_static:1}%{!?_with_static:0}
-/usr/lib*/*.a
-%endif
-
-%dir /usr/share/doc/cups/help
-/usr/share/doc/cups/help/api*.html
-/usr/share/doc/cups/help/cupspm.html
-/usr/share/doc/cups/help/postscript-driver.html
-/usr/share/doc/cups/help/ppd-compiler.html
-/usr/share/doc/cups/help/raster-driver.html
-/usr/share/doc/cups/help/spec*.html
-
-%files libs
-%defattr(-,root,root)
-/usr/lib*/*.so.*
-
-%files lpd
-%defattr(-,root,root)
-%if %{?_with_systemd:1}%{!?_with_systemd:0}
-# SystemD
-/usr/lib/systemd/system/org.cups.cups-lpd*
-%else
-# Legacy xinetd
-/etc/xinetd.d/cups-lpd
-%endif
-
-%dir /usr/lib/cups
-%dir /usr/lib/cups/daemon
-/usr/lib/cups/daemon/cups-lpd
-%dir /usr/share/man/man8
-/usr/share/man/man8/cups-lpd.8.gz
diff --git a/scheduler/ipp.c b/scheduler/ipp.c
index b82b61acf..67691c3f0 100644
--- a/scheduler/ipp.c
+++ b/scheduler/ipp.c
@@ -5365,6 +5365,8 @@ create_local_bg_thread(
if (_ppdCreateFromIPP(fromppd, sizeof(fromppd), response))
{
+ _cupsRWLockWrite(&printer->lock);
+
if ((!printer->info || !*(printer->info)) && (attr = ippFindAttribute(response, "printer-info", IPP_TAG_TEXT)) != NULL)
cupsdSetString(&printer->info, ippGetString(attr, 0, NULL));
@@ -5374,6 +5376,8 @@ create_local_bg_thread(
if ((!printer->geo_location || !*(printer->geo_location)) && (attr = ippFindAttribute(response, "printer-geo-location", IPP_TAG_URI)) != NULL)
cupsdSetString(&printer->geo_location, ippGetString(attr, 0, NULL));
+ _cupsRWUnlock(&printer->lock);
+
if ((from = cupsFileOpen(fromppd, "r")) == NULL)
{
cupsdLogMessage(CUPSD_LOG_ERROR, "%s: Unable to read generated PPD: %s", printer->name, strerror(errno));