summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenshi Muto <kmuto@debian.org>2016-08-09 18:11:33 +0200
committerDidier Raboud <odyx@debian.org>2019-05-08 14:52:30 +0200
commitbfa36b7d15bca23c2aafc2910692fc2467df42d4 (patch)
treecdeab695c82fcb68a43c044d5f8aad642f9fa870
parent76762601727cf67a7ba90b5d6f8c98c0403fed81 (diff)
Do not write VCS tags into installed conffiles
Bug: http://www.cups.org/str.php?L2369 Origin: vendor Author: Didier Raboud <odyx@debian.org> Last-Update: 2014-01-16 Patch-Name: removecvstag.patch
-rw-r--r--conf/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/conf/Makefile b/conf/Makefile
index 42a123f75..db0060d75 100644
--- a/conf/Makefile
+++ b/conf/Makefile
@@ -69,8 +69,12 @@ install-data:
$(INSTALL_CONFIG) -g $(CUPS_GROUP) $$file $(SERVERROOT)/$$file.N ; \
else \
$(INSTALL_CONFIG) -g $(CUPS_GROUP) $$file $(SERVERROOT) ; \
+ grep -v "\$$Id[:\$$]" $(SERVERROOT)/$$file > $(SERVERROOT)/$$file.n ; \
+ mv $(SERVERROOT)/$$file.n $(SERVERROOT)/$$file ; \
fi ; \
$(INSTALL_CONFIG) -g $(CUPS_GROUP) $$file $(DATADIR)/$$file.default; \
+ grep -v "\$$Id[:\$$]" $(DATADIR)/$$file.default > $(DATADIR)/$$file.default.n ; \
+ mv $(DATADIR)/$$file.default.n $(DATADIR)/$$file.default ; \
done
$(INSTALL_DIR) -m 755 $(DATADIR)/mime
for file in $(REPLACE); do \