summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenshi Muto <kmuto@debian.org>2016-08-09 18:11:33 +0200
committerDidier Raboud <odyx@debian.org>2018-06-08 15:11:05 +0200
commitee1b364945c0aae61ec9bd03c2becb01ed68d83b (patch)
tree974a8c073d7da0d0f269a5307dd4fe291cc35703
parente44fc65be3e2b168a504ddb200e6569dd61ad9b2 (diff)
Do not write VCS tags into installed conffiles
Bug: http://www.cups.org/str.php?L2369 Origin: vendor Author: Didier Raboud <odyx@debian.org> Last-Update: 2014-01-16 Patch-Name: removecvstag.patch
-rw-r--r--conf/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/conf/Makefile b/conf/Makefile
index 42a123f75..db0060d75 100644
--- a/conf/Makefile
+++ b/conf/Makefile
@@ -69,8 +69,12 @@ install-data:
$(INSTALL_CONFIG) -g $(CUPS_GROUP) $$file $(SERVERROOT)/$$file.N ; \
else \
$(INSTALL_CONFIG) -g $(CUPS_GROUP) $$file $(SERVERROOT) ; \
+ grep -v "\$$Id[:\$$]" $(SERVERROOT)/$$file > $(SERVERROOT)/$$file.n ; \
+ mv $(SERVERROOT)/$$file.n $(SERVERROOT)/$$file ; \
fi ; \
$(INSTALL_CONFIG) -g $(CUPS_GROUP) $$file $(DATADIR)/$$file.default; \
+ grep -v "\$$Id[:\$$]" $(DATADIR)/$$file.default > $(DATADIR)/$$file.default.n ; \
+ mv $(DATADIR)/$$file.default.n $(DATADIR)/$$file.default ; \
done
$(INSTALL_DIR) -m 755 $(DATADIR)/mime
for file in $(REPLACE); do \