summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authormsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2009-10-15 18:50:47 +0000
committermsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2009-10-15 18:50:47 +0000
commit4d301e694f72b03ab2b6c8189387bd7076a3a2ea (patch)
tree3fe42587c15d843dd9eba082b9519ab52f2571cd /Makefile
parentb226ab99134159fff1c3192d3bf22d2652db386b (diff)
Merge changes from CUPS 1.5svn-r8849.
git-svn-id: svn+ssh://src.apple.com/svn/cups/easysw/current@1725 a1ca3aef-8c08-0410-bb20-df032aa958be
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile126
1 files changed, 4 insertions, 122 deletions
diff --git a/Makefile b/Makefile
index 586c9e6cd..80df66875 100644
--- a/Makefile
+++ b/Makefile
@@ -30,7 +30,7 @@ include Makedefs
DIRS = cups filter backend berkeley cgi-bin driver locale man monitor \
notifier ppdc scheduler systemv test \
$(PHPDIR) \
- conf data doc examples $(FONTS) templates
+ conf data desktop doc examples $(FONTS) templates
#
@@ -111,7 +111,6 @@ distclean: clean
$(RM) cups-config
$(RM) conf/cupsd.conf conf/mime.convs conf/pam.std conf/snmp.conf
$(RM) doc/help/ref-cupsd-conf.html doc/help/standard.html doc/index.html
- $(RM) init/cups.sh init/cups-lpd init/org.cups.cups-lpd.plist
$(RM) man/client.conf.man
$(RM) man/cups-deviced.man man/cups-driverd.man
$(RM) man/cups-lpd.man man/cupsaddsmb.man man/cupsd.man
@@ -120,7 +119,8 @@ distclean: clean
$(RM) packaging/cups-desc.plist packaging/cups-info.plist
$(RM) templates/header.tmpl
$(RM) desktop/cups.desktop
- $(RM) init/cups.xml
+ $(RM) scheduler/cups.sh scheduler/cups-lpd
+ $(RM) scheduler/org.cups.cups-lpd.plist scheduler/cups.xml
-$(RM) doc/*/index.html
-$(RM) templates/*/header.tmpl
-$(RM) -r autom4te*.cache clang cups/charmaps cups/locale driver/test
@@ -175,73 +175,7 @@ install-data:
echo Installing cups-config script...
$(INSTALL_DIR) -m 755 $(BINDIR)
$(INSTALL_SCRIPT) cups-config $(BINDIR)/cups-config
- if test "x$(INITDIR)" != x; then \
- echo Installing init scripts...; \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(INITDIR)/init.d; \
- $(INSTALL_SCRIPT) init/cups.sh $(BUILDROOT)$(INITDIR)/init.d/cups; \
- for level in $(RCLEVELS); do \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(INITDIR)/rc$${level}.d; \
- $(LN) ../init.d/cups $(BUILDROOT)$(INITDIR)/rc$${level}.d/S$(RCSTART)cups; \
- if test `uname` = HP-UX; then \
- level=`expr $$level - 1`; \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(INITDIR)/rc$${level}.d; \
- fi; \
- $(LN) ../init.d/cups $(BUILDROOT)$(INITDIR)/rc$${level}.d/K$(RCSTOP)cups; \
- done; \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(INITDIR)/rc0.d; \
- $(LN) ../init.d/cups $(BUILDROOT)$(INITDIR)/rc0.d/K$(RCSTOP)cups; \
- fi
- if test "x$(INITDIR)" = x -a "x$(INITDDIR)" != x; then \
- $(INSTALL_DIR) $(BUILDROOT)$(INITDDIR); \
- if test "$(INITDDIR)" = "/System/Library/LaunchDaemons"; then \
- echo Installing LaunchDaemons configuration files...; \
- $(INSTALL_DATA) init/org.cups.cupsd.plist $(BUILDROOT)$(DEFAULT_LAUNCHD_CONF); \
- $(INSTALL_DATA) init/org.cups.cups-lpd.plist $(BUILDROOT)/System/Library/LaunchDaemons; \
- case `uname -r` in \
- 8.*) \
- $(INSTALL_DIR) $(BUILDROOT)/System/Library/StartupItems/PrintingServices; \
- $(INSTALL_SCRIPT) init/PrintingServices.launchd $(BUILDROOT)/System/Library/StartupItems/PrintingServices/PrintingServices; \
- $(INSTALL_DATA) init/StartupParameters.plist $(BUILDROOT)/System/Library/StartupItems/PrintingServices/StartupParameters.plist; \
- $(INSTALL_DIR) $(BUILDROOT)/System/Library/StartupItems/PrintingServices/Resources/English.lproj; \
- $(INSTALL_DATA) init/Localizable.strings $(BUILDROOT)/System/Library/StartupItems/PrintingServices/Resources/English.lproj/Localizable.strings; \
- ;; \
- esac \
- else \
- echo Installing RC script...; \
- $(INSTALL_SCRIPT) init/cups.sh $(BUILDROOT)$(INITDDIR)/cups; \
- fi \
- fi
- if test "x$(SMFMANIFESTDIR)" != x; then \
- echo Installing SMF manifest in $(SMFMANIFESTDIR)...;\
- $(INSTALL_DIR) $(BUILDROOT)/$(SMFMANIFESTDIR); \
- $(INSTALL_SCRIPT) init/cups.xml $(BUILDROOT)$(SMFMANIFESTDIR)/cups.xml; \
- fi
- if test "x$(DBUSDIR)" != x; then \
- echo Installing cups.conf in $(DBUSDIR)...;\
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(DBUSDIR)/system.d; \
- $(INSTALL_DATA) packaging/cups-dbus.conf $(BUILDROOT)$(DBUSDIR)/system.d/cups.conf; \
- fi
- if test "x$(XINETD)" != x; then \
- echo Installing xinetd configuration file for cups-lpd...; \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(XINETD); \
- $(INSTALL_DATA) init/cups-lpd $(BUILDROOT)$(XINETD)/cups-lpd; \
- fi
- if test "x$(MENUDIR)" != x; then \
- echo Installing desktop menu...; \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(MENUDIR); \
- $(INSTALL_DATA) desktop/cups.desktop $(BUILDROOT)$(MENUDIR); \
- fi
- if test "x$(ICONDIR)" != x; then \
- echo Installing desktop icons...; \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(ICONDIR)/hicolor/16x16/apps; \
- $(INSTALL_DATA) desktop/cups-16.png $(BUILDROOT)$(ICONDIR)/hicolor/16x16/apps/cups.png; \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(ICONDIR)/hicolor/32x32/apps; \
- $(INSTALL_DATA) desktop/cups-32.png $(BUILDROOT)$(ICONDIR)/hicolor/32x32/apps/cups.png; \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(ICONDIR)/hicolor/64x64/apps; \
- $(INSTALL_DATA) desktop/cups-64.png $(BUILDROOT)$(ICONDIR)/hicolor/64x64/apps/cups.png; \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(ICONDIR)/hicolor/128x128/apps; \
- $(INSTALL_DATA) desktop/cups-128.png $(BUILDROOT)$(ICONDIR)/hicolor/128x128/apps/cups.png; \
- fi
+
#
# Install header files...
@@ -288,58 +222,6 @@ uninstall:
echo Uninstalling cups-config script...
$(RM) $(BINDIR)/cups-config
-$(RMDIR) $(BINDIR)
- echo Uninstalling startup script...
- if test "x$(INITDIR)" != x; then \
- $(RM) $(BUILDROOT)$(INITDIR)/init.d/cups; \
- $(RMDIR) $(BUILDROOT)$(INITDIR)/init.d; \
- $(RM) $(BUILDROOT)$(INITDIR)/rc0.d/K00cups; \
- $(RMDIR) $(BUILDROOT)$(INITDIR)/rc0.d; \
- $(RM) $(BUILDROOT)$(INITDIR)/rc2.d/S99cups; \
- $(RMDIR) $(BUILDROOT)$(INITDIR)/rc2.d; \
- $(RM) $(BUILDROOT)$(INITDIR)/rc3.d/S99cups; \
- $(RMDIR) $(BUILDROOT)$(INITDIR)/rc3.d; \
- $(RM) $(BUILDROOT)$(INITDIR)/rc5.d/S99cups; \
- $(RMDIR) $(BUILDROOT)$(INITDIR)/rc5.d; \
- fi
- if test "x$(INITDIR)" = x -a "x$(INITDDIR)" != x; then \
- if test "$(INITDDIR)" = "/System/Library/StartupItems/PrintingServices"; then \
- $(RM) $(BUILDROOT)$(INITDDIR)/PrintingServices; \
- $(RM) $(BUILDROOT)$(INITDDIR)/StartupParameters.plist; \
- $(RM) $(BUILDROOT)$(INITDDIR)/Resources/English.lproj/Localizable.strings; \
- $(RMDIR) $(BUILDROOT)$(INITDDIR)/Resources/English.lproj; \
- elif test "$(INITDDIR)" = "/System/Library/LaunchDaemons"; then \
- $(RM) $(BUILDROOT)$(INITDDIR)/org.cups.cupsd.plist; \
- $(RM) $(BUILDROOT)$(INITDDIR)/org.cups.cups-lpd.plist; \
- $(RMDIR) $(BUILDROOT)/System/Library/StartupItems/PrintingServices; \
- else \
- $(INSTALL_SCRIPT) init/cups.sh $(BUILDROOT)$(INITDDIR)/cups; \
- fi \
- $(RMDIR) $(BUILDROOT)$(INITDDIR); \
- fi
- if test "x$(SMFMANIFESTDIR)" != x; then \
- echo Uninstalling SMF manifest in $(SMFMANIFESTDIR)...;\
- $(RM) $(BUILDROOT)$(SMFMANIFESTDIR)/cups.xml; \
- fi
- if test "x$(DBUSDIR)" != x; then \
- echo Uninstalling cups.conf in $(DBUSDIR)...;\
- $(RM) $(BUILDROOT)$(DBUSDIR)/cups.conf; \
- $(RMDIR) $(BUILDROOT)$(DBUSDIR); \
- fi
- if test "x$(XINETD)" != x; then \
- echo Uninstalling xinetd configuration file for cups-lpd...; \
- $(RM) $(BUILDROOT)$(XINETD)/cups-lpd; \
- fi
- if test "x$(MENUDIR)" != x; then \
- echo Uninstalling desktop menu...; \
- $(RM) $(BUILDROOT)$(MENUDIR)/cups.desktop; \
- fi
- if test "x$(ICONDIR)" != x; then \
- echo Uninstalling desktop icons...; \
- $(RM) $(BUILDROOT)$(ICONDIR)/hicolor/16x16/apps/cups.png; \
- $(RM) $(BUILDROOT)$(ICONDIR)/hicolor/32x32/apps/cups.png; \
- $(RM) $(BUILDROOT)$(ICONDIR)/hicolor/64x64/apps/cups.png; \
- $(RM) $(BUILDROOT)$(ICONDIR)/hicolor/128x128/apps/cups.png; \
- fi
#