summaryrefslogtreecommitdiff
path: root/backend/Makefile
diff options
context:
space:
mode:
authormsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2014-05-08 22:42:44 +0000
committermsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2014-05-08 22:42:44 +0000
commit38a68cfbeecc582d5efd5a366ef9657ed8dc9f42 (patch)
tree2813debe3714b197cf0f455011b7364601ba3adc /backend/Makefile
parent291e472758173914c36a739247c6342bc0a12898 (diff)
Sync up with some build changes.
git-svn-id: svn+ssh://src.apple.com/svn/cups/cups.org/trunk@11859 a1ca3aef-8c08-0410-bb20-df032aa958be
Diffstat (limited to 'backend/Makefile')
-rw-r--r--backend/Makefile28
1 files changed, 21 insertions, 7 deletions
diff --git a/backend/Makefile b/backend/Makefile
index 8d1e12e71..639a0d7ae 100644
--- a/backend/Makefile
+++ b/backend/Makefile
@@ -3,7 +3,7 @@
#
# Backend makefile for CUPS.
#
-# Copyright 2007-2013 by Apple Inc.
+# Copyright 2007-2014 by Apple Inc.
# Copyright 1997-2007 by Easy Software Products, all rights reserved.
#
# These coded instructions, statements, and computer programs are the
@@ -23,8 +23,8 @@ include ../Makedefs
# RBACKENDS are installed mode 0700 so cupsd will run them as root...
#
-# UBACKENDS are installed mode 0755 so cupsd will run them as an unprivileged
-# user...
+# UBACKENDS and ULBACKENDS are installed mode 0755 so cupsd will run them as
+# an unprivileged user...
#
# See http://www.cups.org/documentation.php/api-filter.html for more info...
RBACKENDS = \
@@ -33,7 +33,8 @@ RBACKENDS = \
$(DNSSD_BACKEND)
UBACKENDS = \
snmp \
- socket \
+ socket
+ULBACKENDS = \
usb
UNITTESTS = \
test1284 \
@@ -42,7 +43,8 @@ UNITTESTS = \
TARGETS = \
libbackend.a \
$(RBACKENDS) \
- $(UBACKENDS)
+ $(UBACKENDS) \
+ $(ULBACKENDS)
LIBOBJS = \
ieee1284.o \
network.o \
@@ -71,7 +73,7 @@ all: $(TARGETS)
# Make library targets...
#
-libs:
+libs: $(ULBACKENDS)
#
@@ -167,6 +169,18 @@ install-headers:
#
install-libs:
+ echo Installing backends in $(SERVERBIN)/backend
+ $(INSTALL_DIR) -m 755 $(SERVERBIN)/backend
+ for file in $(ULBACKENDS); do \
+ $(INSTALL_BIN) $$file $(SERVERBIN)/backend; \
+ done
+ if test "x$(SYMROOT)" != "x"; then \
+ $(INSTALL_DIR) $(SYMROOT); \
+ for file in $(ULBACKENDS); do \
+ cp $$file $(SYMROOT); \
+ dsymutil $(SYMROOT)/$$file; \
+ done \
+ fi
#
@@ -179,7 +193,7 @@ uninstall:
$(RM) $(SERVERBIN)/apple/$$file; \
done
-$(RMDIR) $(SERVERBIN)/apple
- for file in $(RBACKENDS) $(UBACKENDS); do \
+ for file in $(RBACKENDS) $(UBACKENDS) $(ULBACKENDS); do \
$(RM) $(SERVERBIN)/backend/$$file; \
done
for file in $(IPPALIASES); do \