summaryrefslogtreecommitdiff
path: root/backend/Makefile
diff options
context:
space:
mode:
authormsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2008-09-04 17:09:47 +0000
committermsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2008-09-04 17:09:47 +0000
commitc5571a1d68de6e20e127c9745aa7a4dbf4e4474d (patch)
tree226d783d59aac71ddd99f3a6504f1905c2a5b334 /backend/Makefile
parent9a4f8274e930ac2dff201dfb9c7af94e8f444f03 (diff)
Import CUPS 1.4svn-r7908.
git-svn-id: svn+ssh://src.apple.com/svn/cups/easysw/current@943 a1ca3aef-8c08-0410-bb20-df032aa958be
Diffstat (limited to 'backend/Makefile')
-rw-r--r--backend/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/backend/Makefile b/backend/Makefile
index 9c8a96c73..79868f83b 100644
--- a/backend/Makefile
+++ b/backend/Makefile
@@ -17,12 +17,12 @@
include ../Makedefs
-RBACKENDS = ipp lpd $(MDNS)
+RBACKENDS = ipp lpd $(DNSSD_BACKEND)
UBACKENDS = $(PAP) $(LEGACY_BACKENDS) serial snmp socket usb
TARGETS = test1284 testbackend testsupplies \
libbackend.a $(RBACKENDS) $(UBACKENDS)
LIBOBJS = ieee1284.o network.o runloop.o snmp-supplies.o
-OBJS = ipp.o lpd.o mdns.o pap.o parallel.o scsi.o serial.o snmp.o \
+OBJS = ipp.o lpd.o dnssd.o pap.o parallel.o scsi.o serial.o snmp.o \
socket.o test1284.o testbackend.o testsupplies.o usb.o
@@ -52,7 +52,7 @@ unittests:
#
clean:
- $(RM) $(OBJS) $(TARGETS) $(LIBOBJS) http
+ $(RM) $(OBJS) $(TARGETS) $(LIBOBJS) http mdns
#
@@ -168,6 +168,17 @@ libbackend.a: $(LIBOBJS)
#
+# dnssd
+#
+
+dnssd: dnssd.o ../cups/$(LIBCUPS) libbackend.a
+ echo Linking $@...
+ $(CC) $(LDFLAGS) -o dnssd dnssd.o libbackend.a $(LIBS)
+ $(RM) mdns
+ $(LN) dnssd mdns
+
+
+#
# ipp
#
@@ -188,15 +199,6 @@ lpd: lpd.o ../cups/$(LIBCUPS) libbackend.a
#
-# mdns
-#
-
-mdns: mdns.o ../cups/$(LIBCUPS) libbackend.a
- echo Linking $@...
- $(CC) $(LDFLAGS) -o mdns mdns.o libbackend.a $(LIBS)
-
-
-#
# pap
#