summaryrefslogtreecommitdiff
path: root/cups/Makefile
diff options
context:
space:
mode:
authormsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2008-08-26 03:49:44 +0000
committermsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2008-08-26 03:49:44 +0000
commit06d4e77b9b98bf529378c3670de8916982d938f1 (patch)
tree711f62838ab943426a5beab56da56366b9973740 /cups/Makefile
parent1ff0402e472496cf5165dbd796df1bdc131a360b (diff)
Merge changes from CUPS 1.4svn-r7864.
git-svn-id: svn+ssh://src.apple.com/svn/cups/easysw/current@921 a1ca3aef-8c08-0410-bb20-df032aa958be
Diffstat (limited to 'cups/Makefile')
-rw-r--r--cups/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/cups/Makefile b/cups/Makefile
index 735c89dd9..584276a16 100644
--- a/cups/Makefile
+++ b/cups/Makefile
@@ -73,6 +73,7 @@ OBJS = \
$(LIB64OBJS) \
testadmin.o \
testarray.o \
+ testconflicts.o \
testcups.o \
testfile.o \
testhttp.o \
@@ -127,6 +128,7 @@ LIBTARGETS = \
TARGETS = \
$(LIBTARGETS) \
testadmin \
+ testconflicts \
testcups \
testsnmp
@@ -402,6 +404,16 @@ testarray: testarray.o libcups.a
#
+# testconflicts (dependency on static CUPS library is intentional)
+#
+
+testconflicts: testconflicts.o libcups.a
+ echo Linking $@...
+ $(CC) $(LDFLAGS) -o $@ testconflicts.o libcups.a \
+ $(LIBGSSAPI) $(SSLLIBS) $(COMMONLIBS) $(LIBZ)
+
+
+#
# testcups (dependency on static CUPS library is intentional)
#