summaryrefslogtreecommitdiff
path: root/cups/Makefile
diff options
context:
space:
mode:
authormsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2014-05-16 21:54:22 +0000
committermsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2014-05-16 21:54:22 +0000
commit104fd4ae9f4727e4b580bafef6b439af4706e97d (patch)
tree54b181fb3f52a5c0fdb212a3ce8cf7eb67443950 /cups/Makefile
parentae26bf708c7cc06c8dce6d672c2d79b87168a113 (diff)
Save work on destination API unit test program.
Add cupsGetDestWithURI API. Add cupsLocalizeDestMedia API. git-svn-id: svn+ssh://src.apple.com/svn/cups/cups.org/trunk@11884 a1ca3aef-8c08-0410-bb20-df032aa958be
Diffstat (limited to 'cups/Makefile')
-rw-r--r--cups/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/cups/Makefile b/cups/Makefile
index 8af9d9d3f..94bec6836 100644
--- a/cups/Makefile
+++ b/cups/Makefile
@@ -85,6 +85,7 @@ TESTOBJS = \
testarray.o \
testconflicts.o \
testcups.o \
+ testdest.o \
testfile.o \
testhttp.o \
testi18n.o \
@@ -151,6 +152,7 @@ UNITTARGETS = \
testcache \
testconflicts \
testcups \
+ testdest \
testfile \
testhttp \
testi18n \
@@ -405,6 +407,16 @@ testcups: testcups.o $(LIBCUPSSTATIC)
#
+# testdest (dependency on static CUPS library is intentional)
+#
+
+testdest: testdest.o $(LIBCUPSSTATIC)
+ echo Linking $@...
+ $(CC) $(LDFLAGS) -o $@ testdest.o $(LIBCUPSSTATIC) \
+ $(LIBGSSAPI) $(SSLLIBS) $(DNSSDLIBS) $(COMMONLIBS) $(LIBZ)
+
+
+#
# testfile (dependency on static CUPS library is intentional)
#