summaryrefslogtreecommitdiff
path: root/cups/Makefile
diff options
context:
space:
mode:
authormsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2010-05-10 22:58:10 +0000
committermsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2010-05-10 22:58:10 +0000
commitcc75483441ba4241a6b0079e028d7699d99a6b0f (patch)
tree07af3321d8e2ad36d8fad169a15674ce7cc4c460 /cups/Makefile
parent6d2f911bdd077fee9489b1084b960c4e68fc0658 (diff)
Merge changes from CUPS 1.5svn-r9136.
git-svn-id: svn+ssh://src.apple.com/svn/cups/easysw/current@2180 a1ca3aef-8c08-0410-bb20-df032aa958be
Diffstat (limited to 'cups/Makefile')
-rw-r--r--cups/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/cups/Makefile b/cups/Makefile
index cd557d57a..e3f6ec241 100644
--- a/cups/Makefile
+++ b/cups/Makefile
@@ -87,8 +87,7 @@ OBJS = \
testlang.o \
testppd.o \
testpwg.o \
- testsnmp.o \
- php_cups_wrap.o
+ testsnmp.o
#
@@ -355,15 +354,14 @@ libcups.so.2 libcups.sl.2: $(LIBOBJS)
libcups.2.dylib: $(LIBOBJS) $(LIBCUPSORDER)
echo Creating export list for $@...
nm $(LIBOBJS) 2>/dev/null | grep "T _" | awk '{print $$3}' | \
- grep -v -e '^(_cupsConnect|_cupsSetDefaults|_cupsSetHTTPError|_cupsUserDefault|_httpWait)$$' | \
+ grep -v -e '^(_cupsConnect|_cupsCharset|_cupsEncodingName|_cupsSetDefaults|_cupsSetHTTPError|_cupsUserDefault|_httpWait)$$' | \
sort >t.exp
echo Linking $@...
$(DSO) $(ARCHFLAGS) $(DSOFLAGS) -o $@ \
-install_name $(libdir)/$@ \
- -current_version 2.8.0 \
+ -current_version 2.9.0 \
-compatibility_version 2.0.0 \
-exported_symbols_list t.exp \
- -sectorder __TEXT __text $(LIBCUPSORDER) \
$(LIBOBJS) $(LIBGSSAPI) $(SSLLIBS) $(DNSSDLIBS) \
$(COMMONLIBS) $(LIBZ)
$(RM) libcups.dylib t.exp
@@ -390,7 +388,7 @@ libcups_s.a: $(LIBOBJS) libcups_s.exp
libcups.la: $(LIBOBJS)
echo Linking $@...
$(CC) $(ARCHFLAGS) $(DSOFLAGS) -o $@ $(LIBOBJS:.o=.lo) \
- -rpath $(LIBDIR) -version-info 2:8 $(LIBGSSAPI) $(SSLLIBS) \
+ -rpath $(LIBDIR) -version-info 2:9 $(LIBGSSAPI) $(SSLLIBS) \
$(DNSSDLIBS) $(COMMONLIBS) $(LIBZ)