summaryrefslogtreecommitdiff
path: root/cups
diff options
context:
space:
mode:
authorjlovell <jlovell@a1ca3aef-8c08-0410-bb20-df032aa958be>2006-05-22 23:39:03 +0000
committerjlovell <jlovell@a1ca3aef-8c08-0410-bb20-df032aa958be>2006-05-22 23:39:03 +0000
commit3608048605dc5886f0d960ed83e77e2243a6e33d (patch)
tree8c3b3c3e5e89a01f876a404b56617a9918252af8 /cups
parentf301802fc285c5ec9effadfbf13de653822dddd8 (diff)
Load cups into easysw/current.
git-svn-id: svn+ssh://src.apple.com/svn/cups/easysw/current@161 a1ca3aef-8c08-0410-bb20-df032aa958be
Diffstat (limited to 'cups')
-rw-r--r--cups/Makefile4
-rw-r--r--cups/auth.c4
-rw-r--r--cups/backchannel.c4
-rw-r--r--cups/cups.h8
-rw-r--r--cups/encode.c6
-rw-r--r--cups/getifaddrs.c4
-rw-r--r--cups/http-private.h4
-rw-r--r--cups/mark.c4
-rw-r--r--cups/page.c4
-rw-r--r--cups/request.c4
-rw-r--r--cups/snprintf.c4
11 files changed, 24 insertions, 26 deletions
diff --git a/cups/Makefile b/cups/Makefile
index 8bd7f808e..6f2fc67b6 100644
--- a/cups/Makefile
+++ b/cups/Makefile
@@ -1,5 +1,5 @@
#
-# "$Id: Makefile 5563 2006-05-21 17:18:40Z mike $"
+# "$Id: Makefile 5564 2006-05-22 00:59:11Z mike $"
#
# API library Makefile for the Common UNIX Printing System (CUPS).
#
@@ -449,5 +449,5 @@ include Dependencies
#
-# End of "$Id: Makefile 5563 2006-05-21 17:18:40Z mike $".
+# End of "$Id: Makefile 5564 2006-05-22 00:59:11Z mike $".
#
diff --git a/cups/auth.c b/cups/auth.c
index 6dd85bbd3..8f515f8e0 100644
--- a/cups/auth.c
+++ b/cups/auth.c
@@ -1,5 +1,5 @@
/*
- * "$Id: auth.c 5558 2006-05-21 13:58:56Z mike $"
+ * "$Id: auth.c 5559 2006-05-21 13:59:42Z mike $"
*
* Authentication functions for the Common UNIX Printing System (CUPS).
*
@@ -249,5 +249,5 @@ cups_local_auth(http_t *http) /* I - HTTP connection to server */
/*
- * End of "$Id: auth.c 5558 2006-05-21 13:58:56Z mike $".
+ * End of "$Id: auth.c 5559 2006-05-21 13:59:42Z mike $".
*/
diff --git a/cups/backchannel.c b/cups/backchannel.c
index f2a7f0ede..09833fe46 100644
--- a/cups/backchannel.c
+++ b/cups/backchannel.c
@@ -1,5 +1,5 @@
/*
- * "$Id: backchannel.c 5550 2006-05-19 20:20:15Z mike $"
+ * "$Id: backchannel.c 5551 2006-05-19 20:20:32Z mike $"
*
* Backchannel functions for the Common UNIX Printing System (CUPS).
*
@@ -197,5 +197,5 @@ cups_setup(fd_set *set, /* I - Set for select() */
/*
- * End of "$Id: backchannel.c 5550 2006-05-19 20:20:15Z mike $".
+ * End of "$Id: backchannel.c 5551 2006-05-19 20:20:32Z mike $".
*/
diff --git a/cups/cups.h b/cups/cups.h
index 94f9b8981..64b389a08 100644
--- a/cups/cups.h
+++ b/cups/cups.h
@@ -1,5 +1,5 @@
/*
- * "$Id: cups.h 5502 2006-05-08 21:09:15Z mike $"
+ * "$Id: cups.h 5233 2006-03-06 03:39:28Z mike $"
*
* API definitions for the Common UNIX Printing System (CUPS).
*
@@ -61,9 +61,9 @@ extern "C" {
* Constants...
*/
-# define CUPS_VERSION 1.0300
+# define CUPS_VERSION 1.0200
# define CUPS_VERSION_MAJOR 1
-# define CUPS_VERSION_MINOR 3
+# define CUPS_VERSION_MINOR 2
# define CUPS_VERSION_PATCH 0
# define CUPS_DATE_ANY -1
@@ -244,5 +244,5 @@ extern cups_file_t *cupsTempFile2(char *filename, int len);
#endif /* !_CUPS_CUPS_H_ */
/*
- * End of "$Id: cups.h 5502 2006-05-08 21:09:15Z mike $".
+ * End of "$Id: cups.h 5233 2006-03-06 03:39:28Z mike $".
*/
diff --git a/cups/encode.c b/cups/encode.c
index 7d6f4cec4..a00e2c52a 100644
--- a/cups/encode.c
+++ b/cups/encode.c
@@ -1,5 +1,5 @@
/*
- * "$Id: encode.c 5544 2006-05-18 21:00:16Z mike $"
+ * "$Id: encode.c 5545 2006-05-18 21:00:56Z mike $"
*
* Option encoding routines for the Common UNIX Printing System (CUPS).
*
@@ -67,7 +67,6 @@ static const _ipp_option_t ipp_options[] =
{ "copies", IPP_TAG_INTEGER, IPP_TAG_JOB },
{ "copies-default", IPP_TAG_INTEGER, IPP_TAG_PRINTER },
{ "document-format", IPP_TAG_MIMETYPE, IPP_TAG_OPERATION },
- { "document-format-default", IPP_TAG_MIMETYPE, IPP_TAG_PRINTER },
{ "finishings", IPP_TAG_ENUM, IPP_TAG_JOB },
{ "finishings-default", IPP_TAG_ENUM, IPP_TAG_PRINTER },
{ "fitplot", IPP_TAG_BOOLEAN, IPP_TAG_JOB },
@@ -89,7 +88,6 @@ static const _ipp_option_t ipp_options[] =
{ "natural-scaling-default", IPP_TAG_INTEGER, IPP_TAG_PRINTER },
{ "notify-charset", IPP_TAG_CHARSET, IPP_TAG_SUBSCRIPTION },
{ "notify-events", IPP_TAG_KEYWORD, IPP_TAG_SUBSCRIPTION },
- { "notify-events-default", IPP_TAG_KEYWORD, IPP_TAG_PRINTER },
{ "notify-lease-time", IPP_TAG_INTEGER, IPP_TAG_SUBSCRIPTION },
{ "notify-natural-language", IPP_TAG_LANGUAGE, IPP_TAG_SUBSCRIPTION },
{ "notify-pull-method", IPP_TAG_KEYWORD, IPP_TAG_SUBSCRIPTION },
@@ -561,5 +559,5 @@ compare_ipp_options(_ipp_option_t *a, /* I - First option */
/*
- * End of "$Id: encode.c 5544 2006-05-18 21:00:16Z mike $".
+ * End of "$Id: encode.c 5545 2006-05-18 21:00:56Z mike $".
*/
diff --git a/cups/getifaddrs.c b/cups/getifaddrs.c
index 7653cfde9..abfd0fac6 100644
--- a/cups/getifaddrs.c
+++ b/cups/getifaddrs.c
@@ -1,5 +1,5 @@
/*
- * "$Id: getifaddrs.c 5503 2006-05-10 18:55:39Z mike $"
+ * "$Id: getifaddrs.c 5504 2006-05-10 18:57:46Z mike $"
*
* Network interface functions for the Common UNIX Printing System
* (CUPS) scheduler.
@@ -272,5 +272,5 @@ _cups_freeifaddrs(struct ifaddrs *addrs)/* I - Interface list to free */
/*
- * End of "$Id: getifaddrs.c 5503 2006-05-10 18:55:39Z mike $".
+ * End of "$Id: getifaddrs.c 5504 2006-05-10 18:57:46Z mike $".
*/
diff --git a/cups/http-private.h b/cups/http-private.h
index b95b007d8..bef934ed9 100644
--- a/cups/http-private.h
+++ b/cups/http-private.h
@@ -1,5 +1,5 @@
/*
- * "$Id: http-private.h 5503 2006-05-10 18:55:39Z mike $"
+ * "$Id: http-private.h 5504 2006-05-10 18:57:46Z mike $"
*
* Private HTTP definitions for the Common UNIX Printing System (CUPS).
*
@@ -187,5 +187,5 @@ extern void _cups_freeifaddrs(struct ifaddrs *addrs);
#endif /* !_CUPS_HTTP_PRIVATE_H_ */
/*
- * End of "$Id: http-private.h 5503 2006-05-10 18:55:39Z mike $".
+ * End of "$Id: http-private.h 5504 2006-05-10 18:57:46Z mike $".
*/
diff --git a/cups/mark.c b/cups/mark.c
index a7d8fd7bd..3b2226774 100644
--- a/cups/mark.c
+++ b/cups/mark.c
@@ -1,5 +1,5 @@
/*
- * "$Id: mark.c 5528 2006-05-15 20:03:12Z mike $"
+ * "$Id: mark.c 5529 2006-05-15 20:06:46Z mike $"
*
* Option marking routines for the Common UNIX Printing System (CUPS).
*
@@ -679,5 +679,5 @@ ppd_defaults(ppd_file_t *ppd, /* I - PPD file */
/*
- * End of "$Id: mark.c 5528 2006-05-15 20:03:12Z mike $".
+ * End of "$Id: mark.c 5529 2006-05-15 20:06:46Z mike $".
*/
diff --git a/cups/page.c b/cups/page.c
index f835c41c0..f8b79832f 100644
--- a/cups/page.c
+++ b/cups/page.c
@@ -1,5 +1,5 @@
/*
- * "$Id: page.c 5548 2006-05-19 19:38:31Z mike $"
+ * "$Id: page.c 5549 2006-05-19 19:39:28Z mike $"
*
* Page size functions for the Common UNIX Printing System (CUPS).
*
@@ -193,5 +193,5 @@ ppdPageLength(ppd_file_t *ppd, /* I - PPD file */
/*
- * End of "$Id: page.c 5548 2006-05-19 19:38:31Z mike $".
+ * End of "$Id: page.c 5549 2006-05-19 19:39:28Z mike $".
*/
diff --git a/cups/request.c b/cups/request.c
index 6aff5126d..329cce881 100644
--- a/cups/request.c
+++ b/cups/request.c
@@ -1,5 +1,5 @@
/*
- * "$Id: request.c 5556 2006-05-21 13:55:23Z mike $"
+ * "$Id: request.c 5555 2006-05-20 13:35:58Z mike $"
*
* IPP utilities for the Common UNIX Printing System (CUPS).
*
@@ -479,5 +479,5 @@ _cupsSetError(ipp_status_t status, /* I - IPP status code */
/*
- * End of "$Id: request.c 5556 2006-05-21 13:55:23Z mike $".
+ * End of "$Id: request.c 5555 2006-05-20 13:35:58Z mike $".
*/
diff --git a/cups/snprintf.c b/cups/snprintf.c
index 19dff87af..683551b05 100644
--- a/cups/snprintf.c
+++ b/cups/snprintf.c
@@ -1,5 +1,5 @@
/*
- * "$Id: snprintf.c 5527 2006-05-15 19:37:11Z mike $"
+ * "$Id: snprintf.c 5529 2006-05-15 20:06:46Z mike $"
*
* snprintf functions for the Common UNIX Printing System (CUPS).
*
@@ -368,6 +368,6 @@ _cups_snprintf(char *buffer, /* O - Output buffer */
/*
- * End of "$Id: snprintf.c 5527 2006-05-15 19:37:11Z mike $".
+ * End of "$Id: snprintf.c 5529 2006-05-15 20:06:46Z mike $".
*/