summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authormsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2008-06-27 20:26:20 +0000
committermsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2008-06-27 20:26:20 +0000
commit75bd9771f6e44fdd887ee90faac46f403aefc0fc (patch)
tree354e3067522df9490e905772f73b72bfed8733ae /doc
parentdd1abb6b5f145c5e5f279d8848b5f3ec161fd227 (diff)
Merge changes from CUPS 1.4svn-r7696.
git-svn-id: svn+ssh://src.apple.com/svn/cups/easysw/current@818 a1ca3aef-8c08-0410-bb20-df032aa958be
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile2
-rw-r--r--doc/help/api-array.html2
-rw-r--r--doc/help/api-filter.html13
-rw-r--r--doc/help/api-httpipp.html2
-rw-r--r--doc/help/api-ppd.html28
-rw-r--r--doc/help/api-raster.html4
-rw-r--r--doc/help/spec-ipp.html10
-rw-r--r--doc/help/spec-ppd.html22
8 files changed, 65 insertions, 18 deletions
diff --git a/doc/Makefile b/doc/Makefile
index e87eb5c34..9d24b2844 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -1,5 +1,5 @@
#
-# "$Id: Makefile 6900 2007-08-30 17:17:51Z mike $"
+# "$Id: Makefile 7601 2008-05-20 21:08:08Z mike $"
#
# Documentation makefile for the Common UNIX Printing System (CUPS).
#
diff --git a/doc/help/api-array.html b/doc/help/api-array.html
index f08a706a7..007d71278 100644
--- a/doc/help/api-array.html
+++ b/doc/help/api-array.html
@@ -323,7 +323,7 @@ div.contents ul.subcontents li {
</ul></li>
</ul>
<!--
- "$Id: api-array.shtml 7266 2008-01-29 02:15:29Z mike $"
+ "$Id: api-array.shtml 7616 2008-05-28 00:34:13Z mike $"
Array API introduction for the Common UNIX Printing System (CUPS).
diff --git a/doc/help/api-filter.html b/doc/help/api-filter.html
index b645ec353..affeeb4e3 100644
--- a/doc/help/api-filter.html
+++ b/doc/help/api-filter.html
@@ -253,7 +253,7 @@ div.contents ul.subcontents li {
<body>
<div class='body'>
<!--
- "$Id: api-filter.header 7615 2008-05-25 07:17:07Z mike $"
+ "$Id: api-filter.header 7616 2008-05-28 00:34:13Z mike $"
Filter and backend programming header for the Common UNIX Printing System
(CUPS).
@@ -333,7 +333,7 @@ div.contents ul.subcontents li {
</ul></li>
</ul>
<!--
- "$Id: api-filter.shtml 7594 2008-05-19 23:16:03Z mike $"
+ "$Id: api-filter.shtml 7677 2008-06-19 23:22:19Z mike $"
Filter and backend programming introduction for the Common UNIX Printing
System (CUPS).
@@ -519,10 +519,11 @@ prefix strings:</p>
<dt>ATTR: attribute=value [attribute=value]</dt>
<dd>Sets the named printer or job attribute(s). Typically this is used
to set the <code>marker-colors</code>, <code>marker-levels</code>,
- <code>marker-names</code>, <code>marker-types</code>,
- <code>printer-alert</code>, and <code>printer-alert-description</code>
- printer attributes. Standard <code>marker-types</code> values are
- listed in <a href='#TABLE1'>Table 1</a>.</dd>
+ <code>marker-message</code>, <code>marker-names</code>,
+ <code>marker-types</code>, <code>printer-alert</code>, and
+ <code>printer-alert-description</code> printer attributes. Standard
+ <code>marker-types</code> values are listed in <a href='#TABLE1'>Table
+ 1</a>.</dd>
<dt>CRIT: message</dt>
<dd>Sets the printer-state-message attribute and adds the specified
diff --git a/doc/help/api-httpipp.html b/doc/help/api-httpipp.html
index f2e4fa211..e55c460b4 100644
--- a/doc/help/api-httpipp.html
+++ b/doc/help/api-httpipp.html
@@ -792,7 +792,7 @@ tempfd = cupsTempFd(tempfile, sizeof(tempfile));
/* Loop for authentication */
do
{
- status = a href='#cupsSendRequest'>cupsSendRequest</a>(CUPS_HTTP_DEFAULT, request, "/");
+ status = <a href='#cupsSendRequest'>cupsSendRequest</a>(CUPS_HTTP_DEFAULT, request, "/");
if (status == HTTP_UNAUTHORIZED)
{
diff --git a/doc/help/api-ppd.html b/doc/help/api-ppd.html
index 697573e85..b8ea92154 100644
--- a/doc/help/api-ppd.html
+++ b/doc/help/api-ppd.html
@@ -253,7 +253,7 @@ div.contents ul.subcontents li {
<body>
<div class='body'>
<!--
- "$Id: api-ppd.header 7278 2008-01-31 01:23:09Z mike $"
+ "$Id: api-ppd.header 7616 2008-05-28 00:34:13Z mike $"
PPD API header for the Common UNIX Printing System (CUPS).
@@ -326,6 +326,7 @@ marked option choices.">ppdConflicts</a></li>
<li><a href="#ppdIsMarked" title="Check to see if an option is marked.">ppdIsMarked</a></li>
<li><a href="#ppdLastError" title="Return the status from the last ppdOpen*().">ppdLastError</a></li>
<li><a href="#ppdLocalize" title="Localize the PPD file to the current locale.">ppdLocalize</a></li>
+<li><a href="#ppdLocalizeAttr" title="Localize an attribute.">ppdLocalizeAttr</a></li>
<li><a href="#ppdLocalizeIPPReason" title="Get the localized version of a cupsIPPReason
attribute.">ppdLocalizeIPPReason</a></li>
<li><a href="#ppdLocalizeMarkerName" title="Get the localized version of a marker-names
@@ -391,7 +392,7 @@ attribute value.">ppdLocalizeMarkerName</a></li>
</ul></li>
</ul>
<!--
- "$Id: api-ppd.shtml 7278 2008-01-31 01:23:09Z mike $"
+ "$Id: api-ppd.shtml 7616 2008-05-28 00:34:13Z mike $"
PPD API introduction for the Common UNIX Printing System (CUPS).
@@ -1061,6 +1062,29 @@ descriptions, printer presets, and custom option parameters. Each
localized string uses the UTF-8 character encoding.
</p>
+<h3 class="function"><a name="ppdLocalizeAttr">ppdLocalizeAttr</a></h3>
+<p class="description">Localize an attribute.</p>
+<p class="code">
+<a href="#ppd_attr_t">ppd_attr_t</a> *ppdLocalizeAttr (<br>
+&nbsp;&nbsp;&nbsp;&nbsp;<a href="#ppd_file_t">ppd_file_t</a> *ppd,<br>
+&nbsp;&nbsp;&nbsp;&nbsp;const char *keyword,<br>
+&nbsp;&nbsp;&nbsp;&nbsp;const char *spec<br>
+);</p>
+<h4 class="parameters">Parameters</h4>
+<dl>
+<dt>ppd</dt>
+<dd class="description">PPD file</dd>
+<dt>keyword</dt>
+<dd class="description">Main keyword</dd>
+<dt>spec</dt>
+<dd class="description">Option keyword or <code>NULL</code> for none</dd>
+</dl>
+<h4 class="returnvalue">Return Value</h4>
+<p class="description">Localized attribute or <code>NULL</code> if none exists</p>
+<h4 class="discussion">Discussion</h4>
+<p class="discussion">This function uses the current locale to find the localized attribute for
+the given main and option keywords. If no localized version of the
+attribute exists for the current locale, the unlocalized version is returned.</p>
<h3 class="function"><span class="info">&nbsp;CUPS 1.3&nbsp;</span><a name="ppdLocalizeIPPReason">ppdLocalizeIPPReason</a></h3>
<p class="description">Get the localized version of a cupsIPPReason
attribute.</p>
diff --git a/doc/help/api-raster.html b/doc/help/api-raster.html
index da9684b01..2672ec9db 100644
--- a/doc/help/api-raster.html
+++ b/doc/help/api-raster.html
@@ -501,8 +501,8 @@ the memory used to read the raster file:</p>
<ul class="code">
<li><a href="#cupsRasterInterpretPPD" title="Interpret PPD commands to create a page header.">cupsRasterInterpretPPD</a></li>
- <li><a href="#cupsRasterWriteHeader" title="Write a raster page header from a version 1 page header structure.">cupsRasterWriteHeader</a></li>
- <li><a href="#cupsRasterWriteHeader2" title="Write a raster page header from a version 2 page header structure.">cupsRasterWriteHeader2</a> <span class="info">Deprecated in CUPS 1.2/Mac OS X 10.5</span></li>
+ <li><a href="#cupsRasterWriteHeader" title="Write a raster page header from a version 1 page header structure.">cupsRasterWriteHeader</a> <span class="info">Deprecated in CUPS 1.2/Mac OS X 10.5</span></li>
+ <li><a href="#cupsRasterWriteHeader2" title="Write a raster page header from a version 2 page header structure.">cupsRasterWriteHeader2</a></li>
<li><a href="#cupsRasterWritePixels" title="Write raster pixels.">cupsRasterWritePixels</a></li>
</ul>
diff --git a/doc/help/spec-ipp.html b/doc/help/spec-ipp.html
index 344ba67af..a1c85a825 100644
--- a/doc/help/spec-ipp.html
+++ b/doc/help/spec-ipp.html
@@ -2473,8 +2473,8 @@ There will always be at least one banner file available called "none".
<h4><a name="marker-change-time">marker-change-time (integer)</a></h4>
<p>The marker-change-time attribute specifies the printer-up-time value when
-the last change to the marker-colors, marker-levels, marker-names, or
-marker-types attributes was made.</p>
+the last change to the marker-colors, marker-levels, marker-message,
+marker-names, or marker-types attributes was made.</p>
<h4><a name="marker-colors">marker-colors (1setof name(MAX))</a></h4>
@@ -2490,6 +2490,12 @@ printer. It is only available when the driver provides supply levels. A
value of -1 indicates the level is unknown, while values from 0 to 100
indicate the corresponding percentage.</p>
+<h4><a name="marker-message">marker-message (text(MAX))</a></h4>
+
+<p>The marker-message attribute provides a human-readable status message
+for the current supply levels, e.g. "12 pages of ink remaining." It is only
+available when the driver provides supply levels.</p>
+
<h4><a name="marker-names">marker-names (1setof name(MAX))</a></h4>
<p>The marker-names attribute specifies the name(s) for each supply in the
diff --git a/doc/help/spec-ppd.html b/doc/help/spec-ppd.html
index 402b3bcdd..87209f39a 100644
--- a/doc/help/spec-ppd.html
+++ b/doc/help/spec-ppd.html
@@ -8,7 +8,7 @@
</head>
<body>
<!--
- "$Id: spec-ppd.html 6993 2007-09-28 18:05:28Z mike $"
+ "$Id: spec-ppd.html 7677 2008-06-19 23:22:19Z mike $"
CUPS PPD extensions specification for the Common UNIX Printing System (CUPS).
@@ -1254,6 +1254,20 @@ generated by the driver to human readable text.</p>
*cupsMarkerName cyanToner/Cyan Toner: ""
</pre>
+<h3><span class='info'>CUPS 1.4</span><a name='cupsMarkerNotice'>cupsMarkerNotice</a></h3>
+
+<p class='summary'>*cupsMarkerNotice: "disclaimer text"</p>
+
+<p>This optional attribute provides disclaimer text for the supply level
+information provided by the driver, typically something like "supply levels
+are approximate".</p>
+
+<p>Examples:</p>
+
+<pre class='command'>
+*cupsMarkerNotice: "Supply levels are approximate."
+</pre>
+
<h3><a name='cupsModelNumber'>cupsModelNumber</a></h3>
<p class='summary'>*cupsModelNumber: number</p>
@@ -1627,11 +1641,13 @@ the device.</p>
<ul>
- <li>Added <tt>cupsPJLDisplay</tt> attribute.</li>
+ <li>Added <tt>cupsCommands</tt> attribute.</li>
<li>Added <tt>cupsMarkerName</tt> attribute.</li>
- <li>Added <tt>cupsCommands</tt> attribute.</li>
+ <li>Added <tt>cupsMarkerNotice</tt> attribute.</li>
+
+ <li>Added <tt>cupsPJLDisplay</tt> attribute.</li>
</ul>