summaryrefslogtreecommitdiff
path: root/ppdc
diff options
context:
space:
mode:
authormsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2008-11-12 01:01:46 +0000
committermsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2008-11-12 01:01:46 +0000
commite6013cfab0c8f847ed296695fea1cbef6058bda3 (patch)
tree85b8f3d6ad9a54a58843ed2c0808448c297969ec /ppdc
parente4572d571c24d8e71db08ab9ec16210c2428c761 (diff)
Merge changes from CUPS 1.4svn-r8115.
git-svn-id: svn+ssh://src.apple.com/svn/cups/easysw/current@1055 a1ca3aef-8c08-0410-bb20-df032aa958be
Diffstat (limited to 'ppdc')
-rw-r--r--ppdc/Dependencies8
-rw-r--r--ppdc/Makefile2
-rw-r--r--ppdc/ppdc-catalog.cxx13
-rw-r--r--ppdc/sample.drv40
4 files changed, 38 insertions, 25 deletions
diff --git a/ppdc/Dependencies b/ppdc/Dependencies
index 79160528d..1e53cc2a4 100644
--- a/ppdc/Dependencies
+++ b/ppdc/Dependencies
@@ -66,9 +66,11 @@ ppdhtml.o: ../cups/language.h ../cups/array.h
ppdi.o: ppdc.h ../cups/string.h ../config.h ../cups/file.h
ppdi.o: ../cups/versioning.h ../cups/i18n.h ../cups/transcode.h
ppdi.o: ../cups/language.h ../cups/array.h
-ppdmerge.o: ../cups/cups.h ../cups/array.h ../cups/versioning.h
-ppdmerge.o: ../cups/string.h ../config.h ../cups/i18n.h ../cups/transcode.h
-ppdmerge.o: ../cups/language.h ../cups/array.h
+ppdmerge.o: ../cups/ppd-private.h ../cups/cups.h ../cups/ipp.h ../cups/http.h
+ppdmerge.o: ../cups/versioning.h ../cups/string.h ../cups/ppd.h
+ppdmerge.o: ../cups/array.h ../cups/file.h ../cups/language.h ../cups/cups.h
+ppdmerge.o: ../cups/array.h ../cups/string.h ../config.h ../cups/i18n.h
+ppdmerge.o: ../cups/transcode.h
ppdpo.o: ppdc.h ../cups/string.h ../config.h ../cups/file.h
ppdpo.o: ../cups/versioning.h ../cups/i18n.h ../cups/transcode.h
ppdpo.o: ../cups/language.h ../cups/array.h
diff --git a/ppdc/Makefile b/ppdc/Makefile
index 771d23621..598b9112c 100644
--- a/ppdc/Makefile
+++ b/ppdc/Makefile
@@ -162,7 +162,7 @@ install-headers:
# Install libraries...
#
-install-libs: $(INSTALLSTATIC) $(INSTALL32) $(INSTALL64)
+install-libs: $(INSTALLSTATIC)
echo Installing libraries in $(LIBDIR)...
$(INSTALL_DIR) -m 755 $(LIBDIR)
$(INSTALL_LIB) $(LIBCUPSPPDC) $(LIBDIR)
diff --git a/ppdc/ppdc-catalog.cxx b/ppdc/ppdc-catalog.cxx
index da06bb36d..e67754a5b 100644
--- a/ppdc/ppdc-catalog.cxx
+++ b/ppdc/ppdc-catalog.cxx
@@ -14,6 +14,16 @@
//
// Contents:
//
+// ppdcCatalog::ppdcCatalog() - Create a shared message catalog.
+// ppdcCatalog::~ppdcCatalog() - Destroy a shared message catalog.
+// ppdcCatalog::add_message() - Add a new message.
+// ppdcCatalog::find_message() - Find a message in a catalog...
+// ppdcCatalog::load_messages() - Load messages from a .po file.
+// ppdcCatalog::save_messages() - Save the messages to a .po file.
+// get_utf8() - Get a UTF-8 character.
+// get_utf16() - Get a UTF-16 character...
+// put_utf8() - Add a UTF-8 character to a string.
+// put_utf16() - Write a UTF-16 character to a file.
//
//
@@ -140,7 +150,7 @@ ppdcCatalog::add_message(
string = text;
}
- messages->add(new ppdcMessage(id, text));
+ messages->add(new ppdcMessage(id, string));
}
@@ -276,6 +286,7 @@ ppdcCatalog::load_messages(
{
// Add string...
add_message(id, str);
+ id[0] = '\0';
}
}
}
diff --git a/ppdc/sample.drv b/ppdc/sample.drv
index cb9e3a3a6..195466e41 100644
--- a/ppdc/sample.drv
+++ b/ppdc/sample.drv
@@ -22,26 +22,26 @@
// Localizations are provided for all of the base languages supported by
// CUPS...
-#po da ""
-#po de ""
-#po es ""
-#po et ""
-#po fi ""
-#po fr ""
-#po he ""
-#po id ""
-#po it ""
-#po ja ""
-#po ko ""
-#po nl ""
-#po no ""
-#po pl ""
-#po pt ""
-#po pt_BR ""
-#po ru ""
-#po sv ""
-#po zh ""
-#po zh_TW ""
+//#po da ""
+//#po de ""
+//#po es ""
+//#po et ""
+//#po fi ""
+//#po fr ""
+//#po he ""
+//#po id ""
+//#po it ""
+//#po ja ""
+//#po ko ""
+//#po nl ""
+//#po no ""
+//#po pl ""
+//#po pt ""
+//#po pt_BR ""
+//#po ru ""
+//#po sv ""
+//#po zh ""
+//#po zh_TW ""
// MediaSize sizes used by label drivers...
#media "w81h252/Address - 1 1/8 x 3 1/2\"" 81 252