summaryrefslogtreecommitdiff
path: root/notifier/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'notifier/Makefile')
-rw-r--r--notifier/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/notifier/Makefile b/notifier/Makefile
index 2c80380a6..1f63c8497 100644
--- a/notifier/Makefile
+++ b/notifier/Makefile
@@ -64,10 +64,6 @@ install: all install-data install-headers install-libs install-exec
install-data:
$(INSTALL_DIR) -m 775 $(CACHEDIR)/rss
-chgrp $(CUPS_GROUP) $(CACHEDIR)/rss
- if test "x$(SYMROOT)" != "x"; then \
- $(INSTALL_DIR) $(SYMROOT); \
- cp $(NOTIFIERS) $(SYMROOT); \
- fi
#
@@ -80,6 +76,10 @@ install-exec:
for file in $(NOTIFIERS); do \
$(INSTALL_BIN) $$file $(SERVERBIN)/notifier; \
done
+ if test "x$(SYMROOT)" != "x"; then \
+ $(INSTALL_DIR) $(SYMROOT); \
+ cp $(NOTIFIERS) $(SYMROOT); \
+ fi
#
@@ -125,10 +125,6 @@ dbus: dbus.o ../cups/$(LIBCUPS)
echo Linking $@...
$(CC) $(LDFLAGS) -o dbus dbus.o $(DBUS_NOTIFIERLIBS) $(LIBS)
-dbus.o: dbus.h
-dbus.h: dbus-notifier.xml
- dbus-binding-tool --mode=glib-server $< >$@
-
#
# mailto