summaryrefslogtreecommitdiff
path: root/systemv
diff options
context:
space:
mode:
Diffstat (limited to 'systemv')
-rw-r--r--systemv/Dependencies94
-rw-r--r--systemv/Makefile41
-rw-r--r--systemv/accept.c23
-rw-r--r--systemv/cancel.c23
-rw-r--r--systemv/cupsaddsmb.c26
-rw-r--r--systemv/cupsctl.c219
-rw-r--r--systemv/cupstestdsc.c23
-rw-r--r--systemv/cupstestppd.c27
-rw-r--r--systemv/lp.c23
-rw-r--r--systemv/lpadmin.c23
-rw-r--r--systemv/lpinfo.c23
-rw-r--r--systemv/lpmove.c23
-rw-r--r--systemv/lpoptions.c23
-rw-r--r--systemv/lppasswd.c23
-rw-r--r--systemv/lpstat.c23
15 files changed, 378 insertions, 259 deletions
diff --git a/systemv/Dependencies b/systemv/Dependencies
index e48da544c..08e10c1fd 100644
--- a/systemv/Dependencies
+++ b/systemv/Dependencies
@@ -1,45 +1,49 @@
-# DO NOT DELETE
-
-accept.o: ../cups/string.h ../config.h ../cups/cups.h ../cups/ipp.h
-accept.o: ../cups/http.h ../cups/ppd.h ../cups/array.h ../cups/file.h
-accept.o: ../cups/language.h ../cups/i18n.h ../cups/transcode.h
-cancel.o: ../cups/string.h ../config.h ../cups/cups.h ../cups/ipp.h
-cancel.o: ../cups/http.h ../cups/ppd.h ../cups/array.h ../cups/file.h
-cancel.o: ../cups/language.h ../cups/i18n.h ../cups/transcode.h
-cupsaddsmb.o: ../cups/string.h ../config.h ../cups/adminutil.h ../cups/cups.h
-cupsaddsmb.o: ../cups/ipp.h ../cups/http.h ../cups/ppd.h ../cups/array.h
-cupsaddsmb.o: ../cups/file.h ../cups/language.h ../cups/i18n.h
-cupsaddsmb.o: ../cups/transcode.h ../cups/debug.h
-cupstestdsc.o: ../cups/string.h ../config.h ../cups/cups.h ../cups/ipp.h
-cupstestdsc.o: ../cups/http.h ../cups/ppd.h ../cups/array.h ../cups/file.h
-cupstestdsc.o: ../cups/language.h ../cups/file.h ../cups/i18n.h
-cupstestdsc.o: ../cups/transcode.h
-cupstestppd.o: ../cups/string.h ../config.h ../cups/cups.h ../cups/ipp.h
-cupstestppd.o: ../cups/http.h ../cups/ppd.h ../cups/array.h ../cups/file.h
-cupstestppd.o: ../cups/language.h ../cups/i18n.h ../cups/transcode.h
-lp.o: ../cups/string.h ../config.h ../cups/cups.h ../cups/ipp.h
-lp.o: ../cups/http.h ../cups/ppd.h ../cups/array.h ../cups/file.h
-lp.o: ../cups/language.h ../cups/i18n.h ../cups/transcode.h
-lpadmin.o: ../cups/string.h ../config.h ../cups/cups.h ../cups/ipp.h
-lpadmin.o: ../cups/http.h ../cups/ppd.h ../cups/array.h ../cups/file.h
-lpadmin.o: ../cups/language.h ../cups/i18n.h ../cups/transcode.h
-lpadmin.o: ../cups/debug.h
-lpinfo.o: ../cups/string.h ../config.h ../cups/cups.h ../cups/ipp.h
-lpinfo.o: ../cups/http.h ../cups/ppd.h ../cups/array.h ../cups/file.h
-lpinfo.o: ../cups/language.h ../cups/i18n.h ../cups/transcode.h
-lpinfo.o: ../cups/debug.h
-lpmove.o: ../cups/string.h ../config.h ../cups/cups.h ../cups/ipp.h
-lpmove.o: ../cups/http.h ../cups/ppd.h ../cups/array.h ../cups/file.h
-lpmove.o: ../cups/language.h ../cups/i18n.h ../cups/transcode.h
-lpmove.o: ../cups/debug.h
-lpoptions.o: ../cups/string.h ../config.h ../cups/cups.h ../cups/ipp.h
-lpoptions.o: ../cups/http.h ../cups/ppd.h ../cups/array.h ../cups/file.h
-lpoptions.o: ../cups/language.h ../cups/i18n.h ../cups/transcode.h
-lppasswd.o: ../cups/string.h ../config.h ../cups/cups.h ../cups/ipp.h
-lppasswd.o: ../cups/http.h ../cups/ppd.h ../cups/array.h ../cups/file.h
-lppasswd.o: ../cups/language.h ../cups/i18n.h ../cups/transcode.h
-lppasswd.o: ../cups/md5.h
-lpstat.o: ../cups/http-private.h ../config.h ../cups/http.h ../cups/md5.h
-lpstat.o: ../cups/ipp-private.h ../cups/ipp.h ../cups/string.h ../cups/cups.h
-lpstat.o: ../cups/ppd.h ../cups/array.h ../cups/file.h ../cups/language.h
-lpstat.o: ../cups/i18n.h ../cups/transcode.h ../cups/debug.h
+# DO NOT DELETE THIS LINE -- make depend depends on it.
+accept.o: accept.c ../cups/string.h ../config.h ../cups/cups.h \
+ ../cups/ipp.h ../cups/http.h ../cups/ppd.h ../cups/array.h \
+ ../cups/file.h ../cups/language.h ../cups/i18n.h ../cups/transcode.h
+cancel.o: cancel.c ../cups/string.h ../config.h ../cups/cups.h \
+ ../cups/ipp.h ../cups/http.h ../cups/ppd.h ../cups/array.h \
+ ../cups/file.h ../cups/language.h ../cups/i18n.h ../cups/transcode.h
+cupsaddsmb.o: cupsaddsmb.c ../cups/string.h ../config.h \
+ ../cups/adminutil.h ../cups/cups.h ../cups/ipp.h ../cups/http.h \
+ ../cups/ppd.h ../cups/array.h ../cups/file.h ../cups/language.h \
+ ../cups/i18n.h ../cups/transcode.h ../cups/debug.h
+cupsctl.o: cupsctl.c ../cups/adminutil.h ../cups/cups.h ../cups/ipp.h \
+ ../cups/http.h ../cups/ppd.h ../cups/array.h ../cups/file.h \
+ ../cups/language.h ../cups/string.h ../config.h ../cups/i18n.h \
+ ../cups/transcode.h
+cupstestdsc.o: cupstestdsc.c ../cups/string.h ../config.h ../cups/cups.h \
+ ../cups/ipp.h ../cups/http.h ../cups/ppd.h ../cups/array.h \
+ ../cups/file.h ../cups/language.h ../cups/file.h ../cups/i18n.h \
+ ../cups/transcode.h
+cupstestppd.o: cupstestppd.c ../cups/string.h ../config.h ../cups/cups.h \
+ ../cups/ipp.h ../cups/http.h ../cups/ppd.h ../cups/array.h \
+ ../cups/file.h ../cups/language.h ../cups/i18n.h ../cups/transcode.h \
+ ../filter/raster.h
+lp.o: lp.c ../cups/string.h ../config.h ../cups/cups.h ../cups/ipp.h \
+ ../cups/http.h ../cups/ppd.h ../cups/array.h ../cups/file.h \
+ ../cups/language.h ../cups/i18n.h ../cups/transcode.h
+lpadmin.o: lpadmin.c ../cups/string.h ../config.h ../cups/cups.h \
+ ../cups/ipp.h ../cups/http.h ../cups/ppd.h ../cups/array.h \
+ ../cups/file.h ../cups/language.h ../cups/i18n.h ../cups/transcode.h \
+ ../cups/debug.h
+lpinfo.o: lpinfo.c ../cups/string.h ../config.h ../cups/cups.h \
+ ../cups/ipp.h ../cups/http.h ../cups/ppd.h ../cups/array.h \
+ ../cups/file.h ../cups/language.h ../cups/i18n.h ../cups/transcode.h \
+ ../cups/debug.h
+lpmove.o: lpmove.c ../cups/string.h ../config.h ../cups/cups.h \
+ ../cups/ipp.h ../cups/http.h ../cups/ppd.h ../cups/array.h \
+ ../cups/file.h ../cups/language.h ../cups/i18n.h ../cups/transcode.h \
+ ../cups/debug.h
+lpoptions.o: lpoptions.c ../cups/string.h ../config.h ../cups/cups.h \
+ ../cups/ipp.h ../cups/http.h ../cups/ppd.h ../cups/array.h \
+ ../cups/file.h ../cups/language.h ../cups/i18n.h ../cups/transcode.h
+lppasswd.o: lppasswd.c ../cups/string.h ../config.h ../cups/cups.h \
+ ../cups/ipp.h ../cups/http.h ../cups/ppd.h ../cups/array.h \
+ ../cups/file.h ../cups/language.h ../cups/i18n.h ../cups/transcode.h \
+ ../cups/md5.h
+lpstat.o: lpstat.c ../cups/http-private.h ../config.h ../cups/http.h \
+ ../cups/md5.h ../cups/ipp-private.h ../cups/ipp.h ../cups/string.h \
+ ../cups/cups.h ../cups/ppd.h ../cups/array.h ../cups/file.h \
+ ../cups/language.h ../cups/i18n.h ../cups/transcode.h ../cups/debug.h
diff --git a/systemv/Makefile b/systemv/Makefile
index c9be899b0..285e7a6ae 100644
--- a/systemv/Makefile
+++ b/systemv/Makefile
@@ -1,34 +1,25 @@
#
-# "$Id: Makefile 6574 2007-06-19 23:52:37Z mike $"
+# "$Id: Makefile 6649 2007-07-11 21:46:42Z mike $"
#
# System V commands makefile for the Common UNIX Printing System (CUPS).
#
+# Copyright 2007 by Apple Inc.
# Copyright 1997-2006 by Easy Software Products, all rights reserved.
#
# These coded instructions, statements, and computer programs are the
-# property of Easy Software Products and are protected by Federal
-# copyright law. Distribution and use rights are outlined in the file
-# "LICENSE.txt" which should have been included with this file. If this
-# file is missing or damaged please contact Easy Software Products
-# at:
-#
-# Attn: CUPS Licensing Information
-# Easy Software Products
-# 44141 Airport View Drive, Suite 204
-# Hollywood, Maryland 20636 USA
-#
-# Voice: (301) 373-9600
-# EMail: cups-info@cups.org
-# WWW: http://www.cups.org
+# property of Apple Inc. and are protected by Federal copyright
+# law. Distribution and use rights are outlined in the file "LICENSE.txt"
+# which should have been included with this file. If this file is
+# file is missing or damaged, see the license at "http://www.cups.org/".
#
include ../Makedefs
-TARGETS = accept cancel cupsaddsmb cupstestdsc cupstestppd \
+TARGETS = accept cancel cupsaddsmb cupsctl cupstestdsc cupstestppd \
lp lpadmin lpinfo lpmove lpoptions lppasswd lpstat
-OBJS = accept.o cancel.o cupsaddsmb.o cupstestdsc.o cupstestppd.o \
- lp.o lpadmin.o lpinfo.o lpmove.o lpoptions.o lppasswd.o \
- lpstat.o
+OBJS = accept.o cancel.o cupsaddsmb.o cupsctl.o cupstestdsc.o \
+ cupstestppd.o lp.o lpadmin.o lpinfo.o lpmove.o lpoptions.o \
+ lppasswd.o lpstat.o
#
@@ -64,6 +55,7 @@ install: all
$(RM) $(SBINDIR)/reject
$(LN) accept $(SBINDIR)/reject
$(INSTALL_BIN) cupsaddsmb $(SBINDIR)
+ $(INSTALL_BIN) cupsctl $(SBINDIR)
$(INSTALL_BIN) lpadmin $(SBINDIR)
$(INSTALL_BIN) lpinfo $(SBINDIR)
$(INSTALL_BIN) lpmove $(SBINDIR)
@@ -143,6 +135,15 @@ cupsaddsmb: cupsaddsmb.o ../cups/$(LIBCUPS)
#
+# cupsctl
+#
+
+cupsctl: cupsctl.o ../cups/$(LIBCUPS)
+ echo Linking $@...
+ $(CC) $(LDFLAGS) -o cupsctl cupsctl.o $(LIBS)
+
+
+#
# cupstestdsc
#
@@ -231,5 +232,5 @@ include Dependencies
#
-# End of "$Id: Makefile 6574 2007-06-19 23:52:37Z mike $".
+# End of "$Id: Makefile 6649 2007-07-11 21:46:42Z mike $".
#
diff --git a/systemv/accept.c b/systemv/accept.c
index 63dec108e..5d816cf0f 100644
--- a/systemv/accept.c
+++ b/systemv/accept.c
@@ -1,26 +1,17 @@
/*
- * "$Id: accept.c 5925 2006-09-05 19:43:11Z mike $"
+ * "$Id: accept.c 6649 2007-07-11 21:46:42Z mike $"
*
* "accept", "disable", "enable", and "reject" commands for the Common
* UNIX Printing System (CUPS).
*
+ * Copyright 2007 by Apple Inc.
* Copyright 1997-2006 by Easy Software Products.
*
* These coded instructions, statements, and computer programs are the
- * property of Easy Software Products and are protected by Federal
- * copyright law. Distribution and use rights are outlined in the file
- * "LICENSE.txt" which should have been included with this file. If this
- * file is missing or damaged please contact Easy Software Products
- * at:
- *
- * Attn: CUPS Licensing Information
- * Easy Software Products
- * 44141 Airport View Drive, Suite 204
- * Hollywood, Maryland 20636 USA
- *
- * Voice: (301) 373-9600
- * EMail: cups-info@cups.org
- * WWW: http://www.cups.org
+ * property of Apple Inc. and are protected by Federal copyright
+ * law. Distribution and use rights are outlined in the file "LICENSE.txt"
+ * which should have been included with this file. If this file is
+ * file is missing or damaged, see the license at "http://www.cups.org/".
*
* Contents:
*
@@ -288,5 +279,5 @@ main(int argc, /* I - Number of command-line arguments */
/*
- * End of "$Id: accept.c 5925 2006-09-05 19:43:11Z mike $".
+ * End of "$Id: accept.c 6649 2007-07-11 21:46:42Z mike $".
*/
diff --git a/systemv/cancel.c b/systemv/cancel.c
index 37712f9a2..8d057bbdd 100644
--- a/systemv/cancel.c
+++ b/systemv/cancel.c
@@ -1,25 +1,16 @@
/*
- * "$Id: cancel.c 5925 2006-09-05 19:43:11Z mike $"
+ * "$Id: cancel.c 6649 2007-07-11 21:46:42Z mike $"
*
* "cancel" command for the Common UNIX Printing System (CUPS).
*
+ * Copyright 2007 by Apple Inc.
* Copyright 1997-2006 by Easy Software Products.
*
* These coded instructions, statements, and computer programs are the
- * property of Easy Software Products and are protected by Federal
- * copyright law. Distribution and use rights are outlined in the file
- * "LICENSE.txt" which should have been included with this file. If this
- * file is missing or damaged please contact Easy Software Products
- * at:
- *
- * Attn: CUPS Licensing Information
- * Easy Software Products
- * 44141 Airport View Drive, Suite 204
- * Hollywood, Maryland 20636 USA
- *
- * Voice: (301) 373-9600
- * EMail: cups-info@cups.org
- * WWW: http://www.cups.org
+ * property of Apple Inc. and are protected by Federal copyright
+ * law. Distribution and use rights are outlined in the file "LICENSE.txt"
+ * which should have been included with this file. If this file is
+ * file is missing or damaged, see the license at "http://www.cups.org/".
*
* Contents:
*
@@ -392,5 +383,5 @@ main(int argc, /* I - Number of command-line arguments */
/*
- * End of "$Id: cancel.c 5925 2006-09-05 19:43:11Z mike $".
+ * End of "$Id: cancel.c 6649 2007-07-11 21:46:42Z mike $".
*/
diff --git a/systemv/cupsaddsmb.c b/systemv/cupsaddsmb.c
index 32a0a7188..3e48e8fa0 100644
--- a/systemv/cupsaddsmb.c
+++ b/systemv/cupsaddsmb.c
@@ -1,25 +1,16 @@
/*
- * "$Id: cupsaddsmb.c 5925 2006-09-05 19:43:11Z mike $"
+ * "$Id: cupsaddsmb.c 6649 2007-07-11 21:46:42Z mike $"
*
* "cupsaddsmb" command for the Common UNIX Printing System (CUPS).
*
+ * Copyright 2007 by Apple Inc.
* Copyright 2001-2006 by Easy Software Products.
*
* These coded instructions, statements, and computer programs are the
- * property of Easy Software Products and are protected by Federal
- * copyright law. Distribution and use rights are outlined in the file
- * "LICENSE.txt" which should have been included with this file. If this
- * file is missing or damaged please contact Easy Software Products
- * at:
- *
- * Attn: CUPS Licensing Information
- * Easy Software Products
- * 44141 Airport View Drive, Suite 204
- * Hollywood, Maryland 20636 USA
- *
- * Voice: (301) 373-9600
- * EMail: cups-info@cups.org
- * WWW: http://www.cups.org
+ * property of Apple Inc. and are protected by Federal copyright
+ * law. Distribution and use rights are outlined in the file "LICENSE.txt"
+ * which should have been included with this file. If this file is
+ * file is missing or damaged, see the license at "http://www.cups.org/".
*
* Contents:
*
@@ -263,6 +254,9 @@ export_dest(http_t *http, /* I - Connection to server */
status = cupsAdminExportSamba(dest, ppdfile, SAMBAServer,
SAMBAUser, SAMBAPassword,
Verbosity ? stderr : NULL);
+
+ if (!status && cupsLastError() == IPP_NOT_FOUND)
+ break;
}
unlink(ppdfile);
@@ -294,5 +288,5 @@ usage(void)
/*
- * End of "$Id: cupsaddsmb.c 5925 2006-09-05 19:43:11Z mike $".
+ * End of "$Id: cupsaddsmb.c 6649 2007-07-11 21:46:42Z mike $".
*/
diff --git a/systemv/cupsctl.c b/systemv/cupsctl.c
new file mode 100644
index 000000000..bc044a9ad
--- /dev/null
+++ b/systemv/cupsctl.c
@@ -0,0 +1,219 @@
+/*
+ * "$Id: cupsctl.c 6379 2007-03-21 14:57:22Z mike $"
+ *
+ * CUPS control program for the Common UNIX Printing System (CUPS).
+ *
+ * Copyright 2007 by Apple Inc.
+ * Copyright 2006-2007 by Easy Software Products.
+ *
+ * These coded instructions, statements, and computer programs are the
+ * property of Apple Inc. and are protected by Federal copyright
+ * law. Distribution and use rights are outlined in the file "LICENSE.txt"
+ * which should have been included with this file. If this file is
+ * file is missing or damaged, see the license at "http://www.cups.org/".
+ *
+ * This file is subject to the Apple OS-Developed Software exception.
+ *
+ * Contents:
+ *
+ * main() - Get/set server settings.
+ * usage() - Show program usage.
+ */
+
+/*
+ * Include necessary headers...
+ */
+
+#include <cups/adminutil.h>
+#include <cups/string.h>
+#include <cups/i18n.h>
+
+
+/*
+ * Local functions...
+ */
+
+static void usage(const char *opt);
+
+
+/*
+ * 'main()' - Get/set server settings.
+ */
+
+int /* O - Exit status */
+main(int argc, /* I - Number of command-line args */
+ char *argv[]) /* I - Command-line arguments */
+{
+ int i, /* Looping var */
+ num_settings; /* Number of settings */
+ cups_option_t *settings; /* Settings */
+ const char *opt; /* Current option character */
+ http_t *http; /* Connection to server */
+
+
+ /*
+ * Process the command-line...
+ */
+
+ _cupsSetLocale(argv);
+
+ num_settings = 0;
+ settings = NULL;
+
+ for (i = 1; i < argc; i ++)
+ {
+ if (argv[i][0] == '-')
+ {
+ if (argv[i][1] == '-')
+ {
+ if (!strcmp(argv[i], "--debug_logging"))
+ num_settings = cupsAddOption(CUPS_SERVER_DEBUG_LOGGING, "1",
+ num_settings, &settings);
+ else if (!strcmp(argv[i], "--no-debug-logging"))
+ num_settings = cupsAddOption(CUPS_SERVER_DEBUG_LOGGING, "0",
+ num_settings, &settings);
+ else if (!strcmp(argv[i], "--remote-admin"))
+ num_settings = cupsAddOption(CUPS_SERVER_REMOTE_ADMIN, "1",
+ num_settings, &settings);
+ else if (!strcmp(argv[i], "--no-remote-admin"))
+ num_settings = cupsAddOption(CUPS_SERVER_REMOTE_ADMIN, "0",
+ num_settings, &settings);
+ else if (!strcmp(argv[i], "--remote-any"))
+ num_settings = cupsAddOption(CUPS_SERVER_REMOTE_ANY, "1",
+ num_settings, &settings);
+ else if (!strcmp(argv[i], "--no-remote-any"))
+ num_settings = cupsAddOption(CUPS_SERVER_REMOTE_ANY, "0",
+ num_settings, &settings);
+ else if (!strcmp(argv[i], "--remote-printers"))
+ num_settings = cupsAddOption(CUPS_SERVER_REMOTE_PRINTERS, "1",
+ num_settings, &settings);
+ else if (!strcmp(argv[i], "--no-remote-printers"))
+ num_settings = cupsAddOption(CUPS_SERVER_REMOTE_PRINTERS, "0",
+ num_settings, &settings);
+ else if (!strcmp(argv[i], "--share-printers"))
+ num_settings = cupsAddOption(CUPS_SERVER_SHARE_PRINTERS, "1",
+ num_settings, &settings);
+ else if (!strcmp(argv[i], "--no-share-printers"))
+ num_settings = cupsAddOption(CUPS_SERVER_SHARE_PRINTERS, "0",
+ num_settings, &settings);
+ else if (!strcmp(argv[i], "--user-cancel-any"))
+ num_settings = cupsAddOption(CUPS_SERVER_USER_CANCEL_ANY, "1",
+ num_settings, &settings);
+ else if (!strcmp(argv[i], "--no-user-cancel-any"))
+ num_settings = cupsAddOption(CUPS_SERVER_USER_CANCEL_ANY, "0",
+ num_settings, &settings);
+ else
+ usage(argv[i]);
+ }
+ else
+ {
+ for (opt = argv[i] + 1; *opt; opt ++)
+ switch (*opt)
+ {
+ case 'E' :
+ cupsSetEncryption(HTTP_ENCRYPT_REQUIRED);
+ break;
+
+ case 'U' :
+ i ++;
+ if (i >= argc)
+ usage(NULL);
+
+ cupsSetUser(argv[i]);
+ break;
+
+ case 'h' :
+ i ++;
+ if (i >= argc)
+ usage(NULL);
+
+ cupsSetServer(argv[i]);
+ break;
+
+ default :
+ usage(opt);
+ break;
+ }
+ }
+ }
+ else if (strchr(argv[i], '='))
+ num_settings = cupsParseOptions(argv[i], num_settings, &settings);
+ else
+ usage(argv[i]);
+ }
+
+ /*
+ * Connect to the server using the defaults...
+ */
+
+ http = httpConnectEncrypt(cupsServer(), ippPort(), cupsEncryption());
+
+ /*
+ * Set the current configuration if we have anything on the command-line...
+ */
+
+ if (num_settings > 0)
+ {
+ if (!cupsAdminSetServerSettings(http, num_settings, settings))
+ {
+ _cupsLangPrintf(stderr, "cupsctl: %s\n", cupsLastErrorString());
+ return (1);
+ }
+ }
+ else if (!cupsAdminGetServerSettings(http, &num_settings, &settings))
+ {
+ _cupsLangPrintf(stderr, "cupsctl: %s\n", cupsLastErrorString());
+ return (1);
+ }
+ else
+ {
+ for (i = 0; i < num_settings; i ++)
+ _cupsLangPrintf(stdout, "%s=%s\n", settings[i].name, settings[i].value);
+ }
+
+ cupsFreeOptions(num_settings, settings);
+ return (0);
+}
+
+
+/*
+ * 'usage()' - Show program usage.
+ */
+
+static void
+usage(const char *opt) /* I - Option character/string */
+{
+ if (opt)
+ {
+ if (*opt == '-')
+ _cupsLangPrintf(stderr, _("cupsctl: Unknown option \"%s\"!\n"), opt);
+ else
+ _cupsLangPrintf(stderr, _("cupsctl: Unknown option \"-%c\"!\n"), *opt);
+ }
+
+ _cupsLangPuts(stdout,
+ _("Usage: cupsctl [options] [param=value ... paramN=valueN]\n"
+ "\n"
+ "Options:\n"
+ "\n"
+ " -E Enable encryption\n"
+ " -U username Specify username\n"
+ " -h server[:port] Specify server address\n"
+ "\n"
+ " --[no-]debug-logging Turn debug logging on/off\n"
+ " --[no-]remote-admin Turn remote administration "
+ "on/off\n"
+ " --[no-]remote-any Allow/prevent access from the "
+ "Internet\n"
+ " --[no-]remote-printers Show/hide remote printers\n"
+ " --[no-]share-printers Turn printer sharing on/off\n"
+ " --[no-]user-cancel-any Allow/prevent users to cancel "
+ "any job\n"));
+
+ exit(1);
+}
+
+
+/*
+ * End of "$Id: cupsctl.c 6379 2007-03-21 14:57:22Z mike $".
+ */
diff --git a/systemv/cupstestdsc.c b/systemv/cupstestdsc.c
index e9cc988fe..ce4a8a707 100644
--- a/systemv/cupstestdsc.c
+++ b/systemv/cupstestdsc.c
@@ -1,25 +1,16 @@
/*
- * "$Id: cupstestdsc.c 5925 2006-09-05 19:43:11Z mike $"
+ * "$Id: cupstestdsc.c 6649 2007-07-11 21:46:42Z mike $"
*
* DSC test program for the Common UNIX Printing System (CUPS).
*
+ * Copyright 2007 by Apple Inc.
* Copyright 2006 by Easy Software Products, all rights reserved.
*
* These coded instructions, statements, and computer programs are the
- * property of Easy Software Products and are protected by Federal
- * copyright law. Distribution and use rights are outlined in the file
- * "LICENSE.txt" which should have been included with this file. If this
- * file is missing or damaged please contact Easy Software Products
- * at:
- *
- * Attn: CUPS Licensing Information
- * Easy Software Products
- * 44141 Airport View Drive, Suite 204
- * Hollywood, Maryland 20636 USA
- *
- * Voice: (301) 373-9600
- * EMail: cups-info@cups.org
- * WWW: http://www.cups.org
+ * property of Apple Inc. and are protected by Federal copyright
+ * law. Distribution and use rights are outlined in the file "LICENSE.txt"
+ * which should have been included with this file. If this file is
+ * file is missing or damaged, see the license at "http://www.cups.org/".
*
* PostScript is a trademark of Adobe Systems, Inc.
*
@@ -452,5 +443,5 @@ usage(void)
/*
- * End of "$Id: cupstestdsc.c 5925 2006-09-05 19:43:11Z mike $".
+ * End of "$Id: cupstestdsc.c 6649 2007-07-11 21:46:42Z mike $".
*/
diff --git a/systemv/cupstestppd.c b/systemv/cupstestppd.c
index 4f4c6964f..09a361b99 100644
--- a/systemv/cupstestppd.c
+++ b/systemv/cupstestppd.c
@@ -1,25 +1,16 @@
/*
- * "$Id: cupstestppd.c 6574 2007-06-19 23:52:37Z mike $"
+ * "$Id: cupstestppd.c 6649 2007-07-11 21:46:42Z mike $"
*
* PPD test program for the Common UNIX Printing System (CUPS).
*
+ * Copyright 2007 by Apple Inc.
* Copyright 1997-2007 by Easy Software Products, all rights reserved.
*
* These coded instructions, statements, and computer programs are the
- * property of Easy Software Products and are protected by Federal
- * copyright law. Distribution and use rights are outlined in the file
- * "LICENSE.txt" which should have been included with this file. If this
- * file is missing or damaged please contact Easy Software Products
- * at:
- *
- * Attn: CUPS Licensing Information
- * Easy Software Products
- * 44141 Airport View Drive, Suite 204
- * Hollywood, Maryland 20636 USA
- *
- * Voice: (301) 373-9600
- * EMail: cups-info@cups.org
- * WWW: http://www.cups.org
+ * property of Apple Inc. and are protected by Federal copyright
+ * law. Distribution and use rights are outlined in the file "LICENSE.txt"
+ * which should have been included with this file. If this file is
+ * file is missing or damaged, see the license at "http://www.cups.org/".
*
* PostScript is a trademark of Adobe Systems, Inc.
*
@@ -1099,7 +1090,7 @@ main(int argc, /* I - Number of command-line args */
_cupsLangPuts(stdout, _(" FAIL\n"));
if (verbose >= 0)
- _cupsLangPrintf(stderr,
+ _cupsLangPrintf(stdout,
_(" **FAIL** Bad LanguageEncoding %s - "
"must be ISOLatin1!\n"),
attr->value ? attr->value : "(null)");
@@ -1113,7 +1104,7 @@ main(int argc, /* I - Number of command-line args */
_cupsLangPuts(stdout, _(" FAIL\n"));
if (verbose >= 0)
- _cupsLangPrintf(stderr,
+ _cupsLangPrintf(stdout,
_(" **FAIL** Bad LanguageVersion %s - "
"must be English!\n"),
ppd->lang_version ? ppd->lang_version : "(null)");
@@ -2510,5 +2501,5 @@ valid_utf8(const char *s) /* I - String to check */
/*
- * End of "$Id: cupstestppd.c 6574 2007-06-19 23:52:37Z mike $".
+ * End of "$Id: cupstestppd.c 6649 2007-07-11 21:46:42Z mike $".
*/
diff --git a/systemv/lp.c b/systemv/lp.c
index 8500f802e..f9b90836a 100644
--- a/systemv/lp.c
+++ b/systemv/lp.c
@@ -1,25 +1,16 @@
/*
- * "$Id: lp.c 6356 2007-03-19 13:54:48Z mike $"
+ * "$Id: lp.c 6649 2007-07-11 21:46:42Z mike $"
*
* "lp" command for the Common UNIX Printing System (CUPS).
*
+ * Copyright 2007 by Apple Inc.
* Copyright 1997-2007 by Easy Software Products.
*
* These coded instructions, statements, and computer programs are the
- * property of Easy Software Products and are protected by Federal
- * copyright law. Distribution and use rights are outlined in the file
- * "LICENSE.txt" which should have been included with this file. If this
- * file is missing or damaged please contact Easy Software Products
- * at:
- *
- * Attn: CUPS Licensing Information
- * Easy Software Products
- * 44141 Airport View Drive, Suite 204
- * Hollywood, Maryland 20636 USA
- *
- * Voice: (301) 373-9600
- * EMail: cups-info@cups.org
- * WWW: http://www.cups.org
+ * property of Apple Inc. and are protected by Federal copyright
+ * law. Distribution and use rights are outlined in the file "LICENSE.txt"
+ * which should have been included with this file. If this file is
+ * file is missing or damaged, see the license at "http://www.cups.org/".
*
* Contents:
*
@@ -840,5 +831,5 @@ sighandler(int s) /* I - Signal number */
/*
- * End of "$Id: lp.c 6356 2007-03-19 13:54:48Z mike $".
+ * End of "$Id: lp.c 6649 2007-07-11 21:46:42Z mike $".
*/
diff --git a/systemv/lpadmin.c b/systemv/lpadmin.c
index f48677dd1..8625f5a15 100644
--- a/systemv/lpadmin.c
+++ b/systemv/lpadmin.c
@@ -1,25 +1,16 @@
/*
- * "$Id: lpadmin.c 5925 2006-09-05 19:43:11Z mike $"
+ * "$Id: lpadmin.c 6649 2007-07-11 21:46:42Z mike $"
*
* "lpadmin" command for the Common UNIX Printing System (CUPS).
*
+ * Copyright 2007 by Apple Inc.
* Copyright 1997-2006 by Easy Software Products.
*
* These coded instructions, statements, and computer programs are the
- * property of Easy Software Products and are protected by Federal
- * copyright law. Distribution and use rights are outlined in the file
- * "LICENSE.txt" which should have been included with this file. If this
- * file is missing or damaged please contact Easy Software Products
- * at:
- *
- * Attn: CUPS Licensing Information
- * Easy Software Products
- * 44141 Airport View Drive, Suite 204
- * Hollywood, Maryland 20636 USA
- *
- * Voice: (301) 373-9600
- * EMail: cups-info@cups.org
- * WWW: http://www.cups.org
+ * property of Apple Inc. and are protected by Federal copyright
+ * law. Distribution and use rights are outlined in the file "LICENSE.txt"
+ * which should have been included with this file. If this file is
+ * file is missing or damaged, see the license at "http://www.cups.org/".
*
* Contents:
*
@@ -1986,5 +1977,5 @@ validate_name(const char *name) /* I - Name to check */
/*
- * End of "$Id: lpadmin.c 5925 2006-09-05 19:43:11Z mike $".
+ * End of "$Id: lpadmin.c 6649 2007-07-11 21:46:42Z mike $".
*/
diff --git a/systemv/lpinfo.c b/systemv/lpinfo.c
index 26f4cf495..b8697c2c8 100644
--- a/systemv/lpinfo.c
+++ b/systemv/lpinfo.c
@@ -1,25 +1,16 @@
/*
- * "$Id: lpinfo.c 5925 2006-09-05 19:43:11Z mike $"
+ * "$Id: lpinfo.c 6649 2007-07-11 21:46:42Z mike $"
*
* "lpinfo" command for the Common UNIX Printing System (CUPS).
*
+ * Copyright 2007 by Apple Inc.
* Copyright 1997-2006 by Easy Software Products.
*
* These coded instructions, statements, and computer programs are the
- * property of Easy Software Products and are protected by Federal
- * copyright law. Distribution and use rights are outlined in the file
- * "LICENSE.txt" which should have been included with this file. If this
- * file is missing or damaged please contact Easy Software Products
- * at:
- *
- * Attn: CUPS Licensing Information
- * Easy Software Products
- * 44141 Airport View Drive, Suite 204
- * Hollywood, Maryland 20636 USA
- *
- * Voice: (301) 373-9600
- * EMail: cups-info@cups.org
- * WWW: http://www.cups.org
+ * property of Apple Inc. and are protected by Federal copyright
+ * law. Distribution and use rights are outlined in the file "LICENSE.txt"
+ * which should have been included with this file. If this file is
+ * file is missing or damaged, see the license at "http://www.cups.org/".
*
* Contents:
*
@@ -436,5 +427,5 @@ show_models(http_t *http, /* I - HTTP connection to server */
/*
- * End of "$Id: lpinfo.c 5925 2006-09-05 19:43:11Z mike $".
+ * End of "$Id: lpinfo.c 6649 2007-07-11 21:46:42Z mike $".
*/
diff --git a/systemv/lpmove.c b/systemv/lpmove.c
index a46efe0f6..e991dfd9a 100644
--- a/systemv/lpmove.c
+++ b/systemv/lpmove.c
@@ -1,25 +1,16 @@
/*
- * "$Id: lpmove.c 5925 2006-09-05 19:43:11Z mike $"
+ * "$Id: lpmove.c 6649 2007-07-11 21:46:42Z mike $"
*
* "lpmove" command for the Common UNIX Printing System (CUPS).
*
+ * Copyright 2007 by Apple Inc.
* Copyright 1997-2006 by Easy Software Products.
*
* These coded instructions, statements, and computer programs are the
- * property of Easy Software Products and are protected by Federal
- * copyright law. Distribution and use rights are outlined in the file
- * "LICENSE.txt" which should have been included with this file. If this
- * file is missing or damaged please contact Easy Software Products
- * at:
- *
- * Attn: CUPS Licensing Information
- * Easy Software Products
- * 44141 Airport View Drive, Suite 204
- * Hollywood, Maryland 20636 USA
- *
- * Voice: (301) 373-9600
- * EMail: cups-info@cups.org
- * WWW: http://www.cups.org
+ * property of Apple Inc. and are protected by Federal copyright
+ * law. Distribution and use rights are outlined in the file "LICENSE.txt"
+ * which should have been included with this file. If this file is
+ * file is missing or damaged, see the license at "http://www.cups.org/".
*
* Contents:
*
@@ -235,5 +226,5 @@ move_job(http_t *http, /* I - HTTP connection to server */
/*
- * End of "$Id: lpmove.c 5925 2006-09-05 19:43:11Z mike $".
+ * End of "$Id: lpmove.c 6649 2007-07-11 21:46:42Z mike $".
*/
diff --git a/systemv/lpoptions.c b/systemv/lpoptions.c
index 582213204..c9094c709 100644
--- a/systemv/lpoptions.c
+++ b/systemv/lpoptions.c
@@ -1,25 +1,16 @@
/*
- * "$Id: lpoptions.c 6347 2007-03-18 03:21:36Z mike $"
+ * "$Id: lpoptions.c 6649 2007-07-11 21:46:42Z mike $"
*
* Printer option program for the Common UNIX Printing System (CUPS).
*
+ * Copyright 2007 by Apple Inc.
* Copyright 1997-2006 by Easy Software Products.
*
* These coded instructions, statements, and computer programs are the
- * property of Easy Software Products and are protected by Federal
- * copyright law. Distribution and use rights are outlined in the file
- * "LICENSE.txt" which should have been included with this file. If this
- * file is missing or damaged please contact Easy Software Products
- * at:
- *
- * Attn: CUPS Licensing Information
- * Easy Software Products
- * 44141 Airport View Drive, Suite 204
- * Hollywood, Maryland 20636 USA
- *
- * Voice: (301) 373-9600
- * EMail: cups-info@cups.org
- * WWW: http://www.cups.org
+ * property of Apple Inc. and are protected by Federal copyright
+ * law. Distribution and use rights are outlined in the file "LICENSE.txt"
+ * which should have been included with this file. If this file is
+ * file is missing or damaged, see the license at "http://www.cups.org/".
*
* Contents:
*
@@ -496,5 +487,5 @@ usage(void)
/*
- * End of "$Id: lpoptions.c 6347 2007-03-18 03:21:36Z mike $".
+ * End of "$Id: lpoptions.c 6649 2007-07-11 21:46:42Z mike $".
*/
diff --git a/systemv/lppasswd.c b/systemv/lppasswd.c
index 362fbf208..4fcd951c9 100644
--- a/systemv/lppasswd.c
+++ b/systemv/lppasswd.c
@@ -1,25 +1,16 @@
/*
- * "$Id: lppasswd.c 5925 2006-09-05 19:43:11Z mike $"
+ * "$Id: lppasswd.c 6649 2007-07-11 21:46:42Z mike $"
*
* MD5 password program for the Common UNIX Printing System (CUPS).
*
+ * Copyright 2007 by Apple Inc.
* Copyright 1997-2006 by Easy Software Products.
*
* These coded instructions, statements, and computer programs are the
- * property of Easy Software Products and are protected by Federal
- * copyright law. Distribution and use rights are outlined in the file
- * "LICENSE.txt" which should have been included with this file. If this
- * file is missing or damaged please contact Easy Software Products
- * at:
- *
- * Attn: CUPS Licensing Information
- * Easy Software Products
- * 44141 Airport View Drive, Suite 204
- * Hollywood, Maryland 20636 USA
- *
- * Voice: (301) 373-9600
- * EMail: cups-info@cups.org
- * WWW: http://www.cups.org
+ * property of Apple Inc. and are protected by Federal copyright
+ * law. Distribution and use rights are outlined in the file "LICENSE.txt"
+ * which should have been included with this file. If this file is
+ * file is missing or damaged, see the license at "http://www.cups.org/".
*
* Contents:
*
@@ -511,5 +502,5 @@ usage(FILE *fp) /* I - File to send usage to */
/*
- * End of "$Id: lppasswd.c 5925 2006-09-05 19:43:11Z mike $".
+ * End of "$Id: lppasswd.c 6649 2007-07-11 21:46:42Z mike $".
*/
diff --git a/systemv/lpstat.c b/systemv/lpstat.c
index be86072ab..6c5410430 100644
--- a/systemv/lpstat.c
+++ b/systemv/lpstat.c
@@ -1,25 +1,16 @@
/*
- * "$Id: lpstat.c 6559 2007-06-18 21:09:03Z mike $"
+ * "$Id: lpstat.c 6649 2007-07-11 21:46:42Z mike $"
*
* "lpstat" command for the Common UNIX Printing System (CUPS).
*
+ * Copyright 2007 by Apple Inc.
* Copyright 1997-2006 by Easy Software Products.
*
* These coded instructions, statements, and computer programs are the
- * property of Easy Software Products and are protected by Federal
- * copyright law. Distribution and use rights are outlined in the file
- * "LICENSE.txt" which should have been included with this file. If this
- * file is missing or damaged please contact Easy Software Products
- * at:
- *
- * Attn: CUPS Licensing Information
- * Easy Software Products
- * 44141 Airport View Drive, Suite 204
- * Hollywood, Maryland 20636 USA
- *
- * Voice: (301) 373-9600
- * EMail: cups-info@cups.org
- * WWW: http://www.cups.org
+ * property of Apple Inc. and are protected by Federal copyright
+ * law. Distribution and use rights are outlined in the file "LICENSE.txt"
+ * which should have been included with this file. If this file is
+ * file is missing or damaged, see the license at "http://www.cups.org/".
*
* Contents:
*
@@ -2267,5 +2258,5 @@ show_scheduler(http_t *http) /* I - HTTP connection to server */
/*
- * End of "$Id: lpstat.c 6559 2007-06-18 21:09:03Z mike $".
+ * End of "$Id: lpstat.c 6649 2007-07-11 21:46:42Z mike $".
*/