summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Ghedini <ghedo@debian.org>2020-08-24 10:25:44 +0200
committerAlessandro Ghedini <ghedo@debian.org>2020-08-24 10:47:19 +0200
commit5d8fa77b6460144c5d414c0447e4a6dec83b3388 (patch)
tree48565b80731faf02ecdd731c4d4303ccf031e5f4
parentf99f238c9222bab4c75d1ce89b4b4a80c062e92b (diff)
Use python3 executable in tests
-rw-r--r--debian/control1
-rw-r--r--debian/patches/12_use-python3-in-tests.patch50
-rw-r--r--debian/patches/series1
3 files changed, 52 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index addbdb89..cd69a7be 100644
--- a/debian/control
+++ b/debian/control
@@ -23,6 +23,7 @@ Build-Depends: debhelper (>= 12),
libtool,
openssh-server <!nocheck>,
python3:native,
+ python3-impacket,
quilt,
stunnel4 <!nocheck>,
zlib1g-dev
diff --git a/debian/patches/12_use-python3-in-tests.patch b/debian/patches/12_use-python3-in-tests.patch
new file mode 100644
index 00000000..876debbb
--- /dev/null
+++ b/debian/patches/12_use-python3-in-tests.patch
@@ -0,0 +1,50 @@
+Description: Use python3 executable in tests
+Origin: vendor
+Forwarded: not-needed
+Author: Alessandro Ghedini <ghedo@debian.org>
+Reviewed-by: Alessandro Ghedini <ghedo@debian.org>
+Last-Update: 2020-08-24
+
+--- a/tests/curl_test_data.py
++++ b/tests/curl_test_data.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: utf-8 -*-
+ #
+ # Project ___| | | | _ \| |
+--- a/tests/data/test1451
++++ b/tests/data/test1451
+@@ -29,7 +29,7 @@
+ -u 'curltest:curltest' smb://%HOSTIP:%SMBPORT/TESTS/1451
+ </command>
+ <precheck>
+-python -c "__import__('pkgutil').find_loader('impacket') or (__import__('sys').stdout.write('Test only works if Python package impacket is installed\n'), __import__('sys').exit(1))"
++python3 -c "__import__('pkgutil').find_loader('impacket') or (__import__('sys').stdout.write('Test only works if Python package impacket is installed\n'), __import__('sys').exit(1))"
+ </precheck>
+ </client>
+
+--- a/tests/dictserver.py
++++ b/tests/dictserver.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: utf-8 -*-
+ #***************************************************************************
+ # _ _ ____ _
+--- a/tests/negtelnetserver.py
++++ b/tests/negtelnetserver.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: utf-8 -*-
+ #
+ # Project ___| | | | _ \| |
+--- a/tests/smbserver.py
++++ b/tests/smbserver.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: utf-8 -*-
+ #
+ # Project ___| | | | _ \| |
diff --git a/debian/patches/series b/debian/patches/series
index a42ff76d..ec3e1e44 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,6 +3,7 @@
07_do-not-disable-debug-symbols.patch
08_enable-zsh.patch
11_omit-directories-from-config.patch
+12_use-python3-in-tests.patch
# do not add patches below
90_gnutls.patch