summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2011-04-04 15:08:19 +0000
committerColin Watson <cjwatson@debian.org>2011-04-04 15:08:19 +0000
commit389d77b282606d6dbde1f9782b6447205bf551b0 (patch)
tree3743af6afdd730a83c6dd8bc6958dcb726fc0c3e
parent27a0dda2a41498d3da02ba77cab9d14e5ef5b075 (diff)
Link with -lc rather than /usr/lib/libc.so, fixing build failure on
multiarch systems (LP: #749094).
-rw-r--r--Makefile2
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/build-outside-glibc.patch4
-rw-r--r--debian/patches/db_dump185.patch2
4 files changed, 11 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 0677b78..f60578b 100644
--- a/Makefile
+++ b/Makefile
@@ -35,7 +35,7 @@ all: libdb1.so$(libdb.so-version) db_dump185/db_dump185
libdb1.so$(libdb.so-version): $(patsubst %,%.os,$(libdb1-routines))
$(CC) -Wl,-O1 -Wl,--version-script=Versions -Wl,-z,combreloc \
-Wl,-soname=libdb.so$(libdb.so-version) \
- -shared -o $@ $^ /usr/lib/libc.so
+ -shared -o $@ $^ -lc
db_dump185/db_dump185: db_dump185/db_dump185.c libdb1.so$(libdb.so-version)
$(CC) -I. -o $@ $< libdb1.so$(libdb.so-version)
diff --git a/debian/changelog b/debian/changelog
index 5d034ef..3fbc48f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+db1-compat (2.1.3-14) UNRELEASED; urgency=low
+
+ * Link with -lc rather than /usr/lib/libc.so, fixing build failure on
+ multiarch systems (LP: #749094).
+
+ -- Colin Watson <cjwatson@debian.org> Mon, 04 Apr 2011 16:07:32 +0100
+
db1-compat (2.1.3-13) unstable; urgency=low
* Convert to source format 3.0 (quilt) and DEP-3 patch tagging.
diff --git a/debian/patches/build-outside-glibc.patch b/debian/patches/build-outside-glibc.patch
index 7df7f12..a7b41de 100644
--- a/debian/patches/build-outside-glibc.patch
+++ b/debian/patches/build-outside-glibc.patch
@@ -1,7 +1,7 @@
Description: Modify build system to work outside glibc
Author: Colin Watson <cjwatson@debian.org>
Forwarded: no
-Last-Update: 2010-03-26
+Last-Update: 2011-04-04
Index: b/Makefile
===================================================================
@@ -77,7 +77,7 @@ Index: b/Makefile
+libdb1.so$(libdb.so-version): $(patsubst %,%.os,$(libdb1-routines))
+ $(CC) -Wl,-O1 -Wl,--version-script=Versions -Wl,-z,combreloc \
+ -Wl,-soname=libdb.so$(libdb.so-version) \
-+ -shared -o $@ $^ /usr/lib/libc.so
++ -shared -o $@ $^ -lc
+
+clean:
+ rm -f $(patsubst %,%.o,$(libdb1-routines))
diff --git a/debian/patches/db_dump185.patch b/debian/patches/db_dump185.patch
index a2249ba..c5f45e6 100644
--- a/debian/patches/db_dump185.patch
+++ b/debian/patches/db_dump185.patch
@@ -20,7 +20,7 @@ Index: b/Makefile
$(CC) $(CPPFLAGS) $(CFLAGS) -c -g -o $@ $<
@@ -37,7 +37,11 @@
-Wl,-soname=libdb.so$(libdb.so-version) \
- -shared -o $@ $^ /usr/lib/libc.so
+ -shared -o $@ $^ -lc
+db_dump185/db_dump185: db_dump185/db_dump185.c libdb1.so$(libdb.so-version)
+ $(CC) -I. -o $@ $< libdb1.so$(libdb.so-version)