summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2016-03-05 15:50:33 +0000
committerSimon McVittie <smcv@debian.org>2016-03-05 15:50:33 +0000
commitc729593c36c745f99daa02abb955a19737bf37cb (patch)
tree11812d0b6a92820c5f7f5a7531811f67c1b0ebfb /Makefile.am
parent01ecf02c749f7bddb15f57aae26e9e064db0240f (diff)
Move dbus-python.h to a dbus subdirectory
This means we can consistently #include <dbus/dbus-python.h>, either in-tree or out-of-tree. Signed-off-by: Simon McVittie <smcv@debian.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 3a821fa..bdfa56a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -141,8 +141,9 @@ dbus_py_test_la_LDFLAGS = \
$(NULL)
dbus_py_test_la_LIBADD = $(DBUS_LIBS)
dbus_py_test_la_SOURCES = \
+ include/dbus/dbus-python.h \
test/dbus_py_test.c \
- $(top_srcdir)/include/dbus-python.h
+ $(NULL)
# === dbus package ===
@@ -181,7 +182,7 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = dbus-python.pc
dbusincludedir = $(includedir)/dbus-1.0/dbus
-dbusinclude_HEADERS = include/dbus-python.h
+dbusinclude_HEADERS = include/dbus/dbus-python.h
# === Tests ===