summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2010-02-18 17:35:32 +0000
committerSimon McVittie <smcv@debian.org>2010-02-18 17:35:32 +0000
commitc91476085faaf7456c5b67e431c11b153b3c8762 (patch)
tree7ec6c081592d5d16750e4e08d7944e2c213c22c3 /configure.ac
parent65838e33fc871a8cf4b18541a6b0a59af2951eb2 (diff)
Use telepathy-glib's macros for desirable and undesirable compiler warnings
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 16 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index b8d64fb..3f046c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -144,16 +144,22 @@ AC_CHECK_LIB([dbus-1], [dbus_watch_get_unix_fd],
[Define if libdbus-1 has dbus_watch_get_unix_fd])],
[:], [$DBUS_LIBS])
-dnl add required cflags ...
-JH_ADD_CFLAG([-Wall])
-JH_ADD_CFLAG([-Wextra])
-JH_ADD_CFLAG([-Wno-missing-field-initializers])
-JH_ADD_CFLAG([-Wdeclaration-after-statement])
-JH_ADD_CFLAG([-Wshadow])
-JH_ADD_CFLAG([-Wstrict-prototypes])
-JH_ADD_CFLAG([-Wmissing-prototypes])
-JH_ADD_CFLAG([-Wmissing-declarations])
-JH_ADD_CFLAG([-Wdeprecated-declarations])
+TP_COMPILER_WARNINGS([CFLAGS], [test] dbus_python_released [= 0],
+ [all \
+ extra \
+ declaration-after-statement \
+ deprecated-declarations \
+ shadow \
+ strict-prototypes \
+ missing-prototypes \
+ missing-declarations \
+ sign-compare \
+ nested-externs \
+ pointer-arith \
+ format-security \
+ init-self],
+ [missing-field-initializers])
+
JH_ADD_CFLAG([-std=c9x])
JH_ADD_CFLAG([-fno-strict-aliasing])