summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-01-29 09:43:56 +0000
committerSimon McVittie <smcv@collabora.com>2018-01-29 09:43:56 +0000
commit28098f2c7c23bdef9247c5dfbb8437ca3f03dac4 (patch)
treef87cbac1f0a97c848f0450b6131350f273c98aa4 /configure.ac
parent8d0bc022242a89b1d31b2be0aa9e4d570179e3cc (diff)
Integrate dbus-gmain
Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 16a0c4b..40754a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -187,7 +187,7 @@ AM_CONDITIONAL([ENABLE_API_DOCS], [test "$enable_api_docs" != no])
AM_CONDITIONAL([ENABLE_DOCS], [test "$enable_html_docs" != no])
PKG_CHECK_MODULES(DBUS, [dbus-1 >= 1.6])
-PKG_CHECK_MODULES(DBUS_GLIB, [dbus-glib-1 >= 0.70])
+PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.40])
AX_COMPILER_FLAGS([WARN_CFLAGS],
[WARN_LDFLAGS], [],
@@ -216,8 +216,14 @@ AC_ARG_ENABLE([coding-style-checks],
[ENABLE_CODING_STYLE_CHECKS=$enableval],
[ENABLE_CODING_STYLE_CHECKS=$ax_is_release])
+# Make dbus-gmain submodule part of dbus-python's namespace
+AH_BOTTOM([
+#define DBUS_GMAIN_FUNCTION_NAME(name) _dbus_py_glib_ ## name
+])
+
AC_CONFIG_FILES([
Makefile
+ dbus-gmain/Makefile
dbus-python.pc
])
AC_OUTPUT