summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2015-12-06 17:46:21 +0000
committerSimon McVittie <smcv@debian.org>2015-12-06 17:46:21 +0000
commitb95a7f0f596e3e3d000c3756bb520d28b127d5e1 (patch)
tree706f048532efb395836aa782484fedc0aad43721 /configure.ac
parentf8379493b1c413d7b583025d47a38f042b710d89 (diff)
Simplify testing by using dbus-run-session and Automake "log compiler"
Fall back to Telepathy's old with-session-bus.sh script if dbus doesn't have dbus-run-session (versions < 1.8). Also run most of the tests individually, instead of under run-test.sh.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index abedfd7..e5bbc83 100644
--- a/configure.ac
+++ b/configure.ac
@@ -148,6 +148,11 @@ AS_IF([test "${enable_api_docs}" != no],
])
])
+AC_ARG_VAR([DBUS_RUN_SESSION],
+ [The dbus-run-session tool from dbus 1.8 or later])
+AC_PATH_PROG([DBUS_RUN_SESSION], [dbus-run-session], [false])
+AM_CONDITIONAL([HAVE_DBUS_RUN_SESSION], [test "$DBUS_RUN_SESSION" != false])
+
RST2HTMLFLAGS=
if test "${enable_html_docs}" != no; then
AC_CHECK_PROGS([RST2HTML], [rst2html rst2html.py], [])