summaryrefslogtreecommitdiff
path: root/dbus_python.egg-info
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2018-05-04 17:17:06 +0100
committerSimon McVittie <smcv@debian.org>2018-05-04 17:17:06 +0100
commitfbf7b875d784851f4f3f234f0e4ce8e05d3a515d (patch)
treed2340d42eac8f1c03b0b116186b749dfa1281ef5 /dbus_python.egg-info
parent0bbec9dde2adf7d49ba665a0f43fd4db200484f0 (diff)
parentb7f3f7757c28fdc25ce413ccb3c2c6f7e16cbb51 (diff)
New upstream version 1.2.8
Diffstat (limited to 'dbus_python.egg-info')
-rw-r--r--dbus_python.egg-info/PKG-INFO53
-rw-r--r--dbus_python.egg-info/SOURCES.txt171
-rw-r--r--dbus_python.egg-info/dependency_links.txt1
-rw-r--r--dbus_python.egg-info/top_level.txt3
4 files changed, 228 insertions, 0 deletions
diff --git a/dbus_python.egg-info/PKG-INFO b/dbus_python.egg-info/PKG-INFO
new file mode 100644
index 0000000..f450eca
--- /dev/null
+++ b/dbus_python.egg-info/PKG-INFO
@@ -0,0 +1,53 @@
+Metadata-Version: 1.2
+Name: dbus-python
+Version: 1.2.8
+Summary: Python bindings for libdbus
+Home-page: http://www.freedesktop.org/wiki/Software/DBusBindings/#python
+Maintainer: The D-Bus maintainers
+Maintainer-email: dbus@lists.freedesktop.org
+License: Expat (MIT/X11)
+Download-URL: http://dbus.freedesktop.org/releases/dbus-python/
+Description: =======================================
+ dbus-python_: Python bindings for D-Bus
+ =======================================
+
+ .. _dbus-python: http://www.freedesktop.org/wiki/Software/DBusBindings#python
+
+ dbus-python is the original Python binding for ``dbus``, the reference
+ implementation of the D-Bus protocol.
+
+ Online documentation can be found at
+ <http://dbus.freedesktop.org/doc/dbus-python/>.
+
+ Problems and alternatives
+ =========================
+
+ dbus-python might not be the best D-Bus binding for you to use. dbus-python
+ does not follow the principle of "In the face of ambiguity, refuse the
+ temptation to guess", and can't be changed to not do so without seriously
+ breaking compatibility.
+
+ In addition, it uses libdbus (which has known problems with multi-threaded
+ use) and attempts to be main-loop-agnostic (which means you have to select
+ a suitable main loop for your application).
+
+ Alternative ways to get your Python code onto D-Bus include:
+
+ * GDBus, part of the GIO module of `GLib`_, via GObject-Introspection and
+ `PyGI`_ (uses the GLib main loop and object model)
+
+ * QtDBus, part of `Qt`_, via `PyQt`_ (uses the Qt main loop and object model)
+
+ .. _GLib: http://developer.gnome.org/glib/
+ .. _PyGI: https://live.gnome.org/PyGObject
+ .. _Qt: https://qt.nokia.com/
+ .. _PyQT: http://www.riverbankcomputing.co.uk/software/pyqt/intro
+
+Platform: UNKNOWN
+Classifier: Development Status :: 7 - Inactive
+Classifier: License :: OSI Approved :: MIT License
+Classifier: Programming Language :: C
+Classifier: Programming Language :: Python :: 2
+Classifier: Programming Language :: Python :: 3
+Classifier: Programming Language :: Python :: Implementation :: CPython
+Classifier: Topic :: Software Development :: Object Brokering
diff --git a/dbus_python.egg-info/SOURCES.txt b/dbus_python.egg-info/SOURCES.txt
new file mode 100644
index 0000000..93abb63
--- /dev/null
+++ b/dbus_python.egg-info/SOURCES.txt
@@ -0,0 +1,171 @@
+.travis.yml
+.version
+AUTHORS
+COPYING
+ChangeLog
+INSTALL
+MANIFEST
+MANIFEST.in
+Makefile.am
+Makefile.in
+NEWS
+PKG-INFO
+README
+aclocal.m4
+build-aux/compile
+build-aux/config.guess
+build-aux/config.sub
+build-aux/depcomp
+build-aux/install-sh
+build-aux/ltmain.sh
+build-aux/missing
+build-aux/py-compile
+build-aux/tap-driver.sh
+build-aux/test-driver
+config.h.in
+configure
+configure.ac
+dbus-gmain/AUTHORS
+dbus-gmain/CONTRIBUTING
+dbus-gmain/COPYING
+dbus-gmain/Makefile.am
+dbus-gmain/Makefile.in
+dbus-gmain/README
+dbus-gmain/dbus-gmain.c
+dbus-gmain/dbus-gmain.h
+dbus-gmain/tests/30574.c
+dbus-gmain/tests/test-thread-client.c
+dbus-gmain/tests/test-thread-server.c
+dbus-gmain/tests/test-thread.h
+dbus-gmain/tests/util.c
+dbus-gmain/tests/util.h
+dbus-python.pc.in
+dbus/__init__.py
+dbus/_compat.py
+dbus/_dbus.py
+dbus/_expat_introspect_parser.py
+dbus/bus.py
+dbus/connection.py
+dbus/decorators.py
+dbus/exceptions.py
+dbus/gi_service.py
+dbus/glib.py
+dbus/gobject_service.py
+dbus/lowlevel.py
+dbus/mainloop/__init__.py
+dbus/mainloop/glib.py
+dbus/proxies.py
+dbus/server.py
+dbus/service.py
+dbus/types.py
+dbus_bindings/abstract.c
+dbus_bindings/bus.c
+dbus_bindings/bytes.c
+dbus_bindings/compat-internal.h
+dbus_bindings/conn-internal.h
+dbus_bindings/conn-methods.c
+dbus_bindings/conn.c
+dbus_bindings/containers.c
+dbus_bindings/dbus_bindings-internal.h
+dbus_bindings/debug.c
+dbus_bindings/exceptions.c
+dbus_bindings/float.c
+dbus_bindings/generic.c
+dbus_bindings/int.c
+dbus_bindings/libdbusconn.c
+dbus_bindings/mainloop.c
+dbus_bindings/message-append.c
+dbus_bindings/message-get-args.c
+dbus_bindings/message-internal.h
+dbus_bindings/message.c
+dbus_bindings/module.c
+dbus_bindings/pending-call.c
+dbus_bindings/server.c
+dbus_bindings/signature.c
+dbus_bindings/string.c
+dbus_bindings/types-internal.h
+dbus_bindings/unixfd.c
+dbus_bindings/validation.c
+dbus_glib_bindings/module.c
+dbus_python.egg-info/PKG-INFO
+dbus_python.egg-info/SOURCES.txt
+dbus_python.egg-info/dependency_links.txt
+dbus_python.egg-info/top_level.txt
+doc/API_CHANGES.txt
+doc/HACKING.txt
+doc/PY3PORT.txt
+doc/_static/.gitignore
+doc/conf.py
+doc/dbus.bus.rst
+doc/dbus.connection.rst
+doc/dbus.decorators.rst
+doc/dbus.exceptions.rst
+doc/dbus.gi_service.rst
+doc/dbus.glib.rst
+doc/dbus.gobject_service.rst
+doc/dbus.lowlevel.rst
+doc/dbus.mainloop.rst
+doc/dbus.proxies.rst
+doc/dbus.rst
+doc/dbus.server.rst
+doc/dbus.service.rst
+doc/dbus.types.rst
+doc/index.rst
+doc/news.rst
+doc/redirects
+doc/redirects.py
+doc/tutorial.txt
+examples/example-async-client.py
+examples/example-client.py
+examples/example-service.py
+examples/example-signal-emitter.py
+examples/example-signal-recipient.py
+examples/gconf-proxy-client.py
+examples/gconf-proxy-service2.py
+examples/list-system-services.py
+examples/unix-fd-client.py
+examples/unix-fd-service.py
+include/dbus/dbus-python.h
+m4/ax_append_compile_flags.m4
+m4/ax_append_flag.m4
+m4/ax_append_link_flags.m4
+m4/ax_check_compile_flag.m4
+m4/ax_check_link_flag.m4
+m4/ax_compiler_flags.m4
+m4/ax_compiler_flags_cflags.m4
+m4/ax_compiler_flags_gir.m4
+m4/ax_compiler_flags_ldflags.m4
+m4/ax_generate_changelog.m4
+m4/ax_is_release.m4
+m4/ax_python_devel.m4
+m4/ax_python_module.m4
+m4/ax_require_defined.m4
+m4/libtool.m4
+m4/ltoptions.m4
+m4/ltsugar.m4
+m4/ltversion.m4
+m4/lt~obsolete.m4
+m4/pkg.m4
+setup.py
+test/TestSuitePythonService.service.in
+test/cross-test-client.py
+test/cross-test-server.py
+test/crosstest.py
+test/dbus_py_test.c
+test/import-repeatedly.c
+test/run-test.sh
+test/test-client.py
+test/test-exception-py2.py
+test/test-exception-py3.py
+test/test-p2p.py
+test/test-service.py
+test/test-signals.py
+test/test-standalone.py
+test/test-unusable-main-loop.py
+test/tmp-session-bus.conf.in
+test/wait-for-name.py
+test/with-session-bus.sh
+tools/check-c-style.sh
+tools/check-coding-style.mk
+tools/check-py-style.sh
+tools/check-whitespace.sh
diff --git a/dbus_python.egg-info/dependency_links.txt b/dbus_python.egg-info/dependency_links.txt
new file mode 100644
index 0000000..8b13789
--- /dev/null
+++ b/dbus_python.egg-info/dependency_links.txt
@@ -0,0 +1 @@
+
diff --git a/dbus_python.egg-info/top_level.txt b/dbus_python.egg-info/top_level.txt
new file mode 100644
index 0000000..7d64792
--- /dev/null
+++ b/dbus_python.egg-info/top_level.txt
@@ -0,0 +1,3 @@
+_dbus_bindings
+_dbus_glib_bindings
+dbus