summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/rules8
2 files changed, 14 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a7e497f..94a5910 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+dbus-python (1.3.2-3) unstable; urgency=medium
+
+ * Increase an arbitrary test timeout to avoid intermittent FTBFS on
+ slower buildds such as alpha, mips64el and riscv64 (Closes: #1024210)
+
+ -- Simon McVittie <smcv@debian.org> Fri, 25 Nov 2022 11:28:44 +0000
+
dbus-python (1.3.2-2) unstable; urgency=medium
[ Debian Janitor ]
diff --git a/debian/rules b/debian/rules
index 65e6f9b..410cf78 100755
--- a/debian/rules
+++ b/debian/rules
@@ -65,7 +65,13 @@ override_dh_auto_test-arch:
LC_ALL=C.UTF-8 \
PYTHON=/usr/bin/python$$x \
VERBOSE=1 \
- dh_auto_test --no-parallel --arch --builddirectory=build-$$x; \
+ dh_auto_test \
+ --no-parallel \
+ --arch \
+ --builddirectory=build-$$x \
+ -- \
+ --timeout-multiplier 3 \
+ ; \
done
override_dh_auto_test-indep:
: